<!doctype html>
<html lang="en-US" class="no-js-disabled">
<head>
	<meta charset="UTF-8"/>
	<meta name="viewport" content="width=device-width, initial-scale=1"/>
	<link rel="profile" href="https://gmpg.org/xfn/11"/>
	<title>Video: Inside the VFX and SFX of &#039;Shang-Chi&#039; - befores &amp; afters</title>
<meta name='robots' content='max-image-preview:large' />
<!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="P2kQwk9rkrt1yZ1KVkOcp4IHUUOJ1DUp1Zz7NQ_WkEg" />
<script>window._wca = window._wca || [];</script>

<!-- This site is optimized with the Yoast SEO Premium plugin v13.4.1 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="The VFX team behind the film discuss the face replacements, bus shots and dragon and water sims in a new video interview."/>
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/>
<link rel="canonical" href="https://beforesandafters.com/2022/01/24/video-inside-the-vfx-and-sfx-of-shang-chi/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Video: Inside the VFX and SFX of &#039;Shang-Chi&#039; - befores &amp; afters" />
<meta property="og:description" content="The VFX team behind the film discuss the face replacements, bus shots and dragon and water sims in a new video interview." />
<meta property="og:url" content="https://beforesandafters.com/2022/01/24/video-inside-the-vfx-and-sfx-of-shang-chi/" />
<meta property="og:site_name" content="befores &amp; afters" />
<meta property="article:publisher" content="https://www.facebook.com/Befores-Afters-829036060774243/" />
<meta property="article:tag" content="Christopher Townsend" />
<meta property="article:tag" content="Dan Oliver" />
<meta property="article:tag" content="Joe Farrell" />
<meta property="article:tag" content="Sean Walker" />
<meta property="article:tag" content="Shang-Chi and the Legend of the Ten Rings" />
<meta property="article:tag" content="Weta Digital" />
<meta property="article:section" content="Articles" />
<meta property="article:published_time" content="2022-01-24T10:58:15+00:00" />
<meta property="og:image" content="https://beforesandafters.com/wp-content/uploads/2022/01/SBT-32455-1.jpg" />
<meta property="og:image:secure_url" content="https://beforesandafters.com/wp-content/uploads/2022/01/SBT-32455-1.jpg" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="798" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="The VFX team behind the film discuss the face replacements, bus shots and dragon and water sims in a new video interview." />
<meta name="twitter:title" content="Video: Inside the VFX and SFX of &#039;Shang-Chi&#039; - befores &amp; afters" />
<meta name="twitter:site" content="@ianfailes" />
<meta name="twitter:image" content="https://beforesandafters.com/wp-content/uploads/2022/01/SBT-32455-1.jpg" />
<meta name="twitter:creator" content="@ianfailes" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://beforesandafters.com/#organization","name":"befores & afters","url":"https://beforesandafters.com/","sameAs":["https://www.facebook.com/Befores-Afters-829036060774243/","http://instagram.com/ianfailes","https://www.linkedin.com/in/ian-failes-17154b4/","https://www.youtube.com/channel/UCDYWiGfmyQNT5tEdmiKpDKg","https://twitter.com/ianfailes"],"logo":{"@type":"ImageObject","@id":"https://beforesandafters.com/#logo","inLanguage":"en-US","url":"https://beforesandafters.com/wp-content/uploads/2020/05/beforesandafters.jpg","width":960,"height":720,"caption":"befores & afters"},"image":{"@id":"https://beforesandafters.com/#logo"}},{"@type":"WebSite","@id":"https://beforesandafters.com/#website","url":"https://beforesandafters.com/","name":"befores &amp; afters","inLanguage":"en-US","description":"visual effects magazine","publisher":{"@id":"https://beforesandafters.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://beforesandafters.com/?s={search_term_string}","query-input":"required name=search_term_string"}]},{"@type":"ImageObject","@id":"https://beforesandafters.com/2022/01/24/video-inside-the-vfx-and-sfx-of-shang-chi/#primaryimage","inLanguage":"en-US","url":"https://beforesandafters.com/wp-content/uploads/2022/01/SBT-32455-1.jpg","width":1200,"height":798},{"@type":"WebPage","@id":"https://beforesandafters.com/2022/01/24/video-inside-the-vfx-and-sfx-of-shang-chi/#webpage","url":"https://beforesandafters.com/2022/01/24/video-inside-the-vfx-and-sfx-of-shang-chi/","name":"Video: Inside the VFX and SFX of &#039;Shang-Chi&#039; - befores &amp; afters","isPartOf":{"@id":"https://beforesandafters.com/#website"},"inLanguage":"en-US","primaryImageOfPage":{"@id":"https://beforesandafters.com/2022/01/24/video-inside-the-vfx-and-sfx-of-shang-chi/#primaryimage"},"datePublished":"2022-01-24T10:58:15+00:00","dateModified":"2022-01-24T10:58:15+00:00","description":"The VFX team behind the film discuss the face replacements, bus shots and dragon and water sims in a new video interview.","breadcrumb":{"@id":"https://beforesandafters.com/2022/01/24/video-inside-the-vfx-and-sfx-of-shang-chi/#breadcrumb"},"potentialAction":[{"@type":"ReadAction","target":["https://beforesandafters.com/2022/01/24/video-inside-the-vfx-and-sfx-of-shang-chi/"]}]},{"@type":"BreadcrumbList","@id":"https://beforesandafters.com/2022/01/24/video-inside-the-vfx-and-sfx-of-shang-chi/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://beforesandafters.com/","url":"https://beforesandafters.com/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://beforesandafters.com/2022/01/24/video-inside-the-vfx-and-sfx-of-shang-chi/","url":"https://beforesandafters.com/2022/01/24/video-inside-the-vfx-and-sfx-of-shang-chi/","name":"Video: Inside the VFX and SFX of &#8216;Shang-Chi&#8217;"}}]},{"@type":"Article","@id":"https://beforesandafters.com/2022/01/24/video-inside-the-vfx-and-sfx-of-shang-chi/#article","isPartOf":{"@id":"https://beforesandafters.com/2022/01/24/video-inside-the-vfx-and-sfx-of-shang-chi/#webpage"},"author":{"@id":"https://beforesandafters.com/#/schema/person/a05bbb1beae784a05c2b92006d5f966d"},"headline":"Video: Inside the VFX and SFX of &#8216;Shang-Chi&#8217;","datePublished":"2022-01-24T10:58:15+00:00","dateModified":"2022-01-24T10:58:15+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://beforesandafters.com/2022/01/24/video-inside-the-vfx-and-sfx-of-shang-chi/#webpage"},"publisher":{"@id":"https://beforesandafters.com/#organization"},"image":{"@id":"https://beforesandafters.com/2022/01/24/video-inside-the-vfx-and-sfx-of-shang-chi/#primaryimage"},"keywords":"Christopher Townsend,Dan Oliver,Joe Farrell,Sean Walker,Shang-Chi and the Legend of the Ten Rings,Weta Digital","articleSection":"Articles","inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://beforesandafters.com/2022/01/24/video-inside-the-vfx-and-sfx-of-shang-chi/#respond"]}]},{"@type":["Person"],"@id":"https://beforesandafters.com/#/schema/person/a05bbb1beae784a05c2b92006d5f966d","name":"Ian Failes","sameAs":[]}]}</script>
<!-- / Yoast SEO Premium plugin. -->

<link rel='dns-prefetch' href='//stats.wp.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel='dns-prefetch' href='//widgets.wp.com' />
<link rel="alternate" type="application/rss+xml" title="befores &amp; afters &raquo; Feed" href="https://beforesandafters.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="befores &amp; afters &raquo; Comments Feed" href="https://beforesandafters.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="befores &amp; afters &raquo; Video: Inside the VFX and SFX of &#8216;Shang-Chi&#8217; Comments Feed" href="https://beforesandafters.com/2022/01/24/video-inside-the-vfx-and-sfx-of-shang-chi/feed/" />
		<script>
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/beforesandafters.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.8.3"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<!-- beforesandafters.com is managing ads with Advanced Ads – https://wpadvancedads.com/ --><script id="befor-ready">
			window.advanced_ads_ready=function(e,a){a=a||"complete";var d=function(e){return"interactive"===a?"loading"!==e:"complete"===e};d(document.readyState)?e():document.addEventListener("readystatechange",(function(a){d(a.target.readyState)&&e()}),{once:"interactive"===a})},window.advanced_ads_ready_queue=window.advanced_ads_ready_queue||[];		</script>
		<style>
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://beforesandafters.com/wp-includes/css/dist/block-library/style.min.css?ver=5.8.3' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='themezee-magazine-blocks-css'  href='https://beforesandafters.com/wp-content/plugins/themezee-magazine-blocks/assets/css/themezee-magazine-blocks.css?ver=1.1.3' media='all' />
<link rel='stylesheet' id='mediaelement-css'  href='https://beforesandafters.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.16' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='https://beforesandafters.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=5.8.3' media='all' />
<link rel='stylesheet' id='wc-blocks-vendors-style-css'  href='https://beforesandafters.com/wp-content/plugins/woocommerce/packages/woocommerce-blocks/build/wc-blocks-vendors-style.css?ver=6.5.2' media='all' />
<link rel='stylesheet' id='wc-blocks-style-css'  href='https://beforesandafters.com/wp-content/plugins/woocommerce/packages/woocommerce-blocks/build/wc-blocks-style.css?ver=6.5.2' media='all' />
<link rel='stylesheet' id='wp-components-css'  href='https://beforesandafters.com/wp-includes/css/dist/components/style.min.css?ver=5.8.3' media='all' />
<link rel='stylesheet' id='wp-block-editor-css'  href='https://beforesandafters.com/wp-includes/css/dist/block-editor/style.min.css?ver=5.8.3' media='all' />
<link rel='stylesheet' id='wp-nux-css'  href='https://beforesandafters.com/wp-includes/css/dist/nux/style.min.css?ver=5.8.3' media='all' />
<link rel='stylesheet' id='wp-reusable-blocks-css'  href='https://beforesandafters.com/wp-includes/css/dist/reusable-blocks/style.min.css?ver=5.8.3' media='all' />
<link rel='stylesheet' id='wp-editor-css'  href='https://beforesandafters.com/wp-includes/css/dist/editor/style.min.css?ver=5.8.3' media='all' />
<link rel='stylesheet' id='drop_shadow_block-style-css-css'  href='https://beforesandafters.com/wp-content/plugins/drop-shadow-boxes/block/blocks.style.build.css?ver=1.7.4' media='all' />
<link rel='stylesheet' id='simple-banner-style-css'  href='https://beforesandafters.com/wp-content/plugins/simple-banner/simple-banner.css?ver=2.10.6' media='all' />
<link rel='stylesheet' id='virp-style-css'  href='https://beforesandafters.com/wp-content/plugins/vi-random-posts-widget/css/virp-frontend.css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://beforesandafters.com/wp-content/plugins/vi-random-posts-widget/css/font-awesome.css' media='all' />
<link rel='stylesheet' id='woocommerce-layout-css'  href='https://beforesandafters.com/wp-content/plugins/woocommerce/assets/css/woocommerce-layout.css?ver=6.1.1' media='all' />
<style id='woocommerce-layout-inline-css'>

	.infinite-scroll .woocommerce-pagination {
		display: none;
	}
</style>
<link rel='stylesheet' id='woocommerce-smallscreen-css'  href='https://beforesandafters.com/wp-content/plugins/woocommerce/assets/css/woocommerce-smallscreen.css?ver=6.1.1' media='only screen and (max-width: 768px)' />
<link rel='stylesheet' id='woocommerce-general-css'  href='https://beforesandafters.com/wp-content/plugins/woocommerce/assets/css/woocommerce.css?ver=6.1.1' media='all' />
<style id='woocommerce-inline-inline-css'>
.woocommerce form .form-row .required { visibility: visible; }
</style>
<link rel='stylesheet' id='wcz-frontend-css'  href='https://beforesandafters.com/wp-content/plugins/woocustomizer/assets/css/frontend.css?ver=2.3.7' media='all' />
<link rel='stylesheet' id='wp-date-remover-css'  href='https://beforesandafters.com/wp-content/plugins/wp-date-remover/public/css/wp-date-remover-public.css?ver=1.0.0' media='all' />
<link rel='stylesheet' id='extendify-sdk-utility-classes-css'  href='https://beforesandafters.com/wp-content/plugins/wp-mail-logging/lib/vendor/redux-framework/redux-core/extendify-sdk/public/build/extendify-utilities.css?ver=11.7' media='all' />
<link rel='stylesheet' id='mc4wp-form-themes-css'  href='https://beforesandafters.com/wp-content/plugins/mailchimp-for-wp/assets/css/form-themes.css?ver=4.8.6' media='all' />
<link rel='stylesheet' id='exs-style-css'  href='https://beforesandafters.com/wp-content/themes/exs-pro/assets/css/min/main-1200.css?ver=1.8.4' media='all' />
<link rel='stylesheet' id='exs-menu-desktop-type-style-css'  href='https://beforesandafters.com/wp-content/themes/exs-pro/assets/css/min/menu-desktop3.css?ver=1.8.4' media='all and (min-width: 1200px)' />
<link rel='stylesheet' id='exs-shop-style-css'  href='https://beforesandafters.com/wp-content/themes/exs-pro/assets/css/min/shop.css?ver=1.8.4' media='all' />
<link rel='stylesheet' id='exs-amp-style-css'  href='https://beforesandafters.com/wp-content/themes/exs-pro/assets/css/min/amp.css?ver=1.8.4' media='all' />
<link rel='stylesheet' id='wp-calypso-bridge-masterbar-css'  href='https://beforesandafters.com/wp-content/mu-plugins/wpcomsh/vendor/automattic/wc-calypso-bridge/store-on-wpcom/assets/css/masterbar.css?ver=1.8.4' media='all' />
<link rel='stylesheet' id='recent-posts-widget-with-thumbnails-public-style-css'  href='https://beforesandafters.com/wp-content/plugins/recent-posts-widget-with-thumbnails/public.css?ver=7.1.1' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='open-sans-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400italic%2C600italic%2C300%2C400%2C600&#038;subset=latin%2Clatin-ext&#038;display=fallback&#038;ver=5.8.3' media='all' />
<style id='wcz-customizer-custom-css-inline-css'>
body.woocommerce .woocommerce-breadcrumb{display:none !important;}body.post-type-archive-product header.woocommerce-products-header .woocommerce-products-header__title{display:none !important;}body.woocommerce form.woocommerce-ordering{display:none !important;}body.woocommerce p.woocommerce-result-count{display:none !important;}body.wcz-btns.wcz-woocommerce ul.products li.product a.button,
					body.wcz-btns.wcz-woocommerce .related.products ul.products li.product a.button,
                    body.wcz-btns.wcz-woocommerce.single-product div.product form.cart .button,
                    body.wcz-btns.wcz-woocommerce.wcz-wooblocks ul.wc-block-grid__products li.wc-block-grid__product .add_to_cart_button{padding:12px 24px 13px !important;}body.woocommerce.wcz-woocommerce ul.products li.product .woocommerce-loop-product__title,
					body.wcz-woocommerce .products .product .woocommerce-loop-product__title,
                    body.wcz-wooblocks ul.wc-block-grid__products li.wc-block-grid__product .wc-block-grid__product-title a{color:#000000 !important;}body.woocommerce.wcz-woocommerce ul.products li.product .price,
					body.wcz-woocommerce .products .product .price,
                    body.wcz-wooblocks ul.wc-block-grid__products li.wc-block-grid__product .wc-block-grid__product-price{font-size:22px !important;}body.woocommerce.wcz-woocommerce ul.products li.product .price,
					body.wcz-woocommerce .products .product .price,
                    body.wcz-wooblocks ul.wc-block-grid__products li.wc-block-grid__product .wc-block-grid__product-price__value,
                    body.wcz-wooblocks ul.wc-block-grid__products li.wc-block-grid__product .wc-block-grid__product-price ins{color:#000000 !important;}body.wcz-wooblocks ul.wc-block-grid__products li.wc-block-grid__product .wc-block-grid__product-price del{color:rgba(0, 0, 0, 0.45);}body.single-product .woocommerce-breadcrumb{display:none !important;}body.single-product .product_meta .posted_in{display:none !important;}body.single-product .product_meta .tagged_as{display:none !important;}body.single-product section.upsells{display:none !important;}.single-product section.related.products{display:none !important;}body.single-product a.wcz-continue{margin-bottom:20px;}body.single-product.wcz-woocommerce div.product .product_title{color:#000000 !important;}body.single-product.wcz-woocommerce div.product p.price{font-size:23px !important;}body.single-product.wcz-woocommerce div.product p.price,
					body.single-product.wcz-woocommerce div.product .woocommerce-variation-price span.price{color:#000000 !important;}body.woocommerce-cart a.button.wcz-bts-btn{background-color:#000000 !important;color:#ffffff !important;}body.woocommerce-cart .wc-proceed-to-checkout a.button.checkout-button{background-color:#000000 !important;color:#ffffff !important;}
</style>
<style id='exs-style-inline-inline-css'>
:root{--colorLight:#ffffff;--colorLightRGB:255,255,255;--colorFont:#000000;--colorFontMuted:#666666;--colorBackground:#f7f7f7;--colorBorder:#e1e1e1;--colorDark:#000000;--colorDarkMuted:#000000;--colorMain:#000000;--colorMain2:#000000;--colorMain3:#000000;--colorMain4:#000000;--btn-fs:.92em;--socialGap:1em;--wli-my:.5em;--sb-gap:2.5rem;--sideNavWidth:290px;--sideNavPX:20px;--mobileNavWidth:290px;--mobileNavPX:20px;}
</style>
<link rel='stylesheet' id='jetpack_css-css'  href='https://beforesandafters.com/wp-content/plugins/jetpack/css/jetpack.css?ver=10.6-a.3' media='all' />
<script id='jetpack_related-posts-js-extra'>
var related_posts_js_options = {"post_heading":"h4"};
</script>
<script src='https://beforesandafters.com/wp-content/plugins/jetpack/_inc/build/related-posts/related-posts.min.js?ver=20211209' id='jetpack_related-posts-js'></script>
<script src='https://beforesandafters.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script src='https://beforesandafters.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script id='simple-banner-script-js-extra'>
var simpleBannerScriptParams = {"version":"2.10.6","hide_simple_banner":"yes","simple_banner_position":"","header_margin":"","header_padding":"","simple_banner_text":"Get the latest issue of <a href=\"https:\/\/beforesandafters.com\/shop\/\">befores & afters magazine.<\/a>","pro_version_enabled":"","disabled_on_current_page":"","debug_mode":"","id":"77370","disabled_pages_array":[],"is_current_page_a_post":"1","disabled_on_posts":"","simple_banner_font_size":"14","simple_banner_color":"#000000","simple_banner_text_color":"#ffffff","simple_banner_link_color":"#ffeb00","simple_banner_close_color":"","simple_banner_custom_css":"","simple_banner_scrolling_custom_css":"","simple_banner_text_custom_css":"","simple_banner_button_css":"","site_custom_css":"","keep_site_custom_css":"","site_custom_js":"","keep_site_custom_js":"","wp_body_open_enabled":"","wp_body_open":"1","close_button_enabled":"on","close_button_expiration":"","close_button_cookie_set":""};
</script>
<script src='https://beforesandafters.com/wp-content/plugins/simple-banner/simple-banner.js?ver=2.10.6' id='simple-banner-script-js'></script>
<script src='https://beforesandafters.com/wp-content/plugins/wp-date-remover/public/js/wp-date-remover-public.js?ver=1.0.0' id='wp-date-remover-js'></script>
<script defer src='https://stats.wp.com/s-202204.js' id='woocommerce-analytics-js'></script>
<link rel="https://api.w.org/" href="https://beforesandafters.com/wp-json/" /><link rel="alternate" type="application/json" href="https://beforesandafters.com/wp-json/wp/v2/posts/77370" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://beforesandafters.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://beforesandafters.com/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='https://wp.me/par5YM-k7U' />
<link rel="alternate" type="application/json+oembed" href="https://beforesandafters.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fbeforesandafters.com%2F2022%2F01%2F24%2Fvideo-inside-the-vfx-and-sfx-of-shang-chi%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://beforesandafters.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fbeforesandafters.com%2F2022%2F01%2F24%2Fvideo-inside-the-vfx-and-sfx-of-shang-chi%2F&#038;format=xml" />
<style type="text/css">.simple-banner{display:none;}</style><style type="text/css">.simple-banner .simple-banner-text{font-size:14;}</style><style type="text/css">.simple-banner{background:#000000;}</style><style type="text/css">.simple-banner .simple-banner-text{color:#ffffff;}</style><style type="text/css">.simple-banner .simple-banner-text a{color:#ffeb00;}</style><style id="simple-banner-site-custom-css-dummy" type="text/css"></style><script id="simple-banner-site-custom-js-dummy" type="text/javascript"></script>		<script>
			var jabvfcr = {
				selector: "DIV.copyright",
				manipulation: "html",
				html: "© Copyright 2021 befores & afters."
			};
		</script>
		<meta name="framework" content="Redux 4.3.3" /><style type='text/css'>img#wpstats{display:none}</style>
		<noscript><style>.woocommerce-product-gallery{ opacity: 1 !important; }</style></noscript>
			<style type="text/css">
			.recentcomments a {
				display: inline !important;
				padding: 0 !important;
				margin: 0 !important;
			}

			table.recentcommentsavatartop img.avatar, table.recentcommentsavatarend img.avatar {
				border: 0px;
				margin: 0;
			}

			table.recentcommentsavatartop a, table.recentcommentsavatarend a {
				border: 0px !important;
				background-color: transparent !important;
			}

			td.recentcommentsavatarend, td.recentcommentsavatartop {
				padding: 0px 0px 1px 0px;
				margin: 0px;
			}

			td.recentcommentstextend {
				border: none !important;
				padding: 0px 0px 2px 10px;
			}

			.rtl td.recentcommentstextend {
				padding: 0px 10px 2px 0px;
			}

			td.recentcommentstexttop {
				border: none;
				padding: 0px 0px 0px 10px;
			}

			.rtl td.recentcommentstexttop {
				padding: 0px 10px 0px 0px;
			}
		</style>
		<style id="custom-background-css">
body.custom-background { background-color: #ffffff; }
</style>
	<link rel="amphtml" href="https://beforesandafters.com/2022/01/24/video-inside-the-vfx-and-sfx-of-shang-chi/?amp"><meta name="google-site-verification" content="P2kQwk9rkrt1yZ1KVkOcp4IHUUOJ1DUp1Zz7NQ_WkEg" />


<script  async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-7530686204223811" crossorigin="anonymous"></script><link rel="icon" href="https://beforesandafters.com/wp-content/uploads/2019/03/cropped-beforesafters-32x32.jpeg" sizes="32x32" />
<link rel="icon" href="https://beforesandafters.com/wp-content/uploads/2019/03/cropped-beforesafters-192x192.jpeg" sizes="192x192" />
<link rel="apple-touch-icon" href="https://beforesandafters.com/wp-content/uploads/2019/03/cropped-beforesafters-180x180.jpeg" />
<meta name="msapplication-TileImage" content="https://beforesandafters.com/wp-content/uploads/2019/03/cropped-beforesafters-270x270.jpeg" />
<style type="text/css" id="wp-custom-css">.grid-item article:hover .post-thumbnail img, .hfeed article:hover .post-thumbnail img {
    opacity: 1;
    -webkit-transform: none;
    transform: none;
}


.entry-content a {
color: blue;
}

a:hover {
  text-decoration: underline;
}</style><!-- Jetpack Google Analytics -->
			<script type='text/javascript'>
				var _gaq = _gaq || [];
				_gaq.push(['_setAccount', 'UA-140669838-1']);
_gaq.push(['_trackPageview']);
				(function() {
					var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
					ga.src = ('https:' === document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
					var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
				})();
			</script>
			<!-- End Jetpack Google Analytics -->
</head>
<body id="body" class="post-template-default single single-post postid-77370 single-format-standard custom-background wp-custom-logo theme-exs-pro woocommerce-no-js wcz-woocommerce wcz-btns wcz-btn-style-default wcz-wooblocks wcz-soldout-style-angle singular no-sidebar woo woocommerce title-hidden aa-prefix-befor-" itemtype="https://schema.org/Blog" itemscope="itemscope" data-nonce="1038322db9" data-ajax="https://beforesandafters.com/wp-admin/admin-ajax.php"
	>

<a id="skip_link" class="screen-reader-text skip-link" href="#main">Skip to content</a>
<div id="box" class="box-normal">
	<div id="top-wrap" class="container-960">	<header id="header"
	        data-bg="l"
			class="header header-1 l  menu-right    header-tall has-menu">
						<div class="container">
			<a class="logo logo-left with-image  px" href="https://beforesandafters.com/" rel="home" itemprop="url">
	<img width="86" height="100" src="https://beforesandafters.com/wp-content/uploads/2019/09/logo_100.jpg" class="attachment-full size-full" alt="befores &amp; afters" loading="lazy" data-attachment-id="3538" data-permalink="https://beforesandafters.com/logo_100/" data-orig-file="https://beforesandafters.com/wp-content/uploads/2019/09/logo_100.jpg" data-orig-size="86,100" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1552907665&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="logo_100" data-image-description="" data-image-caption="" data-medium-file="https://beforesandafters.com/wp-content/uploads/2019/09/logo_100.jpg" data-large-file="https://beforesandafters.com/wp-content/uploads/2019/09/logo_100.jpg" /></a><!-- .logo -->
			<div id="logo-align"></div>
			<div id="overlay"></div>
							<nav id="nav_top" class="top-nav" aria-label="Top Menu">
					<ul id="menu-primary" class="top-menu menu-low-items"><li id="menu-item-67623" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-67623"><a href="https://beforesandafters.com/about/" data-hover="ABOUT"><span class="nav-menu-item-inside" data-hover="ABOUT">ABOUT</span></a></li>
<li id="menu-item-46233" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-46233"><a href="https://beforesandafters.com/shop/" data-hover="MAGAZINE"><span class="nav-menu-item-inside" data-hover="MAGAZINE">MAGAZINE</span></a></li>
<li id="menu-item-66290" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66290"><a href="https://beforesandafters.com/category/podcasts/" data-hover="PODCASTS"><span class="nav-menu-item-inside" data-hover="PODCASTS">PODCASTS</span></a></li>
<li id="menu-item-71900" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-71900"><a href="https://beforesandafters.com/my-account/" data-hover="LOGIN"><span class="nav-menu-item-inside" data-hover="LOGIN">LOGIN</span></a></li>
</ul>							<button id="nav_close" class="nav-btn active"
									aria-controls="nav_top"
									aria-expanded="true"
									aria-label="Top Menu Close"
																		on="tap:nav_top.toggleClass(class='active'),nav_toggle.toggleClass(class='active'),body.toggleClass(class='top-menu-active')"
																>
								<span></span>
							</button>
										</nav><!-- .top-nav -->
						<div class="header-search ">
			<button id="search_toggle"
					aria-controls="search_dropdown"
					aria-expanded="false"
					aria-label="Search Dropdown Toggler"
										on="tap:search_dropdown.toggleClass(class='active'),body.toggleClass(class='search-dropdown-active')"
								>
				<span class="svg-icon icon-magnify"><svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" width="24" height="24" viewBox="0 0 24 24">
	<path
		d="M9.5,3A6.5,6.5 0 0,1 16,9.5C16,11.11 15.41,12.59 14.44,13.73L14.71,14H15.5L20.5,19L19,20.5L14,15.5V14.71L13.73,14.44C12.59,15.41 11.11,16 9.5,16A6.5,6.5 0 0,1 3,9.5A6.5,6.5 0 0,1 9.5,3M9.5,5C7,5 5,7 5,9.5C5,12 7,14 9.5,14C12,14 14,12 14,9.5C14,7 12,5 9.5,5Z"/>
</svg>
</span>			</button>
		</div><!-- .header-search -->
			<div class="cart-dropdown">
		<a class="dropdown-toggle" href="#" role="button" id="dropdown-cart-toggle" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false"
		   on="tap:dropdown-cart.toggleClass(class='active'),dropdown-cart-toggle.toggleClass(class='active'),body.toggleClass(class='cart-dropdown-active')"
		>
			<span class="wc-icon-cart"></span>
			<span class="cart-count"></span>		</a>
		<div class="cart-dropdown-menu dropdown-menu-right" id="dropdown-cart" aria-labelledby="dropdown-cart-toggle">
			<div class="widget woocommerce widget_shopping_cart"><div class="widget_shopping_cart_content"></div></div>		</div>
	</div>
					<button id="nav_toggle" class="nav-btn"
						aria-controls="nav_top"
						aria-expanded="false"
						aria-label="Top Menu Toggler"
												on="tap:nav_top.toggleClass(class='active'),nav_toggle.toggleClass(class='active'),body.toggleClass(class='top-menu-active')"
										>
					<span></span>
				</button>
					</div><!-- .container -->
			</header><!-- #header -->
	</div><!--#top-wrap-->	<div id="main" class="main sidebar-33 sidebar-gap- container-960">
		<div class="container pt-1 pb-1">
						<div id="columns" class="main-columns">
				<main id="col" class="column-main ">
								<div id="layout" class="layout-meta-top">
					<article id="post-77370" class="post-77370 post type-post status-publish format-standard has-post-thumbnail hentry category-articles tag-christopher-townsend tag-dan-oliver tag-joe-farrell tag-sean-walker tag-shang-chi-and-the-legend-of-the-ten-rings tag-weta-digital" itemtype="https://schema.org/Article" itemscope="itemscope">
				<header class="entry-header">
			<h1 class="entry-title" itemprop="headline"><span>Video: Inside the VFX and SFX of &#8216;Shang-Chi&#8217;</span></h1>		</header>
			
		<footer
			class="entry-footer entry-footer-top">			<span class="entry-author-wrap icon-inline">
			<span class="svg-icon icon-account-outline"><svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" width="24" height="24" viewBox="0 0 24 24">
	<path
		d="M12,4A4,4 0 0,1 16,8A4,4 0 0,1 12,12A4,4 0 0,1 8,8A4,4 0 0,1 12,4M12,6A2,2 0 0,0 10,8A2,2 0 0,0 12,10A2,2 0 0,0 14,8A2,2 0 0,0 12,6M12,13C14.67,13 20,14.33 20,17V20H4V17C4,14.33 9.33,13 12,13M12,14.9C9.03,14.9 5.9,16.36 5.9,17V18.1H18.1V17C18.1,16.36 14.97,14.9 12,14.9Z"/>
</svg>
</span>				<span class="vcard author" itemtype="https://schema.org/Person" itemscope="itemscope" itemprop="author">
				<a href="https://beforesandafters.com/author/beforesandafters/" title="Posts by Ian Failes" rel="author" itemprop="url"><span itemprop="name">Ian Failes</span></a>				</span><!-- .author -->
			</span><!--.entry-author-wrap-->
						<span class="entry-date-wrap icon-inline">
			<span class="svg-icon icon-clock-outline"><svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" width="24" height="24" viewBox="0 0 24 24">
	<path
		d="M12,20A8,8 0 0,0 20,12A8,8 0 0,0 12,4A8,8 0 0,0 4,12A8,8 0 0,0 12,20M12,2A10,10 0 0,1 22,12A10,10 0 0,1 12,22C6.47,22 2,17.5 2,12A10,10 0 0,1 12,2M12.5,7V12.25L17,14.92L16.25,16.15L11,13V7H12.5Z"/>
</svg>
</span>				<span itemprop="datePublished">
				January 24, 2022				</span>
				<span class="hidden" itemprop="dateModified">January 24, 2022</span>
						</span><!--.entry-date-wrap-->
							<span class="entry-categories-wrap icon-inline">
				<span class="svg-icon icon-folder-outline"><svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" width="24" height="24" viewBox="0 0 24 24">
	<path
		d="M20,18H4V8H20M20,6H12L10,4H4C2.89,4 2,4.89 2,6V18A2,2 0 0,0 4,20H20A2,2 0 0,0 22,18V8C22,6.89 21.1,6 20,6Z"/>
</svg>
</span>					<span class="categories-list">
				<a href="https://beforesandafters.com/category/articles/" rel="category tag">Articles</a>					</span><!--.categories-list-->
				</span><!--.entry-categories-wrap-->
									<span class="comments-link icon-inline">
					<span class="svg-icon icon-comment-outline"><svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" width="24" height="24" viewBox="0 0 24 24">
	<path
		d="M9,22A1,1 0 0,1 8,21V18H4A2,2 0 0,1 2,16V4C2,2.89 2.9,2 4,2H20A2,2 0 0,1 22,4V16A2,2 0 0,1 20,18H13.9L10.2,21.71C10,21.9 9.75,22 9.5,22V22H9M10,16V19.08L13.08,16H20V4H4V16H10Z"/>
</svg>
</span><a href="https://beforesandafters.com/2022/01/24/video-inside-the-vfx-and-sfx-of-shang-chi/#respond">0</a>					</span><!-- .comments-link -->
					</footer>
		<!-- .entry-footer -->
						<figure class="post-thumbnail  ">
					<img width="1140" height="758" src="https://beforesandafters.com/wp-content/uploads/2022/01/SBT-32455-1-1140x758.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Video: Inside the VFX and SFX of &#8216;Shang-Chi&#8217;" loading="lazy" itemprop="image" srcset="https://beforesandafters.com/wp-content/uploads/2022/01/SBT-32455-1-1140x758.jpg 1140w, https://beforesandafters.com/wp-content/uploads/2022/01/SBT-32455-1-300x200.jpg 300w, https://beforesandafters.com/wp-content/uploads/2022/01/SBT-32455-1-1024x681.jpg 1024w, https://beforesandafters.com/wp-content/uploads/2022/01/SBT-32455-1-768x511.jpg 768w, https://beforesandafters.com/wp-content/uploads/2022/01/SBT-32455-1-600x399.jpg 600w, https://beforesandafters.com/wp-content/uploads/2022/01/SBT-32455-1.jpg 1200w" sizes="(max-width: 1140px) 100vw, 1140px" data-attachment-id="77372" data-permalink="https://beforesandafters.com/2022/01/24/video-inside-the-vfx-and-sfx-of-shang-chi/sbt-32455-1/" data-orig-file="https://beforesandafters.com/wp-content/uploads/2022/01/SBT-32455-1.jpg" data-orig-size="1200,798" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;2.8&quot;,&quot;credit&quot;:&quot;jasinboland@gmail.com&quot;,&quot;camera&quot;:&quot;NIKON Z 6&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1603322745&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;40&quot;,&quot;iso&quot;:&quot;3200&quot;,&quot;shutter_speed&quot;:&quot;0.005&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="SBT-32455 1" data-image-description="" data-image-caption="" data-medium-file="https://beforesandafters.com/wp-content/uploads/2022/01/SBT-32455-1-300x200.jpg" data-large-file="https://beforesandafters.com/wp-content/uploads/2022/01/SBT-32455-1-1024x681.jpg" />				</figure><!-- .post-thumbnail -->
						<div class="item-content">
			<div class="entry-content" itemprop="text">
				<blockquote><p>The VFX team behind the film discuss the face replacements, bus shots and dragon and water sims in a new video interview.</p></blockquote>
<p>We sit down with members of the VFX team on <em>Shang-Chi and the Legend of the Ten Rings</em> to discuss face replacements, making the bus scene and crafting the dragon and water sims for the final battle.</p>
<p>Hear from visual effects supervisor Christopher Townsend, additional visual effects supervisor Joe Farrell, special effects supervisor Dan Oliver and Weta Digital visual effects supervisor Sean Walker.</p>
<p><span class="embed-youtube" style="text-align:center; display: block;"><iframe loading="lazy" class="youtube-player" width="640" height="360" src="https://www.youtube.com/embed/uD17-M8ZS4U?version=3&#038;rel=1&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;fs=1&#038;hl=en-US&#038;autohide=2&#038;wmode=transparent" allowfullscreen="true" style="border:0;" sandbox="allow-scripts allow-same-origin allow-popups allow-presentation"></iframe></span></p>
<div data-advadstrackid="72669" data-advadstrackbid="1" class="befor-target" id="befor-690640904"><a href="https://bit.ly/3iAQdQf" class="adv-link"><img loading="lazy" src="https://beforesandafters.com/wp-content/uploads/2021/10/Befores-and-Afters-Banner-Small-Box-300x300-1.png" alt=""  srcset="https://beforesandafters.com/wp-content/uploads/2021/10/Befores-and-Afters-Banner-Small-Box-300x300-1.png 300w, https://beforesandafters.com/wp-content/uploads/2021/10/Befores-and-Afters-Banner-Small-Box-300x300-1-150x150.png?crop=1 150w, https://beforesandafters.com/wp-content/uploads/2021/10/Befores-and-Afters-Banner-Small-Box-300x300-1-45x45.png?crop=1 45w, https://beforesandafters.com/wp-content/uploads/2021/10/Befores-and-Afters-Banner-Small-Box-300x300-1-80x80.png?crop=1 80w, https://beforesandafters.com/wp-content/uploads/2021/10/Befores-and-Afters-Banner-Small-Box-300x300-1-50x50.png?crop=1 50w, https://beforesandafters.com/wp-content/uploads/2021/10/Befores-and-Afters-Banner-Small-Box-300x300-1-100x100.png?crop=1 100w" sizes="(max-width: 300px) 100vw, 300px" width="300" height="300"   /></a></div>

<em><a href="https://www.patreon.com/beforesandafters">Get bonus VFX content at the befores & afters Patreon</a></em>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>You might also like</em></h3>
</div>			</div><!-- .entry-content -->

			<footer
				class="entry-footer entry-footer-bottom">				<span class="entry-tags-wrap icon-inline">
					<span class="svg-icon icon-tag"><svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" width="24" height="24" viewBox="0 0 24 24">
	<path
		d="M5.5,7A1.5,1.5 0 0,1 4,5.5A1.5,1.5 0 0,1 5.5,4A1.5,1.5 0 0,1 7,5.5A1.5,1.5 0 0,1 5.5,7M21.41,11.58L12.41,2.58C12.05,2.22 11.55,2 11,2H4C2.89,2 2,2.89 2,4V11C2,11.55 2.22,12.05 2.59,12.41L11.58,21.41C11.95,21.77 12.45,22 13,22C13.55,22 14.05,21.77 14.41,21.41L21.41,14.41C21.78,14.05 22,13.55 22,13C22,12.44 21.77,11.94 21.41,11.58Z"/>
</svg>
</span>				<span class="tags-list">
				<span class="entry-tags"><a href="https://beforesandafters.com/tag/christopher-townsend/" rel="tag">Christopher Townsend</a><span class="entry-tags-separator"> </span><a href="https://beforesandafters.com/tag/dan-oliver/" rel="tag">Dan Oliver</a><span class="entry-tags-separator"> </span><a href="https://beforesandafters.com/tag/joe-farrell/" rel="tag">Joe Farrell</a><span class="entry-tags-separator"> </span><a href="https://beforesandafters.com/tag/sean-walker/" rel="tag">Sean Walker</a><span class="entry-tags-separator"> </span><a href="https://beforesandafters.com/tag/shang-chi-and-the-legend-of-the-ten-rings/" rel="tag">Shang-Chi and the Legend of the Ten Rings</a><span class="entry-tags-separator"> </span><a href="https://beforesandafters.com/tag/weta-digital/" rel="tag">Weta Digital</a></span>				</span><!--.tags-list-->
			</span><!--.entry-tags-wrap-->
				</footer>
			<!-- .entry-footer -->

		</div><!-- .item-content -->
	</article><!-- #post-77370 -->
		<nav class="post-nav post-nav-layout-title">
			<div><a href="https://beforesandafters.com/2022/01/23/watch-dnegs-vfx-breakdown-for-the-matrix-resurrections/" rel="prev"><div class="post-nav-item prev-item">
							<span class="post-nav-arrow"><span class="svg-icon icon-chevron-left"><svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" width="24" height="24" viewBox="0 0 24 24">
	<path d="M15.41,16.58L10.83,12L15.41,7.41L14,6L8,12L14,18L15.41,16.58Z"/>
</svg>
</span></span>
							<span class="post-nav-words-wrap">
								<span class="post-nav-word"></span>
								<span class="post-nav-title">Watch DNEG&#8217;s VFX breakdown for &#8216;The Matrix Resurrections&#8217;</span>
							</span>
						</div></a></div><div><a href="https://beforesandafters.com/2022/01/24/when-you-have-to-craft-not-one-spider-man-but-three/" rel="next"><div class="post-nav-item next-item">
							<span class="post-nav-words-wrap">
								<span class="post-nav-word"></span> 
								<span class="post-nav-title">When you have to craft not one Spider-Man, but three!</span>
							</span>
							<span class="post-nav-arrow"><span class="svg-icon icon-chevron-right"><svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" width="24" height="24" viewBox="0 0 24 24">
	<path d="M8.59,16.58L13.17,12L8.59,7.41L10,6L16,12L10,18L8.59,16.58Z"/>
</svg>
</span></span>
						</div></a></div>		</nav><!-- .navigation -->
		
<div id="comments" class="comments-area">

	
		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">Leave a Reply					<small><a rel="nofollow" id="cancel-comment-reply-link" href="/2022/01/24/video-inside-the-vfx-and-sfx-of-shang-chi/#respond" style="display:none;">Cancel reply</a></small>
				</h3>
						<form id="commentform" class="comment-form">
				<iframe
					title="Comment Form"
					src="https://jetpack.wordpress.com/jetpack-comment/?blogid=154221204&#038;postid=77370&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=0&#038;avatar_default=identicon&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=10.6-a.3&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=0f1408380a303b1220fcfccfacbda0ae04485717#parent=https%3A%2F%2Fbeforesandafters.com%2F2022%2F01%2F24%2Fvideo-inside-the-vfx-and-sfx-of-shang-chi%2F"
											name="jetpack_remote_comment"
						style="width:100%; height: 430px; border:0;"
										class="jetpack_remote_comment"
					id="jetpack_remote_comment"
					sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups"
				>
									</iframe>
									<!--[if !IE]><!-->
					<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = false;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
					<!--<![endif]-->
							</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

		</div><!-- #comments -->
			</div><!-- #layout -->
			</main><!-- #main -->
		</div><!-- #columns -->
		</div><!-- .container -->
	</div><!-- #main -->
	<div id="bottom-wrap" class="container-960"><div id="copyright" class="copyright  fs-14 "
	>
	<div class="container pt-2 pb-2">
		<div class="copyright-text text-center">
			© <span class="copyright-year">2022</span> befores &amp; afters - All rights reserved		</div>
	</div><!-- .container -->
</div><!-- #copyright -->
</div><!-- #bottom-wrap --></div><!-- #box -->

<div id="search_dropdown">
	<form autocomplete="off" role="search" method="get" class="search-form" action="https://beforesandafters.com/">

	<input
		type="search"
		id="search-form-61eead6a95495"
		class="search-field"
		placeholder="Search"
		value=""
		name="s"
	/>
			<button type="submit" class="search-submit"><span class="svg-icon icon-magnify"><svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" width="24" height="24" viewBox="0 0 24 24">
	<path
		d="M9.5,3A6.5,6.5 0 0,1 16,9.5C16,11.11 15.41,12.59 14.44,13.73L14.71,14H15.5L20.5,19L19,20.5L14,15.5V14.71L13.73,14.44C12.59,15.41 11.11,16 9.5,16A6.5,6.5 0 0,1 3,9.5A6.5,6.5 0 0,1 9.5,3M9.5,5C7,5 5,7 5,9.5C5,12 7,14 9.5,14C12,14 14,12 14,9.5C14,7 12,5 9.5,5Z"/>
</svg>
</span>			<span class="screen-reader-text">Search</span>
		</button>
		
	<label for="search-form-61eead6a95495" class="screen-reader-text">
		Search for:	</label>

</form><!-- .search-form -->
</div><!-- #search_dropdown -->
<button
	id="search_modal_close"
	class="nav-btn active"
	aria-controls="search_dropdown"
	aria-expanded="true"
	aria-label="Search Toggler"
		on="tap:search_dropdown.toggleClass(class='active'),body.toggleClass(class='search-dropdown-active')"
	>
	<span></span>
</button>

	<a id="to-top" href="#body">
		<span class="screen-reader-text">
			Go to top		</span>
	</a>
<!--  -->
<script defer id='bilmur' data-provider='wordpress.com' data-service='atomic' src='https://s0.wp.com/wp-content/js/bilmur.min.js?m=202204'></script>
<div class="simple-banner simple-banner-text" style="display:none !important"></div>		<script type="text/javascript">
				</script>
	<script id="mcjs">!function(c,h,i,m,p){m=c.createElement(h),p=c.getElementsByTagName(h)[0],m.async=1,m.src=i,p.parentNode.insertBefore(m,p)}(document,"script","https://chimpstatic.com/mcjs-connected/js/users/fe63a873c305d7bd840d6d7bf/b4c6a8e923281a2171852ca33.js");</script>	<script type="text/javascript">
		(function () {
			var c = document.body.className;
			c = c.replace(/woocommerce-no-js/, 'woocommerce-js');
			document.body.className = c;
		})();
	</script>
	<script src='https://beforesandafters.com/wp-content/plugins/woocommerce/assets/js/jquery-blockui/jquery.blockUI.min.js?ver=2.7.0-wc.6.1.1' id='jquery-blockui-js'></script>
<script id='wc-add-to-cart-js-extra'>
var wc_add_to_cart_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","i18n_view_cart":"View cart","cart_url":"https:\/\/beforesandafters.com\/cart\/","is_cart":"","cart_redirect_after_add":"no"};
</script>
<script src='https://beforesandafters.com/wp-content/plugins/woocommerce/assets/js/frontend/add-to-cart.min.js?ver=6.1.1' id='wc-add-to-cart-js'></script>
<script src='https://beforesandafters.com/wp-content/plugins/woocommerce/assets/js/js-cookie/js.cookie.min.js?ver=2.1.4-wc.6.1.1' id='js-cookie-js'></script>
<script id='woocommerce-js-extra'>
var woocommerce_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%"};
</script>
<script src='https://beforesandafters.com/wp-content/plugins/woocommerce/assets/js/frontend/woocommerce.min.js?ver=6.1.1' id='woocommerce-js'></script>
<script id='wc-cart-fragments-js-extra'>
var wc_cart_fragments_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","cart_hash_key":"wc_cart_hash_75e1028262d39148383b7dbe9afd6af1","fragment_name":"wc_fragments_75e1028262d39148383b7dbe9afd6af1","request_timeout":"5000"};
</script>
<script src='https://beforesandafters.com/wp-content/plugins/woocommerce/assets/js/frontend/cart-fragments.min.js?ver=6.1.1' id='wc-cart-fragments-js'></script>
<script id='wc-cart-fragments-js-after'>
		jQuery( 'body' ).bind( 'wc_fragments_refreshed', function() {
			var jetpackLazyImagesLoadEvent;
			try {
				jetpackLazyImagesLoadEvent = new Event( 'jetpack-lazy-images-load', {
					bubbles: true,
					cancelable: true
				} );
			} catch ( e ) {
				jetpackLazyImagesLoadEvent = document.createEvent( 'Event' )
				jetpackLazyImagesLoadEvent.initEvent( 'jetpack-lazy-images-load', true, true );
			}
			jQuery( 'body' ).get( 0 ).dispatchEvent( jetpackLazyImagesLoadEvent );
		} );
		
</script>
<script id='ppcp-smart-button-js-extra'>
var PayPalCommerceGateway = {"script_attributes":{"data-partner-attribution-id":"Woo_PPCP"},"data_client_id":{"set_attribute":false,"endpoint":"https:\/\/beforesandafters.com\/?wc-ajax=ppc-data-client-id","nonce":"4ac8d4a22f","user":0},"redirect":"https:\/\/beforesandafters.com\/checkout\/","context":"mini-cart","ajax":{"change_cart":{"endpoint":"https:\/\/beforesandafters.com\/?wc-ajax=ppc-change-cart","nonce":"b08f165a9a"},"create_order":{"endpoint":"https:\/\/beforesandafters.com\/?wc-ajax=ppc-create-order","nonce":"bc535523f5"},"approve_order":{"endpoint":"https:\/\/beforesandafters.com\/?wc-ajax=ppc-approve-order","nonce":"f13f3f8feb"}},"enforce_vault":"","save_card":"","bn_codes":{"checkout":"Woo_PPCP","cart":"Woo_PPCP","mini-cart":"Woo_PPCP","product":"Woo_PPCP"},"payer":null,"button":{"wrapper":"#ppc-button","mini_cart_wrapper":"#ppc-button-minicart","cancel_wrapper":"#ppcp-cancel","url":"https:\/\/www.paypal.com\/sdk\/js?client-id=AZ1bWE6uZdh9dAbydRSzXxjHG_CZeoa_eZuID-zCLpzS5a4jMK0rdo5kbDCacC6YfxZplF3hJD3YqgS2&currency=AUD&integration-date=2021-09-17&components=buttons,messages&vault=false&commit=false&intent=capture&disable-funding=card,credit&enable-funding=venmo","mini_cart_style":{"layout":"vertical","color":"gold","shape":"rect","label":"paypal","height":35},"style":{"layout":"vertical","color":"gold","shape":"rect","label":"paypal"}},"hosted_fields":{"wrapper":"#ppcp-hosted-fields","mini_cart_wrapper":"#ppcp-hosted-fields-mini-cart","labels":{"credit_card_number":"","cvv":"","mm_yy":"MM\/YY","fields_not_valid":"Unfortunately, your credit card details are not valid.","card_not_supported":"Unfortunately, we do not support your credit card.","cardholder_name_required":"Cardholder's first and last name are required, please fill the checkout form required fields."},"valid_cards":["mastercard","visa","master-card"],"contingency":"SCA_WHEN_REQUIRED"},"messages":[],"labels":{"error":{"generic":"Something went wrong. Please try again or choose another payment source."}},"order_id":"0","single_product_buttons_enabled":"1","mini_cart_buttons_enabled":"1"};
</script>
<script src='https://beforesandafters.com/wp-content/plugins/woocommerce-paypal-payments/modules/ppcp-button//assets/js/button.js?ver=1.3.2' id='ppcp-smart-button-js'></script>
<script id='mailchimp-woocommerce-js-extra'>
var mailchimp_public_data = {"site_url":"https:\/\/beforesandafters.com","ajax_url":"https:\/\/beforesandafters.com\/wp-admin\/admin-ajax.php","language":"en","allowed_to_set_cookies":"1"};
</script>
<script src='https://beforesandafters.com/wp-content/plugins/mailchimp-for-woocommerce/public/js/mailchimp-woocommerce-public.min.js?ver=2.5.4' id='mailchimp-woocommerce-js'></script>
<script src='https://beforesandafters.com/wp-content/themes/exs-pro/assets/js/min/init.js?ver=1.8.4' id='exs-init-script-js'></script>
<script src='https://beforesandafters.com/wp-includes/js/comment-reply.min.js?ver=5.8.3' id='comment-reply-js'></script>
<script src='https://beforesandafters.com/wp-content/plugins/jetpack/modules/likes/queuehandler.js?ver=10.6-a.3' id='jetpack_likes_queuehandler-js'></script>
<script id='advadsTrackingScript-js-extra'>
var advadsTracking = {"impressionActionName":"aatrack-records","clickActionName":"aatrack-click","targetClass":"befor-target","blogId":"1"};
</script>
<script src='https://beforesandafters.com/wp-content/plugins/advanced-ads-tracking/public/assets/js/dist/tracking.min.js?ver=2.1.3' id='advadsTrackingScript-js'></script>
<script src='https://beforesandafters.com/wp-content/plugins/visual-footer-credit-remover/script.js?ver=5.8.3' id='jabvfcr_script-js'></script>
<script src='https://beforesandafters.com/wp-includes/js/wp-embed.min.js?ver=5.8.3' id='wp-embed-js'></script>
<script>!function(){window.advanced_ads_ready_queue=window.advanced_ads_ready_queue||[],advanced_ads_ready_queue.push=window.advanced_ads_ready;for(var d=0,a=advanced_ads_ready_queue.length;d<a;d++)advanced_ads_ready(advanced_ads_ready_queue[d])}();</script>
		<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
		<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=154221204&postid=77370&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=0&avatar_default=identicon&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=10.6-a.3&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=0f1408380a303b1220fcfccfacbda0ae04485717#parent=https%3A%2F%2Fbeforesandafters.com%2F2022%2F01%2F24%2Fvideo-inside-the-vfx-and-sfx-of-shang-chi%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=154221204&postid=77370&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=0&avatar_default=identicon&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=10.6-a.3&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=0f1408380a303b1220fcfccfacbda0ae04485717#parent=https%3A%2F%2Fbeforesandafters.com%2F2022%2F01%2F24%2Fvideo-inside-the-vfx-and-sfx-of-shang-chi%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								frame.style.height = event.data + 'px';
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								frame.style.height = event.data + 'px';
							});
						}
					}
				})

			})();
		</script>

		<script src='https://stats.wp.com/e-202204.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.6-a.3',blog:'154221204',post:'77370',tz:'11',srv:'beforesandafters.com'} ]);
	_stq.push([ 'clickTrackerInit', '154221204', '77370' ]);
</script>
<script id="befor-tracking">var advads_tracking_ads = {"1":[72669]};var advads_tracking_urls = {"1":"https:\/\/beforesandafters.com\/wp-content\/ajax-handler.php"};var advads_tracking_methods = {"1":"frontend"};var advads_tracking_parallel = {"1":false};var advads_tracking_linkbases = {"1":"https:\/\/beforesandafters.com\/linkout\/"};</script></body>
</html>
