<!DOCTYPE html>
<html lang="en-US" id="arve">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11">
<link rel="pingback" href="https://beforesandafters.com/xmlrpc.php">

<title>Procedural pores, modeling teeth, messy fighting and other new things Weta Digital did to turn Will Smith into a 23-year-old - befores &amp; afters</title>

<!-- This site is optimized with the Yoast SEO plugin v12.2 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/>
<link rel="canonical" href="https://beforesandafters.com/2019/10/11/procedural-pores-modeling-teeth-messy-fighting-and-other-new-things-weta-digital-did-to-turn-will-smith-into-a-23-year-old/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Procedural pores, modeling teeth, messy fighting and other new things Weta Digital did to turn Will Smith into a 23-year-old - befores &amp; afters" />
<meta property="og:description" content="Weta Digital also had to work with 40 times the usual data on ‘Gemini Man’." />
<meta property="og:url" content="https://beforesandafters.com/2019/10/11/procedural-pores-modeling-teeth-messy-fighting-and-other-new-things-weta-digital-did-to-turn-will-smith-into-a-23-year-old/" />
<meta property="og:site_name" content="befores &amp; afters" />
<meta property="article:publisher" content="https://www.facebook.com/Befores-Afters-829036060774243/" />
<meta property="article:tag" content="Gemini Man" />
<meta property="article:tag" content="Guy Williams" />
<meta property="article:tag" content="Weta Digital" />
<meta property="article:section" content="Article" />
<meta property="article:published_time" content="2019-10-11T09:47:27+00:00" />
<meta property="article:modified_time" content="2019-10-11T09:49:24+00:00" />
<meta property="og:updated_time" content="2019-10-11T09:49:24+00:00" />
<meta property="og:image" content="https://beforesandafters.com/wp-content/uploads/2019/10/GM_FF_031K_size.jpg" />
<meta property="og:image:secure_url" content="https://beforesandafters.com/wp-content/uploads/2019/10/GM_FF_031K_size.jpg" />
<meta property="og:image:width" content="800" />
<meta property="og:image:height" content="441" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Weta Digital also had to work with 40 times the usual data on ‘Gemini Man’." />
<meta name="twitter:title" content="Procedural pores, modeling teeth, messy fighting and other new things Weta Digital did to turn Will Smith into a 23-year-old - befores &amp; afters" />
<meta name="twitter:site" content="@vfxblog" />
<meta name="twitter:image" content="https://beforesandafters.com/wp-content/uploads/2019/10/GM_FF_031K_size.jpg" />
<meta name="twitter:creator" content="@vfxblog" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://beforesandafters.com/#organization","name":"befores & afters","url":"https://beforesandafters.com/","sameAs":["https://www.facebook.com/Befores-Afters-829036060774243/","http://instagram.com/vfxblog","https://www.linkedin.com/in/ian-failes-17154b4/","https://twitter.com/vfxblog"],"logo":{"@type":"ImageObject","@id":"https://beforesandafters.com/#logo","url":"https://beforesandafters.com/wp-content/uploads/2019/03/ba_500.jpg","width":500,"height":581,"caption":"befores & afters"},"image":{"@id":"https://beforesandafters.com/#logo"}},{"@type":"WebSite","@id":"https://beforesandafters.com/#website","url":"https://beforesandafters.com/","name":"befores & afters","publisher":{"@id":"https://beforesandafters.com/#organization"},"potentialAction":{"@type":"SearchAction","target":"https://beforesandafters.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://beforesandafters.com/2019/10/11/procedural-pores-modeling-teeth-messy-fighting-and-other-new-things-weta-digital-did-to-turn-will-smith-into-a-23-year-old/#primaryimage","url":"https://beforesandafters.com/wp-content/uploads/2019/10/GM_FF_031K_size.jpg","width":800,"height":441},{"@type":"WebPage","@id":"https://beforesandafters.com/2019/10/11/procedural-pores-modeling-teeth-messy-fighting-and-other-new-things-weta-digital-did-to-turn-will-smith-into-a-23-year-old/#webpage","url":"https://beforesandafters.com/2019/10/11/procedural-pores-modeling-teeth-messy-fighting-and-other-new-things-weta-digital-did-to-turn-will-smith-into-a-23-year-old/","inLanguage":"en-US","name":"Procedural pores, modeling teeth, messy fighting and other new things Weta Digital did to turn Will Smith into a 23-year-old - befores &amp; afters","isPartOf":{"@id":"https://beforesandafters.com/#website"},"primaryImageOfPage":{"@id":"https://beforesandafters.com/2019/10/11/procedural-pores-modeling-teeth-messy-fighting-and-other-new-things-weta-digital-did-to-turn-will-smith-into-a-23-year-old/#primaryimage"},"datePublished":"2019-10-11T09:47:27+00:00","dateModified":"2019-10-11T09:49:24+00:00"},{"@type":"Article","@id":"https://beforesandafters.com/2019/10/11/procedural-pores-modeling-teeth-messy-fighting-and-other-new-things-weta-digital-did-to-turn-will-smith-into-a-23-year-old/#article","isPartOf":{"@id":"https://beforesandafters.com/2019/10/11/procedural-pores-modeling-teeth-messy-fighting-and-other-new-things-weta-digital-did-to-turn-will-smith-into-a-23-year-old/#webpage"},"author":{"@id":"https://beforesandafters.com/#/schema/person/a05bbb1beae784a05c2b92006d5f966d"},"headline":"Procedural pores, modeling teeth, messy fighting and other new things Weta Digital did to turn Will Smith into a 23-year-old","datePublished":"2019-10-11T09:47:27+00:00","dateModified":"2019-10-11T09:49:24+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://beforesandafters.com/2019/10/11/procedural-pores-modeling-teeth-messy-fighting-and-other-new-things-weta-digital-did-to-turn-will-smith-into-a-23-year-old/#webpage"},"publisher":{"@id":"https://beforesandafters.com/#organization"},"image":{"@id":"https://beforesandafters.com/2019/10/11/procedural-pores-modeling-teeth-messy-fighting-and-other-new-things-weta-digital-did-to-turn-will-smith-into-a-23-year-old/#primaryimage"},"keywords":"Gemini Man,Guy Williams,Weta Digital","articleSection":"Article"},{"@type":["Person"],"@id":"https://beforesandafters.com/#/schema/person/a05bbb1beae784a05c2b92006d5f966d","name":"Ian Failes","sameAs":[]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="befores &amp; afters &raquo; Feed" href="https://beforesandafters.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="befores &amp; afters &raquo; Comments Feed" href="https://beforesandafters.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="befores &amp; afters &raquo; Procedural pores, modeling teeth, messy fighting and other new things Weta Digital did to turn Will Smith into a 23-year-old Comments Feed" href="https://beforesandafters.com/2019/10/11/procedural-pores-modeling-teeth-messy-fighting-and-other-new-things-weta-digital-did-to-turn-will-smith-into-a-23-year-old/feed/" />
<!-- This site uses the Google Analytics by MonsterInsights plugin v7.9.0 - Using Analytics tracking - https://www.monsterinsights.com/ -->
<script type="text/javascript" data-cfasync="false">
	var mi_version         = '7.9.0';
	var mi_track_user      = true;
	var mi_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-140669838-1';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}
	
	if ( mi_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

		__gaTracker('create', 'UA-140669838-1', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('require', 'displayfeatures');
		__gaTracker('send','pageview');
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
					})();
		}
</script>
<!-- / Google Analytics by MonsterInsights -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/beforesandafters.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.2.3"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<!-- managing ads with Advanced Ads – https://wpadvancedads.com/ --><script>
					advanced_ads_ready=function(){var fns=[],listener,doc=typeof document==="object"&&document,hack=doc&&doc.documentElement.doScroll,domContentLoaded="DOMContentLoaded",loaded=doc&&(hack?/^loaded|^c/:/^loaded|^i|^c/).test(doc.readyState);if(!loaded&&doc){listener=function(){doc.removeEventListener(domContentLoaded,listener);window.removeEventListener("load",listener);loaded=1;while(listener=fns.shift())listener()};doc.addEventListener(domContentLoaded,listener);window.addEventListener("load",listener)}return function(fn){loaded?setTimeout(fn,0):fns.push(fn)}}();
			</script><style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://c0.wp.com/c/5.2.3/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://c0.wp.com/c/5.2.3/wp-includes/css/dashicons.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='easy-pull-quotes-css'  href='https://beforesandafters.com/wp-content/plugins/easy-pull-quotes/public/css/easy-pull-quotes-public.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='perfect-pullquotes-styles-css'  href='https://beforesandafters.com/wp-content/plugins/perfect-pullquotes/perfect-pullquotes.css?ver=1.7.5' type='text/css' media='all' />
<link rel='stylesheet' id='twenty20-style-css'  href='https://beforesandafters.com/wp-content/plugins/twenty20/assets/css/twenty20.css?ver=1.55' type='text/css' media='all' />
<link rel='stylesheet' id='wp-date-remover-css'  href='https://beforesandafters.com/wp-content/plugins/wp-date-remover/public/css/wp-date-remover-public.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='patch-font-awesome-style-css'  href='https://beforesandafters.com/wp-content/themes/patch/assets/css/font-awesome.css?ver=4.3.0' type='text/css' media='all' />
<link rel='stylesheet' id='patch-style-css'  href='https://beforesandafters.com/wp-content/themes/patch/style.css?ver=5.2.3' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='patch-fonts-css'  href='https://fonts.googleapis.com/css?family=Roboto%3A500%2C400%2C300%2C500italic%2C400italic%2C300italic%7COswald%3A300%2C400%2C700&#038;subset=latin%2Clatin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='mc4wp-form-themes-css'  href='https://beforesandafters.com/wp-content/plugins/mailchimp-for-wp/assets/css/form-themes.min.css?ver=4.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://c0.wp.com/p/jetpack/7.8/_inc/social-logos/social-logos.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/7.8/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript' src='https://c0.wp.com/c/5.2.3/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.2.3/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/7.8/_inc/build/related-posts/related-posts.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,exe,js,pdf,ppt,tgz,zip,xls","inbound_paths":"[{\"path\":\"\\\/go\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/recommend\\\/\",\"label\":\"affiliate\"}]","home_url":"https:\/\/beforesandafters.com","hash_tracking":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='https://beforesandafters.com/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend.min.js?ver=7.9.0'></script>
<script type='text/javascript' src='https://beforesandafters.com/wp-content/plugins/wp-date-remover/public/js/wp-date-remover-public.js?ver=1.0.0'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/7.8/_inc/build/postmessage.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/7.8/_inc/build/jquery.jetpack-resize.min.js'></script>
<link rel='https://api.w.org/' href='https://beforesandafters.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://beforesandafters.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://beforesandafters.com/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='https://wp.me/par5YM-1bj' />
<link rel="alternate" type="application/json+oembed" href="https://beforesandafters.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fbeforesandafters.com%2F2019%2F10%2F11%2Fprocedural-pores-modeling-teeth-messy-fighting-and-other-new-things-weta-digital-did-to-turn-will-smith-into-a-23-year-old%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://beforesandafters.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fbeforesandafters.com%2F2019%2F10%2F11%2Fprocedural-pores-modeling-teeth-messy-fighting-and-other-new-things-weta-digital-did-to-turn-will-smith-into-a-23-year-old%2F&#038;format=xml" />

<link rel='dns-prefetch' href='//widgets.wp.com'/>
<link rel='dns-prefetch' href='//s0.wp.com'/>
<link rel='dns-prefetch' href='//0.gravatar.com'/>
<link rel='dns-prefetch' href='//1.gravatar.com'/>
<link rel='dns-prefetch' href='//2.gravatar.com'/>
<link rel='dns-prefetch' href='//jetpack.wordpress.com'/>
<link rel='dns-prefetch' href='//s1.wp.com'/>
<link rel='dns-prefetch' href='//s2.wp.com'/>
<link rel='dns-prefetch' href='//public-api.wordpress.com'/>
<link rel='dns-prefetch' href='//c0.wp.com'/>
<style type='text/css'>img#wpstats{display:none}</style>			<!-- Site Logo: hide header text -->
			<style type="text/css">
			.site-title, .site-description-text {
				position: absolute;
				clip: rect(1px, 1px, 1px, 1px);
			}
			</style>
							<script type="text/javascript">
									if (typeof WebFont !== 'undefined') {				WebFont.load({
				google: {families: ['Oswald:200:cyrillic','Lato:100,100italic,300,300italic,regular,italic,700,700italic,900,900italic:latin']},
				classes: false,
				events: false
				});
				} else {
				var tk = document.createElement('script');
				tk.src = '//ajax.googleapis.com/ajax/libs/webfont/1/webfont.js';
				tk.type = 'text/javascript';

				tk.onload = tk.onreadystatechange = function () {
				WebFont.load({
				google: {families: ['Oswald:200:cyrillic','Lato:100,100italic,300,300italic,regular,italic,700,700italic,900,900italic:latin']},
				classes: false,
				events: false
				});
				};

				var s = document.getElementsByTagName('script')[0];
				s.parentNode.insertBefore(tk, s);
				}				</script>
							<style id="customify_typography_output_style">
					.site-title a, h1, h2, h3, h4, h5, h6,
										h1 a, h2 a, h3 a, h4 a, h5 a, h6 a,
										.widget-title {
 font-family: Oswald;
font-weight: 200;
}
html body {
 font-family: Lato;
}
				</style>
			<link rel="amphtml" href="https://beforesandafters.com/2019/10/11/procedural-pores-modeling-teeth-messy-fighting-and-other-new-things-weta-digital-did-to-turn-will-smith-into-a-23-year-old/amp/"><meta name="google-site-verification" content="P2kQwk9rkrt1yZ1KVkOcp4IHUUOJ1DUp1Zz7NQ_WkEg" />
<script async src="//pagead2.googlesyndication.com/
pagead/js/adsbygoogle.js"></script>
<script>
(adsbygoogle = window.adsbygoogle || []).push({
google_ad_client: "pub-7530686204223811",
enable_page_level_ads: true
});
</script><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>(adsbygoogle = window.adsbygoogle || []).push({
google_ad_client: "ca-pub-7530686204223811",
enable_page_level_ads: true,
});
</script>
<link rel="icon" href="https://beforesandafters.com/wp-content/uploads/2019/03/cropped-beforesafters-32x32.jpeg" sizes="32x32" />
<link rel="icon" href="https://beforesandafters.com/wp-content/uploads/2019/03/cropped-beforesafters-192x192.jpeg" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://beforesandafters.com/wp-content/uploads/2019/03/cropped-beforesafters-180x180.jpeg" />
<meta name="msapplication-TileImage" content="https://beforesandafters.com/wp-content/uploads/2019/03/cropped-beforesafters-270x270.jpeg" />
			<style id="customify_output_style">
				a, .entry-meta a { color: #000000; }
.site-title a, h1, h2, h3, h4, h5, h6,
h1 a, h2 a, h3 a, h4 a, h5 a, h6 a,
.widget-title,
a:hover, .entry-meta a:hover { color: #000000; }
body { color: #000000; }
body, .site { background: #ffffff; }

@media screen and (min-width: 1000px) { 

	.site-title { font-size: 24px; }

	.site-content { padding: 18px; }

}
			</style>
			</head>

<body class="post-template-default single single-post postid-4545 single-format-standard has_sidebar has-site-logo">


<div id="page" class="hfeed site">
	<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

	<div id="content" class="site-content">
		<div class="container">

		

<header id="masthead" class="site-header" role="banner">
	<div class="site-branding">

		<a href="https://beforesandafters.com/" class="site-logo-link" rel="home" itemprop="url"><img width="172" height="200" src="https://beforesandafters.com/wp-content/uploads/2019/03/logo_200.jpg" class="site-logo attachment-patch-site-logo" alt="" data-size="patch-site-logo" itemprop="logo" data-attachment-id="429" data-permalink="https://beforesandafters.com/logo_200/" data-orig-file="https://beforesandafters.com/wp-content/uploads/2019/03/logo_200.jpg" data-orig-size="172,200" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="logo_200" data-image-description="" data-medium-file="https://beforesandafters.com/wp-content/uploads/2019/03/logo_200.jpg" data-large-file="https://beforesandafters.com/wp-content/uploads/2019/03/logo_200.jpg" /></a>
		<div class="site-title">
		<a href="https://beforesandafters.com/" rel="home">
			befores &amp; afters		</a>

		</div>
		
			<div class="site-description">
				<span class="site-description-text">covering the VFX industry</span>
			</div>

		
	</div><!-- .site-branding -->

	<nav id="site-navigation" class="main-navigation" role="navigation">

		<ul id="menu-primary" class="nav nav--main"><li id="menu-item-19" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-19"><a href="https://beforesandafters.com/about/">About</a></li>
<li id="menu-item-197" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-197"><a href="https://beforesandafters.com/category/retro/">Retro VFX</a></li>
<li id="menu-item-231" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-231"><a href="https://beforesandafters.com/support/">Support us</a></li>
<li id="menu-item-7" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7"><a href="https://beforesandafters.com/contact/">Contact</a></li>
</ul>
		<ul id="menu-social" class="nav nav--social"><li id="menu-item-214" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-214"><a href="https://twitter.com/vfxblog">Twitter</a></li>
<li id="menu-item-217" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-217"><a href="https://www.instagram.com/vfxblog/">Instagram</a></li>
<li id="menu-item-554" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-554"><a href="https://www.facebook.com/Befores-Afters-829036060774243/">Facebook</a></li>
<li id="menu-item-218" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-218"><a href="https://www.linkedin.com/in/ian-failes-17154b4/">LinkedIn</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom"><a href="#search">Search</a></li></ul>
	</nav><!-- #site-navigation -->

</header><!-- #masthead -->


	<div id="primary" class="content-area">
		<main id="main" class="site-main" role="main">

			
<article id="post-4545" class="post-4545 post type-post status-publish format-standard has-post-thumbnail hentry category-article tag-gemini-man tag-guy-williams tag-weta-digital entry-image--wide">

	
	<header class="entry-header">
		<div class="entry-meta">

			<span class="cat-links"><a href="https://beforesandafters.com/category/article/" rel="category tag">Article</a></span>
			<div class="clearfix">

				<span class="byline"> by <span class="author vcard"><a class="url fn n" href="https://beforesandafters.com/author/beforesandafters/">Ian Failes</a></span></span><span class="posted-on"><a href="https://beforesandafters.com/2019/10/11/procedural-pores-modeling-teeth-messy-fighting-and-other-new-things-weta-digital-did-to-turn-will-smith-into-a-23-year-old/" rel="bookmark"><time class="entry-date published" datetime="2019-10-11T20:47:27+11:00">October 11, 2019<span class="entry-time">8:47 pm</span></time><time class="updated" hidden datetime="2019-10-11T20:49:24+11:00">October 11, 2019</time></a></span>
			</div>

		</div><!-- .entry-meta -->

		<h1 class="entry-title">Procedural pores, modeling teeth, messy fighting and other new things Weta Digital did to turn Will Smith into a 23-year-old</h1>
	</header><!-- .entry-header -->

	
		<div class="entry-featured  entry-thumbnail">

			<img width="800" height="441" src="https://beforesandafters.com/wp-content/uploads/2019/10/GM_FF_031K_size.jpg" class="attachment-patch-single-image size-patch-single-image wp-post-image" alt="" srcset="https://beforesandafters.com/wp-content/uploads/2019/10/GM_FF_031K_size.jpg 800w, https://beforesandafters.com/wp-content/uploads/2019/10/GM_FF_031K_size-300x165.jpg 300w, https://beforesandafters.com/wp-content/uploads/2019/10/GM_FF_031K_size-768x423.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" data-attachment-id="4560" data-permalink="https://beforesandafters.com/2019/10/11/procedural-pores-modeling-teeth-messy-fighting-and-other-new-things-weta-digital-did-to-turn-will-smith-into-a-23-year-old/null-39/" data-orig-file="https://beforesandafters.com/wp-content/uploads/2019/10/GM_FF_031K_size.jpg" data-orig-size="800,441" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;Paramount Pictures&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;Will Smith as \&quot;Junior\&quot; in Gemini Man from Paramount Pictures, Skydance and Jerry Bruckheimer Films.&quot;,&quot;created_timestamp&quot;:&quot;1559817526&quot;,&quot;copyright&quot;:&quot;\u00a9\u00a02019 Paramount Pictures. All Rights Reserved.&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;null&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="null" data-image-description="" data-medium-file="https://beforesandafters.com/wp-content/uploads/2019/10/GM_FF_031K_size-300x165.jpg" data-large-file="https://beforesandafters.com/wp-content/uploads/2019/10/GM_FF_031K_size.jpg" />
		</div>

	
	<div class="entry-content">

		<p>Weta Digital has made photoreal CG humans before (<em>Furious 7, Iron Man 3, Guardians of the Galaxy Vol. 2</em>), and it’s made photoreal CG characters based on actor performances before, too (<em>Avatar, Apes</em> films, <em>Alita: Battle Angel, Avengers: Infinity War</em> and <em>Endgame</em>).</p>
<p>The studio constantly refines its expertise in performance; all the way from the original motion capture, through to motion editing, keyframe animation and into the many, many details that make up these digital humans and characters.</p>
<p><span class="alignnone"><img data-attachment-id="4556" data-permalink="https://beforesandafters.com/2019/10/11/procedural-pores-modeling-teeth-messy-fighting-and-other-new-things-weta-digital-did-to-turn-will-smith-into-a-23-year-old/gemini-man-3/" data-orig-file="https://beforesandafters.com/wp-content/uploads/2019/10/gmff035_0.jpg" data-orig-size="1200,669" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;Paramount Pictures&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;Will Smith in Gemini Man from Paramount Pictures, Skydance and Jerry Bruckheimer Films.&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;\u00a9 2019 PARAMOUNT PICTURES. ALL RIGHTS RESERVED.&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;GEMINI MAN&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="" data-image-description="" data-medium-file="https://beforesandafters.com/wp-content/uploads/2019/10/gmff035_0-300x167.jpg" data-large-file="https://beforesandafters.com/wp-content/uploads/2019/10/gmff035_0-1024x571.jpg" class="alignnone size-full wp-image-4556" src="https://beforesandafters.com/wp-content/uploads/2019/10/gmff035_0.jpg" alt="" width="1200" height="669" srcset="https://beforesandafters.com/wp-content/uploads/2019/10/gmff035_0.jpg 1200w, https://beforesandafters.com/wp-content/uploads/2019/10/gmff035_0-300x167.jpg 300w, https://beforesandafters.com/wp-content/uploads/2019/10/gmff035_0-768x428.jpg 768w, https://beforesandafters.com/wp-content/uploads/2019/10/gmff035_0-1024x571.jpg 1024w, https://beforesandafters.com/wp-content/uploads/2019/10/gmff035_0-800x445.jpg 800w" sizes="(max-width: 1200px) 100vw, 1200px" /></span></p>
<p>For Ang Lee’s <em>Gemini Man</em>, where Weta Digital created a completely digital 23 year-old Will Smith who ‘acts’ alongside the real 50 year old Will Smith, I wanted to ask the studio what new things in particular were done to achieve this, and what new challenges they faced, given this was a high-frame rate film shot in native stereo.</p>
<p>Weta Digital visual effects supervisor Guy Williams, working under production VFX supervisor Bill Westenhofer, led a team that included co-visual effects supervisor Sheldon Stopsack and animation supervisor Paul Story, that continued to advance the studio’s character pipeline. Here, Williams runs down a hit list of 10 new digital human advancements, all the way from what proof of concepts were done, to the shooting methodology &#8211; including the idea of &#8216;messy fighting &#8211; and then individual CG approaches such as a new procedural pore system and the use of Deep Shapes.</p>
<h3>#1 &#8211; the A/B approach to shooting</h3>
<p><strong>Guy Williams</strong>: For filming, we landed on what we called the A/B approach, because Will had to be in the frame twice. First we shot Will as the character Henry in costume and makeup opposite an acting double who was playing the part of Junior (the younger clone of Henry). We shot clean plates so we could paint the acting double out.</p>
<p><span class="alignnone"><img data-attachment-id="4549" data-permalink="https://beforesandafters.com/2019/10/11/procedural-pores-modeling-teeth-messy-fighting-and-other-new-things-weta-digital-did-to-turn-will-smith-into-a-23-year-old/null-33/" data-orig-file="https://beforesandafters.com/wp-content/uploads/2019/10/GM_12362R.jpg" data-orig-size="1200,800" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;2.8&quot;,&quot;credit&quot;:&quot;Ben Rothstein&quot;,&quot;camera&quot;:&quot;X-H1&quot;,&quot;caption&quot;:&quot;Will Smith and Mary Elizabeth Winstead on the set of Gemini Man from Paramount Pictures, Skydance and Jerry Bruckheimer Films.&quot;,&quot;created_timestamp&quot;:&quot;1528477089&quot;,&quot;copyright&quot;:&quot;\u00a9 2019 Paramount Pictures. All Rights Reserved.&quot;,&quot;focal_length&quot;:&quot;38.8&quot;,&quot;iso&quot;:&quot;2500&quot;,&quot;shutter_speed&quot;:&quot;0.004&quot;,&quot;title&quot;:&quot;null&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="null" data-image-description="" data-medium-file="https://beforesandafters.com/wp-content/uploads/2019/10/GM_12362R-300x200.jpg" data-large-file="https://beforesandafters.com/wp-content/uploads/2019/10/GM_12362R-1024x683.jpg" class="alignnone size-full wp-image-4549" src="https://beforesandafters.com/wp-content/uploads/2019/10/GM_12362R.jpg" alt="" width="1200" height="800" srcset="https://beforesandafters.com/wp-content/uploads/2019/10/GM_12362R.jpg 1200w, https://beforesandafters.com/wp-content/uploads/2019/10/GM_12362R-300x200.jpg 300w, https://beforesandafters.com/wp-content/uploads/2019/10/GM_12362R-768x512.jpg 768w, https://beforesandafters.com/wp-content/uploads/2019/10/GM_12362R-1024x683.jpg 1024w" sizes="(max-width: 1200px) 100vw, 1200px" /></span></p>
<p>At the end of the live action shoot, we set up a mocap stage and reversed the roles so that Will would be playing the Junior character wearing mocap gear and the acting double was playing the Henry character. We’d pick a favorite take, sync up all the audio and record it all again with Will for a second performance. One of the new things here was witness cameras &#8211; we had to get some RED RAVENs just to guarantee that we&#8217;d be able to go 120 fps true, that we could gen-lock (since the film is shot 120 fps).</p>
<p>One thing that we realized later on was that if Will wasn’t in frame with himself, we could just capture him in-situ. So we would just mark up his face and put the helmet rig on him and shoot the shot live action. And then ‘all’ we had to do was paint out his head and replace his head with a younger person of himself.</p>
<h3>#2 &#8211; The Pepsi challenge</h3>
<p>As part of our process of making sure we were on the right track, we did what we called the ‘Pepsi challenge’ with footage, but first we used photographs. We picked four photographs from various movies that we thought were iconic Will Smith. And then the goal was to line up our digital Will Smith to those photographs, light it as accurately as we could and put them side by side and see if you could tell which photograph is which.</p>
<p>We’d constantly shuffle the order so you couldn’t tell which one was the digital one. We eventually got to a point where it got hard to tell. That was probably the Will Smith 1.0. The one you see in the movie is probably Will Smith 35.0.</p>
<div class="jetpack-video-wrapper">
<div class="arve-wrapper" data-mode="normal" data-provider="youtube" id="arve-k5y4kxhZIBA" style="max-width:980px;" itemscope itemtype="http://schema.org/VideoObject">
<div class="arve-embed-container" style="padding-bottom:56.250000%"><iframe allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen class="arve-iframe fitvidsignore" frameborder="0" name sandbox="allow-scripts allow-same-origin allow-presentation allow-popups allow-popups-to-escape-sandbox" scrolling="no" src="https://www.youtube-nocookie.com/embed/k5y4kxhZIBA?iv_load_policy=3&#038;modestbranding=1&#038;rel=0&#038;autohide=1&#038;playsinline=1&#038;autoplay=0" width="480" height="270"></iframe></div>
</div>
</div>
<p>Then came the Pepsi challenge. We took a scene from <em>Bad Boys</em> where Will Smith and Martin Lawrence are in the car together talking and there&#8217;s a lot of back and forth. There’s 30 some odd shots in the scene. What we did was we took two of the shots of Will Smith and painted him out and replaced them with a digital Smith. Same performance, same audio, same everything. And the goal was to get to the point where when you watch the one minute long cut and then turn to the audience and say, tell me which two shots we replaced, that it became very hard to tell.</p>
<p>These are the kinds of things that you have to do to just have the confidence internally that you&#8217;re doing the right thing, that you&#8217;re on the right track. You can’t just build a Will Smith on a gray turntable and say, yes, I believe that that is Will Smith. You constantly want to find the most damning tests that you can do, put it through that test and if it fails, then you need to go back through the wash.</p>
<h3>#3 &#8211; A procedural pore system</h3>
<p>The major thing that we did that we hadn&#8217;t done before was a procedural pore system. Typically what you would do for skin detail, is you&#8217;d take a live cast of the actor, create a plaster mold for that, then do small latex sheets out of the mold, and then put those on a flatbed scanner and then do a lot of careful registration to get those pores to line back up to get those pores to align back up to the texture of the face. You get really accurate pores that way. It’s just that the shape of the pores isn&#8217;t perfect because you&#8217;re taking it from a flat mold, not an actual three-dimensional object, so you’re losing the detail at the scanning point.</p>
<p><span class="aligncenter"><img data-attachment-id="4547" data-permalink="https://beforesandafters.com/2019/10/11/procedural-pores-modeling-teeth-messy-fighting-and-other-new-things-weta-digital-did-to-turn-will-smith-into-a-23-year-old/pores/" data-orig-file="https://beforesandafters.com/wp-content/uploads/2019/10/pores.gif" data-orig-size="480,270" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="pores" data-image-description="" data-medium-file="https://beforesandafters.com/wp-content/uploads/2019/10/pores-300x169.gif" data-large-file="https://beforesandafters.com/wp-content/uploads/2019/10/pores.gif" class="aligncenter size-full wp-image-4547" src="https://beforesandafters.com/wp-content/uploads/2019/10/pores.gif" alt="" width="480" height="270" /></span></p>
<p>What we did this time was, we actually came up with a system for growing the pores on the face. It used flow maps, because pores obviously have a flow and structure to them. From there you can control things like anisotropy, depth, width and height. And we just kept on iterating on small areas until we got to look exactly like what the actor looked like. Now, obviously every pore isn’t in exactly the correct space, but in any given area it was the right shape and the right size. The added benefit of this system is that you get a perfect shape of the pore, the right round shapes.</p>
<p>Then we could take that pore system and once the face was animated, we could run a tetrahedral solve on top of that, allowing us to get, not just wrinkles, but wrinkles forming along pore lines, and also the pores collapsing in the correct ways. Pores are sort-of shaped like diamonds &#8211; they can collapse in multiple ways but they have a dominant way of collapsing.</p>
<p>All that came along with the simulation process &#8211; we scripted that out so that every shot that had animation, we could nominate shots to simulate and they could run overnight.</p>
<p><span class="alignnone"><img data-attachment-id="4551" data-permalink="https://beforesandafters.com/2019/10/11/procedural-pores-modeling-teeth-messy-fighting-and-other-new-things-weta-digital-did-to-turn-will-smith-into-a-23-year-old/null-35/" data-orig-file="https://beforesandafters.com/wp-content/uploads/2019/10/GM_FF_013K.jpg" data-orig-size="1200,675" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;Paramount Pictures&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;Will Smith as \&quot;Junior\&quot; in Gemini Man from Paramount Pictures, Skydance and Jerry Bruckheimer Films.&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;\u00a9\u00a02019 Paramount Pictures. All Rights Reserved.&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;null&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="null" data-image-description="" data-medium-file="https://beforesandafters.com/wp-content/uploads/2019/10/GM_FF_013K-300x169.jpg" data-large-file="https://beforesandafters.com/wp-content/uploads/2019/10/GM_FF_013K-1024x576.jpg" class="alignnone size-full wp-image-4551" src="https://beforesandafters.com/wp-content/uploads/2019/10/GM_FF_013K.jpg" alt="" width="1200" height="675" srcset="https://beforesandafters.com/wp-content/uploads/2019/10/GM_FF_013K.jpg 1200w, https://beforesandafters.com/wp-content/uploads/2019/10/GM_FF_013K-300x169.jpg 300w, https://beforesandafters.com/wp-content/uploads/2019/10/GM_FF_013K-768x432.jpg 768w, https://beforesandafters.com/wp-content/uploads/2019/10/GM_FF_013K-1024x576.jpg 1024w" sizes="(max-width: 1200px) 100vw, 1200px" /></span></p>
<h3>#4 &#8211; Defining the skin in terms of melanin</h3>
<p>We define the skin in terms of melanin. Specifically eumelanin, and pheomelanin, which are the two sub-types of melanin that define colors. The important thing about that is, instead of just painting a simple color map for the face, we actually end up with something that, depending on which angle you look at it, it looks correct. So light enters the skin, interacts with the correct melanin, and gives you the correct spectral responses that come back out and gives you a visual result, as opposed to just bouncing off the color map. The advantage of that was the skin can be very view dependent. You can see different colors depending on what angles you look at the skin. Also when you do tricks like blood flow, which we did, when you scrunch up your face, you squeeze blood out of certain areas. This was handled in our spectral renderer Manuka.</p>
<h3> #5 &#8211; Deep shapes</h3>
<p>One of our animators came up with this system called Deep Shapes (which was also used on <a href="https://beforesandafters.com/2019/05/16/hey-thanos-whats-new-with-you/">Endgame</a>). It basically treats the blend shapes of the face as different depths of the skin, so that over time, as the muscle starts to move the skin follows after. So there&#8217;s this delay effect that gives you this beautiful naturalistic move. For example, when your eyes blink, instead of the lid coming down and going right back up, the lid comes down but as it starts to go up the eyelid, the eye bag is still traveling down ever so slightly &#8211; it just gives you this much more naturalistic skin solution.</p>
<p><span class="alignnone"><img data-attachment-id="4553" data-permalink="https://beforesandafters.com/2019/10/11/procedural-pores-modeling-teeth-messy-fighting-and-other-new-things-weta-digital-did-to-turn-will-smith-into-a-23-year-old/null-37/" data-orig-file="https://beforesandafters.com/wp-content/uploads/2019/10/GM_FF_027K.jpg" data-orig-size="1200,648" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;Paramount Pictures.&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;Clive Owen and Will Smith as \&quot;Junior\&quot; in Gemini Man from Paramount Pictures, Sydance and Jerry Bruckheimer Films.&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;\u00a9 2019 Paramount Pictures. All Rights Reserved.&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;null&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="null" data-image-description="" data-medium-file="https://beforesandafters.com/wp-content/uploads/2019/10/GM_FF_027K-300x162.jpg" data-large-file="https://beforesandafters.com/wp-content/uploads/2019/10/GM_FF_027K-1024x553.jpg" class="alignnone size-full wp-image-4553" src="https://beforesandafters.com/wp-content/uploads/2019/10/GM_FF_027K.jpg" alt="" width="1200" height="648" srcset="https://beforesandafters.com/wp-content/uploads/2019/10/GM_FF_027K.jpg 1200w, https://beforesandafters.com/wp-content/uploads/2019/10/GM_FF_027K-300x162.jpg 300w, https://beforesandafters.com/wp-content/uploads/2019/10/GM_FF_027K-768x415.jpg 768w, https://beforesandafters.com/wp-content/uploads/2019/10/GM_FF_027K-1024x553.jpg 1024w" sizes="(max-width: 1200px) 100vw, 1200px" /></span></p>
<h3>#6 &#8211; Teeth and eye modeling</h3>
<p>We modeled the teeth correctly this time. We actually modeled them as two volumes. The dentine and the enamel were modeled separately. So they actually get a proper transition from yellow to blue in the teeth.</p>
<p>For the eyes, we modeled the conjunctiva, to make sure the corner of the eyes go that little bit yellow that they&#8217;re supposed to go. It&#8217;s not just mapped onto the eyeball. So, we were able to also do things such as when the the eye looks left and the iris stays in the corner just that little bit longer to look more realistic.</p>
<h3>#7 &#8211; Fighting ‘messy’</h3>
<p>Ang had this idea of what he called &#8216;messy fighting&#8217;, which is, when two stunt people fight, there&#8217;s sort of a timed choreography to it, which sometimes makes it look like they are anticipating the next beat. Stunt performers have done amazing work over the years of trying to hide that choreography so it feels like people fighting. The thing is, in stereo at 120 fps, it becomes obvious that it&#8217;s a dance and that it&#8217;s not really fighting. So Ang wanted to take it this next level, what he called messy fighting, which is break the choreography up, mess with the timing, mess with the freneticism and make sure the contact’s actually contact.</p>
<div class="jetpack-video-wrapper">
<div class="arve-wrapper" data-mode="normal" data-provider="youtube" id="arve-yPlY9HGErc8" style="max-width:980px;" itemscope itemtype="http://schema.org/VideoObject">
<div class="arve-embed-container" style="padding-bottom:56.250000%"><iframe allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen class="arve-iframe fitvidsignore" frameborder="0" name sandbox="allow-scripts allow-same-origin allow-presentation allow-popups allow-popups-to-escape-sandbox" scrolling="no" src="https://www.youtube-nocookie.com/embed/yPlY9HGErc8?iv_load_policy=3&#038;modestbranding=1&#038;rel=0&#038;autohide=1&#038;playsinline=1&#038;autoplay=0" width="480" height="270"></iframe></div>
</div>
</div>
<p>For example, we had to make sure the head doesn&#8217;t start moving until after the fist is half-way into it, pushing it sideways. That required a lot of effort, because it was pretty quick to get to a digital fight, but then we just kept on changing the timing and kept on changing the speeds and trying to make it look less and less like two stunt performers and more and more like just two talented fighters beating the snot out of each other. We had to do simulations on the face so that when it punched in right really hard, you actually saw the cheeks and the ears wobble around.</p>
<h3>#8 &#8211; 4K, 120 fps, native stereo (oh my)</h3>
<p><em>Gemini Man</em> is 4K stereo at 120 fps and native stereo, so you end up with 40 times the data (5 times as many frames, 4 times as many pixels per frame and 2 eyes). What that means is if you put a Quicktime in our internal view system, it takes 40 times as long to create the Quicktime. It could take upwards of six hours just to drop the clips to the system &#8211; one 2-minute long shot took that long to put in our system.</p>
<p>So, you&#8217;d seen it in the morning, give notes, you&#8217;d see it in the afternoon, you give notes, knowing that the version you were going to see next, you either were going to send or not send- you couldn’t get a revision on it. It would just take too long to see again. There was a significant burden on the day to day work of the artists. The amount of data being pushed back and forth was astronomical.</p>
<div class="jetpack-video-wrapper">
<div class="arve-wrapper" data-mode="normal" data-provider="youtube" id="arve-9lJa8iKCWOM" style="max-width:980px;" itemscope itemtype="http://schema.org/VideoObject">
<div class="arve-embed-container" style="padding-bottom:56.250000%"><iframe allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen class="arve-iframe fitvidsignore" frameborder="0" name sandbox="allow-scripts allow-same-origin allow-presentation allow-popups allow-popups-to-escape-sandbox" scrolling="no" src="https://www.youtube-nocookie.com/embed/9lJa8iKCWOM?iv_load_policy=3&#038;modestbranding=1&#038;rel=0&#038;autohide=1&#038;playsinline=1&#038;autoplay=0" width="480" height="270"></iframe></div>
</div>
</div>
<p>It didn&#8217;t really change the mocap at all because mocap already captures at 120 fps. That was sort of like, everyone&#8217;s like, ‘Yay!. We don&#8217;t need to capture higher than 120 because the face really can&#8217;t move that fast. It’s not like there&#8217;s information that we&#8217;re losing beyond 120.</p>
<p>Some processes are painfully linear, like roto &#8211; these amazing paint and roto artists, they work per-pixel. So, if you increase the data set by 40 times, it just means there work becomes really long. That took a lot of scheduling. Kudos to the production team for juggling those 10,000 balls all at the same time to make sure that everything came together in the end at the right time.</p>
<p>And then the challenge of native stereo is that it&#8217;s not theoretically perfect. In other words, you can’t say, &#8216;We know that the eyes are exactly this far apart, just track one camera and we&#8217;re done.&#8217; You actually have to track both cameras as if they&#8217;re unique cameras because they do have slight imperfections and inconsistencies. And it&#8217;s one thing to say that you don&#8217;t mind those imperfections, but it manifests itself in one eye that the character’s not sitting on the bike, he&#8217;s sitting one inch to the right of the bike. So you have to make sure that you get all that right.</p>
<p><span class="alignnone"><img data-attachment-id="4550" data-permalink="https://beforesandafters.com/2019/10/11/procedural-pores-modeling-teeth-messy-fighting-and-other-new-things-weta-digital-did-to-turn-will-smith-into-a-23-year-old/null-34/" data-orig-file="https://beforesandafters.com/wp-content/uploads/2019/10/GM_FF_001K.jpg" data-orig-size="1200,673" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;Paramount Pictures&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;Will Smith as \&quot;Junior\&quot; in Gemini Man from Paramount Pictures, Skydance and Jerry Bruckheimer Films.&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;\u00a9\u00a02019 Paramount Pictures. All Rights Reserved.&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;null&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="null" data-image-description="" data-medium-file="https://beforesandafters.com/wp-content/uploads/2019/10/GM_FF_001K-300x168.jpg" data-large-file="https://beforesandafters.com/wp-content/uploads/2019/10/GM_FF_001K-1024x574.jpg" class="alignnone size-full wp-image-4550" src="https://beforesandafters.com/wp-content/uploads/2019/10/GM_FF_001K.jpg" alt="" width="1200" height="673" srcset="https://beforesandafters.com/wp-content/uploads/2019/10/GM_FF_001K.jpg 1200w, https://beforesandafters.com/wp-content/uploads/2019/10/GM_FF_001K-300x168.jpg 300w, https://beforesandafters.com/wp-content/uploads/2019/10/GM_FF_001K-768x431.jpg 768w, https://beforesandafters.com/wp-content/uploads/2019/10/GM_FF_001K-1024x574.jpg 1024w" sizes="(max-width: 1200px) 100vw, 1200px" /></span></p>
<h3>#9 &#8211; Replace the body in CG, or not?</h3>
<p>Whether we went completely CG with Junior was all about figuring out what mattered. And what I mean by that is that when you look at a shot, if it&#8217;s performance driven, then the body has to be Will Smith’s body. And if Will Smith’s already in the frame, it can&#8217;t be Will Smith’s body, it has to be a fully digital body from the mocap. So it&#8217;s still Will’s performance.</p>
<p>The thing we kept on saying is that even when an actor is not talking, they&#8217;re still acting. At an empirical level, if you just do a head replacement on another actor’s body, it starts to feel like a bobblehead. It feels like it&#8217;s not connected, like it doesn&#8217;t match. One of the reasons is, when you talk you tend to gesture. Your body is doing very subtle things that reinforce what the head is doing. So if you replace the head and not the body, you create disconnects.</p>
<div class="jetpack-video-wrapper">
<div class="arve-wrapper" data-mode="normal" data-provider="youtube" id="arve-2ldrMDw1oSg" style="max-width:980px;" itemscope itemtype="http://schema.org/VideoObject">
<div class="arve-embed-container" style="padding-bottom:56.250000%"><iframe allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen class="arve-iframe fitvidsignore" frameborder="0" name sandbox="allow-scripts allow-same-origin allow-presentation allow-popups allow-popups-to-escape-sandbox" scrolling="no" src="https://www.youtube-nocookie.com/embed/2ldrMDw1oSg?iv_load_policy=3&#038;modestbranding=1&#038;rel=0&#038;autohide=1&#038;playsinline=1&#038;autoplay=0" width="480" height="270"></iframe></div>
</div>
</div>
<p>So in those situations we always replaced the body, full, top to bottom, CG clothes, CG outfits, everything. The only time we got away without doing that, there were two special cases.</p>
<p>In certain situations when Will Smith was not performing against another Will Smith, then Will was able to get made up for the Junior role. We&#8217;d put clothes on him because he looks like Junior, and then we can replace his head because the body was the performance we wanted. That would save us some time in mocap later.</p>
<p>The other situation is when it was a stunt, say riding a bike at 50 miles an hour as he goes across the wall that&#8217;s only one foot wide. The performance that you want is the performance that the stunt person is giving you. Will Smith isn’t going to be able to give you something better because he can&#8217;t ride a bike 50 miles an hour on a one foot wide wall. So in those situations, we kept the performer&#8217;s body, for the most part. In some situations &#8211; this is sort of the rule of thumb, but then it was always broken &#8211; the exception in this case was that Junior’s stunt rider was significantly smaller than Junior. So we replaced them from the waist up. Now if you look really closely, you&#8217;ll notice that his legs are about two inches too short. But it&#8217;s hard to tell because his legs are folded on the bike.</p>
<p><span class="alignnone"><img data-attachment-id="4552" data-permalink="https://beforesandafters.com/2019/10/11/procedural-pores-modeling-teeth-messy-fighting-and-other-new-things-weta-digital-did-to-turn-will-smith-into-a-23-year-old/null-36/" data-orig-file="https://beforesandafters.com/wp-content/uploads/2019/10/GM_FF_014K.jpg" data-orig-size="1200,675" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;Paramount Pictures&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;Will Smith as \&quot;Junior\&quot; and \&quot;Henry\&quot;  in Gemini Man from Paramount Pictures, Skydance and Jerry Bruckheimer Films.&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;\u00a9 2019 Paramount Pictures. All Rights Reserved.&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;null&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="" data-image-description="" data-medium-file="https://beforesandafters.com/wp-content/uploads/2019/10/GM_FF_014K-300x169.jpg" data-large-file="https://beforesandafters.com/wp-content/uploads/2019/10/GM_FF_014K-1024x576.jpg" class="alignnone size-full wp-image-4552" src="https://beforesandafters.com/wp-content/uploads/2019/10/GM_FF_014K.jpg" alt="" width="1200" height="675" srcset="https://beforesandafters.com/wp-content/uploads/2019/10/GM_FF_014K.jpg 1200w, https://beforesandafters.com/wp-content/uploads/2019/10/GM_FF_014K-300x169.jpg 300w, https://beforesandafters.com/wp-content/uploads/2019/10/GM_FF_014K-768x432.jpg 768w, https://beforesandafters.com/wp-content/uploads/2019/10/GM_FF_014K-1024x576.jpg 1024w" sizes="(max-width: 1200px) 100vw, 1200px" /></span></p>
<h3>#10 &#8211; Determining (and discussing) likeness</h3>
<p>We found that ‘likeness’ was a razor’s edge. It was really quick to get a Will Smith that looked interesting and looked like the right Will Smith. That wasn&#8217;t hard to do. The second he started animating or the second the camera angle changed, your mind instantly finds a new anchor to look for. So what we found was that we had to just constantly, constantly, constantly work on the system so that every time we found the new situation that didn&#8217;t hold up it got elevated.</p>
<p>To some degree we do that with all animation. That&#8217;s the process of making sure that the character comes through. But this was like 10 times harder. On top of getting the animation right, you had to go through and make sure any one of those animation shapes that are so critical to getting performance don&#8217;t undermine likeness.</p>
<div class="jetpack-video-wrapper">
<div class="arve-wrapper" data-mode="normal" data-provider="youtube" id="arve-k1C-pToEkyk" style="max-width:980px;" itemscope itemtype="http://schema.org/VideoObject">
<div class="arve-embed-container" style="padding-bottom:56.250000%"><iframe allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen class="arve-iframe fitvidsignore" frameborder="0" name sandbox="allow-scripts allow-same-origin allow-presentation allow-popups allow-popups-to-escape-sandbox" scrolling="no" src="https://www.youtube-nocookie.com/embed/k1C-pToEkyk?iv_load_policy=3&#038;modestbranding=1&#038;rel=0&#038;autohide=1&#038;playsinline=1&#038;autoplay=0" width="480" height="270"></iframe></div>
</div>
</div>
<p>In reviews, people would sometimes say, &#8216;It feels like Will’s cousin. It feels like a real person, it kinda looks like Will, but not exactly like him.&#8217; Those become just incredibly esoteric questions to answer. What was surprising was that you could go off-model but he would still be believable as a breathing character. We didn&#8217;t expect likeness and believability to be so uncoupled. We thought that they would be heavily coupled and once we got believability, then if we got likeness on one frame then it would follow through. That turned out not to be the case at all.</p>
<p>If you imagine that a facial system is made up of hundreds of shapes and that those hundreds of shapes can create thousands, if not tens of thousands, of in-between shapes. If any one of those in-between shapes is wrong, or even slightly wrong then you don&#8217;t recognize it as Will Smith anymore. One of the animators described it as just constantly surfing on a razor&#8217;s edge, trying not to fall off one side or the other towards unlikeness. Until the last day we were still just chasing it.</p>
<a href="https://www.patreon.com/beforesandafters">Get exclusive content, join the befores & afters Patreon community</a><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-4545" class="share-twitter sd-button share-icon" href="https://beforesandafters.com/2019/10/11/procedural-pores-modeling-teeth-messy-fighting-and-other-new-things-weta-digital-did-to-turn-will-smith-into-a-23-year-old/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-4545" class="share-facebook sd-button share-icon" href="https://beforesandafters.com/2019/10/11/procedural-pores-modeling-teeth-messy-fighting-and-other-new-things-weta-digital-did-to-turn-will-smith-into-a-23-year-old/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-end"></li></ul></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-154221204-4545-5da0825c93350' data-src='https://widgets.wp.com/likes/#blog_id=154221204&amp;post_id=4545&amp;origin=beforesandafters.com&amp;obj_id=154221204-4545-5da0825c93350' data-name='like-post-frame-154221204-4545-5da0825c93350'><h3 class="sd-title">Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div>
		
	</div><!-- .entry-content -->

	<footer class="entry-footer">

		<span class="screen-reader-text">Tagged with: </span><span class="tags-links"><a href="https://beforesandafters.com/tag/gemini-man/" rel="tag">Gemini Man</a> <a href="https://beforesandafters.com/tag/guy-williams/" rel="tag">Guy Williams</a> <a href="https://beforesandafters.com/tag/weta-digital/" rel="tag">Weta Digital</a></span>
	</footer><!-- .entry-footer -->
</article><!-- #post-## -->
<aside>
	<div id="comments" class="comments-area  no-comments">
		<div class="comments-area-title">
			<h2 class="comments-title"><span class="comment-number  comment-number--dark  no-comments">i</span>There are no comments</h2>
			<a class="comments_add-comment" href="#reply-title">Add yours</a>		</div>
		
	</div>
	<!-- #comments .comments-area -->
	
	
		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">Leave a Reply					<small><a rel="nofollow" id="cancel-comment-reply-link" href="/2019/10/11/procedural-pores-modeling-teeth-messy-fighting-and-other-new-things-weta-digital-did-to-turn-will-smith-into-a-23-year-old/#respond" style="display:none;">Cancel reply</a></small>
				</h3>
						<form id="commentform" class="comment-form">
				<iframe title="Comment Form" src="https://jetpack.wordpress.com/jetpack-comment/?blogid=154221204&#038;postid=4545&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=0&#038;avatar_default=identicon&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=7.8&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=e848287f9d81265b0d2c5cc8461360a3ddaf3ecc#parent=https%3A%2F%2Fbeforesandafters.com%2F2019%2F10%2F11%2Fprocedural-pores-modeling-teeth-messy-fighting-and-other-new-things-weta-digital-did-to-turn-will-smith-into-a-23-year-old%2F" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment" sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups"></iframe>
									<!--[if !IE]><!-->
					<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = false;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
					<!--<![endif]-->
							</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

		
</aside>
		</main><!-- #main -->
	</div><!-- #primary -->


<div id="secondary" class="sidebar" role="complementary">

	<aside id="custom_html-18" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div class="befor-sidebar" id="befor-659789388"><a href="https://sa2019.siggraph.org/registration?utm_source=beforesandafters&#038;utm_medium=banner&#038;utm_campaign=website"><img width="300" height="250" src='https://beforesandafters.com/wp-content/uploads/2019/09/SA19_300x250-VP.gif' alt=''  /></a></div></div></aside>		<aside id="recent-posts-10" class="widget widget_recent_entries">		<h4 class="widget-title">Don&#8217;t Miss</h4>		<ul>
											<li>
					<a href="https://beforesandafters.com/2019/10/11/procedural-pores-modeling-teeth-messy-fighting-and-other-new-things-weta-digital-did-to-turn-will-smith-into-a-23-year-old/">Procedural pores, modeling teeth, messy fighting and other new things Weta Digital did to turn Will Smith into a 23-year-old</a>
									</li>
											<li>
					<a href="https://beforesandafters.com/2019/10/11/klaus-is-coming-and-youre-going-to-be-fascinated-about-how-this-2d-animated-film-was-made/">&#8216;Klaus&#8217; is coming, and you&#8217;re going to be fascinated about how this 2D animated film was made</a>
									</li>
											<li>
					<a href="https://beforesandafters.com/2019/10/10/a-brief-history-of-will-smiths-incredible-digital-alter-egos/">A brief history of Will Smith&#8217;s incredible digital alter egos</a>
									</li>
											<li>
					<a href="https://beforesandafters.com/2019/10/08/motion-controlled-robots-controlled-by-maya/">Motion controlled robots, controlled by&#8230;Maya!</a>
									</li>
											<li>
					<a href="https://beforesandafters.com/2019/10/07/you-might-be-surprised-how-thing-was-made-for-the-addams-family/">You might be surprised how Thing was made for &#8216;The Addams Family&#8217;</a>
									</li>
					</ul>
		</aside><aside id="mc4wp_form_widget-7" class="widget widget_mc4wp_form_widget"><h4 class="widget-title">Sign up for the Newsletter</h4><script>(function() {
	if (!window.mc4wp) {
		window.mc4wp = {
			listeners: [],
			forms    : {
				on: function (event, callback) {
					window.mc4wp.listeners.push({
						event   : event,
						callback: callback
					});
				}
			}
		}
	}
})();
</script><!-- Mailchimp for WordPress v4.6.1 - https://wordpress.org/plugins/mailchimp-for-wp/ --><form id="mc4wp-form-1" class="mc4wp-form mc4wp-form-258 mc4wp-form-theme mc4wp-form-theme-light" method="post" data-id="258" data-name="Befores &amp; Afters - The Newsletter" ><div class="mc4wp-form-fields"><label> </label>
	<input type="email" name="EMAIL" placeholder="Your email address" required />

	<input type="submit" value="Sign up" /></div><label style="display: none !important;">Leave this field empty if you're human: <input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off" /></label><input type="hidden" name="_mc4wp_timestamp" value="1570800220" /><input type="hidden" name="_mc4wp_form_id" value="258" /><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-1" /><div class="mc4wp-response"></div></form><!-- / Mailchimp for WordPress Plugin --></aside>
</div><!-- #secondary -->		</div><!-- .container -->
	</div><!-- #content -->

	<footer id="colophon" class="site-footer" role="contentinfo">
		<div class="site-info">
			<a href="https://wordpress.com/?ref=footer_custom_com">WordPress.com</a>.
			
					</div><!-- .site-info
		--><div class="back-to-top-wrapper">
			<a href="#top" class="back-to-top-button"><svg width="10px" height="19px" viewBox="0 0 10 19" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink">
	<defs></defs>
	<g id="Page-1" stroke="none" stroke-width="1" fill="none" fill-rule="evenodd">
		<g id="Rectangle-2-+--">
			<rect id="bar" fill="#ffde00" x="0" y="0" width="10" height="3"></rect>
			<path d="M5,5.953125 L9,12 L1,12 L5,5.953125 Z M4,12 L6,12 L6,19 L4,19 L4,12 Z" id="arrow" fill="#FFFFFF"></path>
		</g>
	</g>
</svg></a>
		</div><!--
		-->	</footer><!-- #colophon -->
	<div class="overlay--search">
		<div class="overlay__wrapper">
			<form role="search" method="get" class="search-form" action="https://beforesandafters.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" title="Search for:" />
				</label>
				<button class="search-submit"><i class="fa fa-search"></i></button>
			</form>			<p>Begin typing your search above and press return to search. Press Esc to cancel.</p>
		</div>
		<b class="overlay__close"></b>
	</div>
</div><!-- #page -->

<div class="mobile-header">
	<div class="mobile-header-wrapper">
		<button class="navigation__trigger  js-nav-trigger">
			<i class="fa fa-bars"></i><span class="screen-reader-text">Menu</span>
		</button>
		<button class="nav__item--search  search__trigger">
			<i class="fa fa-search"></i>
		</button>
	</div>
</div>

<!--  -->
		<script type="text/javascript">
				</script>
	<!-- Your Google Analytics Plugin is missing the tracking ID -->
	<div style="display:none">
	</div>
<script>(function() {function addEventListener(element,event,handler) {
	if(element.addEventListener) {
		element.addEventListener(event,handler, false);
	} else if(element.attachEvent){
		element.attachEvent('on'+event,handler);
	}
}function maybePrefixUrlField() {
	if(this.value.trim() !== '' && this.value.indexOf('http') !== 0) {
		this.value = "http://" + this.value;
	}
}

var urlFields = document.querySelectorAll('.mc4wp-form input[type="url"]');
if( urlFields && urlFields.length > 0 ) {
	for( var j=0; j < urlFields.length; j++ ) {
		addEventListener(urlFields[j],'blur',maybePrefixUrlField);
	}
}/* test if browser supports date fields */
var testInput = document.createElement('input');
testInput.setAttribute('type', 'date');
if( testInput.type !== 'date') {

	/* add placeholder & pattern to all date fields */
	var dateFields = document.querySelectorAll('.mc4wp-form input[type="date"]');
	for(var i=0; i<dateFields.length; i++) {
		if(!dateFields[i].placeholder) {
			dateFields[i].placeholder = 'YYYY-MM-DD';
		}
		if(!dateFields[i].pattern) {
			dateFields[i].pattern = '[0-9]{4}-(0[1-9]|1[012])-(0[1-9]|1[0-9]|2[0-9]|3[01])';
		}
	}
}

})();</script>
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/beforesandafters.com\/2019\/10\/11\/procedural-pores-modeling-teeth-messy-fighting-and-other-new-things-weta-digital-did-to-turn-will-smith-into-a-23-year-old\/":4545};
	</script>
				<link rel='stylesheet' id='advanced-responsive-video-embedder-css'  href='https://beforesandafters.com/wp-content/plugins/advanced-responsive-video-embedder/public/arve.min.css?ver=8.10.12' type='text/css' media='all' />
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201941'></script>
<script type='text/javascript' src='https://beforesandafters.com/wp-content/plugins/twenty20/assets/js/jquery.twenty20.js?ver=1.55'></script>
<script type='text/javascript' src='https://beforesandafters.com/wp-content/plugins/twenty20/assets/js/jquery.event.move.js?ver=1.55'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.2.3/wp-includes/js/imagesloaded.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.2.3/wp-includes/js/masonry.min.js'></script>
<script type='text/javascript' src='https://beforesandafters.com/wp-content/themes/patch/assets/js/imagesloaded.js?ver=3.1.8'></script>
<script type='text/javascript' src='https://beforesandafters.com/wp-content/themes/patch/assets/js/velocity.js?ver=1.2.2'></script>
<script type='text/javascript' src='https://beforesandafters.com/wp-content/themes/patch/assets/js/main.js?ver=1.0.0'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.2.3/wp-includes/js/comment-reply.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/7.8/_inc/build/twitter-timeline.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/7.8/_inc/build/likes/queuehandler.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.2.3/wp-includes/js/wp-embed.min.js'></script>
<script type='text/javascript' src='https://beforesandafters.com/wp-content/plugins/advanced-responsive-video-embedder/public/arve.min.js?ver=8.10.12'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/7.8/modules/theme-tools/responsive-videos/responsive-videos.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/7.8/_inc/build/spin.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/7.8/_inc/build/jquery.spin.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/beforesandafters.com\/wp-admin\/admin-ajax.php","nonce":"475894ebf8","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/beforesandafters.com\/wp-login.php?redirect_to=https%3A%2F%2Fbeforesandafters.com%2F2019%2F10%2F11%2Fprocedural-pores-modeling-teeth-messy-fighting-and-other-new-things-weta-digital-did-to-turn-will-smith-into-a-23-year-old%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/7.8/_inc/build/carousel/jetpack-carousel.min.js'></script>
<script async="async" type='text/javascript' src='https://beforesandafters.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mc4wp_forms_config = [];
/* ]]> */
</script>
<script type='text/javascript' src='https://beforesandafters.com/wp-content/plugins/mailchimp-for-wp/assets/js/forms-api.min.js?ver=4.6.1'></script>
<!--[if lte IE 9]>
<script type='text/javascript' src='https://beforesandafters.com/wp-content/plugins/mailchimp-for-wp/assets/js/third-party/placeholders.min.js?ver=4.6.1'></script>
<![endif]-->
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/7.8/_inc/build/sharedaddy/sharing.min.js'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
</script>
	<iframe src='https://widgets.wp.com/likes/master.html?ver=201941#ver=201941' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
	<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
	
		<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
		<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=154221204&postid=4545&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=0&avatar_default=identicon&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=7.8&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=e848287f9d81265b0d2c5cc8461360a3ddaf3ecc#parent=https%3A%2F%2Fbeforesandafters.com%2F2019%2F10%2F11%2Fprocedural-pores-modeling-teeth-messy-fighting-and-other-new-things-weta-digital-did-to-turn-will-smith-into-a-23-year-old%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=154221204&postid=4545&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=0&avatar_default=identicon&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=7.8&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=e848287f9d81265b0d2c5cc8461360a3ddaf3ecc#parent=https%3A%2F%2Fbeforesandafters.com%2F2019%2F10%2F11%2Fprocedural-pores-modeling-teeth-messy-fighting-and-other-new-things-weta-digital-did-to-turn-will-smith-into-a-23-year-old%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>

		<script type='text/javascript' src='https://stats.wp.com/e-201941.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:7.8',blog:'154221204',post:'4545',tz:'11',srv:'beforesandafters.com'} ]);
	_stq.push([ 'clickTrackerInit', '154221204', '4545' ]);
</script>

</body>
</html>
<!--
	generated in 0.244 seconds
	83111 bytes batcached for 300 seconds
-->
