<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11">
<link rel="pingback" href="https://beforesandafters.com/xmlrpc.php">

<link href="https://fonts.googleapis.com" rel="preconnect" crossorigin><link href="https://fonts.gstatic.com" rel="preconnect" crossorigin><title>That insane &#039;Shang-Chi&#039; bamboo scaffolding fight featured equally insane roto, reflection VFX and a fully CG Macau - befores &amp; afters</title>
<meta name='robots' content='max-image-preview:large' />
<script>window._wca = window._wca || [];</script>

<!-- This site is optimized with the Yoast SEO Premium plugin v13.4.1 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="How Rodeo FX pulled off the intricate bamboo scaffolding fight in ‘Shang-Chi’."/>
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/>
<link rel="canonical" href="https://beforesandafters.com/2021/09/20/that-insane-shang-chi-bamboo-scaffolding-fight-featured-insane-roto-reflection-vfx-and-a-fully-cg-macau/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="That insane &#039;Shang-Chi&#039; bamboo scaffolding fight featured equally insane roto, reflection VFX and a fully CG Macau - befores &amp; afters" />
<meta property="og:description" content="How Rodeo FX pulled off the intricate bamboo scaffolding fight in ‘Shang-Chi’." />
<meta property="og:url" content="https://beforesandafters.com/2021/09/20/that-insane-shang-chi-bamboo-scaffolding-fight-featured-insane-roto-reflection-vfx-and-a-fully-cg-macau/" />
<meta property="og:site_name" content="befores &amp; afters" />
<meta property="article:publisher" content="https://www.facebook.com/Befores-Afters-829036060774243/" />
<meta property="article:tag" content="Ara Khanikian" />
<meta property="article:tag" content="Rodeo FX" />
<meta property="article:tag" content="Shang-Chi and the Legend of the Ten Rings" />
<meta property="article:section" content="Articles" />
<meta property="article:published_time" content="2021-09-20T07:24:56+00:00" />
<meta property="article:modified_time" content="2021-09-20T07:30:03+00:00" />
<meta property="og:updated_time" content="2021-09-20T07:30:03+00:00" />
<meta property="og:image" content="https://beforesandafters.com/wp-content/uploads/2021/09/SBT-18015.jpg" />
<meta property="og:image:secure_url" content="https://beforesandafters.com/wp-content/uploads/2021/09/SBT-18015.jpg" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="798" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="How Rodeo FX pulled off the intricate bamboo scaffolding fight in ‘Shang-Chi’." />
<meta name="twitter:title" content="That insane &#039;Shang-Chi&#039; bamboo scaffolding fight featured equally insane roto, reflection VFX and a fully CG Macau - befores &amp; afters" />
<meta name="twitter:site" content="@ianfailes" />
<meta name="twitter:image" content="https://beforesandafters.com/wp-content/uploads/2021/09/SBT-18015.jpg" />
<meta name="twitter:creator" content="@ianfailes" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://beforesandafters.com/#organization","name":"befores & afters","url":"https://beforesandafters.com/","sameAs":["https://www.facebook.com/Befores-Afters-829036060774243/","http://instagram.com/ianfailes","https://www.linkedin.com/in/ian-failes-17154b4/","https://www.youtube.com/channel/UCDYWiGfmyQNT5tEdmiKpDKg","https://twitter.com/ianfailes"],"logo":{"@type":"ImageObject","@id":"https://beforesandafters.com/#logo","inLanguage":"en-US","url":"https://beforesandafters.com/wp-content/uploads/2020/05/beforesandafters.jpg","width":960,"height":720,"caption":"befores & afters"},"image":{"@id":"https://beforesandafters.com/#logo"}},{"@type":"WebSite","@id":"https://beforesandafters.com/#website","url":"https://beforesandafters.com/","name":"befores &amp; afters","inLanguage":"en-US","description":"visual effects magazine","publisher":{"@id":"https://beforesandafters.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://beforesandafters.com/?s={search_term_string}","query-input":"required name=search_term_string"}]},{"@type":"ImageObject","@id":"https://beforesandafters.com/2021/09/20/that-insane-shang-chi-bamboo-scaffolding-fight-featured-insane-roto-reflection-vfx-and-a-fully-cg-macau/#primaryimage","inLanguage":"en-US","url":"https://beforesandafters.com/wp-content/uploads/2021/09/SBT-18015.jpg","width":1200,"height":798},{"@type":"WebPage","@id":"https://beforesandafters.com/2021/09/20/that-insane-shang-chi-bamboo-scaffolding-fight-featured-insane-roto-reflection-vfx-and-a-fully-cg-macau/#webpage","url":"https://beforesandafters.com/2021/09/20/that-insane-shang-chi-bamboo-scaffolding-fight-featured-insane-roto-reflection-vfx-and-a-fully-cg-macau/","name":"That insane &#039;Shang-Chi&#039; bamboo scaffolding fight featured equally insane roto, reflection VFX and a fully CG Macau - befores &amp; afters","isPartOf":{"@id":"https://beforesandafters.com/#website"},"inLanguage":"en-US","primaryImageOfPage":{"@id":"https://beforesandafters.com/2021/09/20/that-insane-shang-chi-bamboo-scaffolding-fight-featured-insane-roto-reflection-vfx-and-a-fully-cg-macau/#primaryimage"},"datePublished":"2021-09-20T07:24:56+00:00","dateModified":"2021-09-20T07:30:03+00:00","description":"How Rodeo FX pulled off the intricate bamboo scaffolding fight in \u2018Shang-Chi\u2019.","potentialAction":[{"@type":"ReadAction","target":["https://beforesandafters.com/2021/09/20/that-insane-shang-chi-bamboo-scaffolding-fight-featured-insane-roto-reflection-vfx-and-a-fully-cg-macau/"]}]},{"@type":"Article","@id":"https://beforesandafters.com/2021/09/20/that-insane-shang-chi-bamboo-scaffolding-fight-featured-insane-roto-reflection-vfx-and-a-fully-cg-macau/#article","isPartOf":{"@id":"https://beforesandafters.com/2021/09/20/that-insane-shang-chi-bamboo-scaffolding-fight-featured-insane-roto-reflection-vfx-and-a-fully-cg-macau/#webpage"},"author":{"@id":"https://beforesandafters.com/#/schema/person/a05bbb1beae784a05c2b92006d5f966d"},"headline":"That insane &#8216;Shang-Chi&#8217; bamboo scaffolding fight featured equally insane roto, reflection VFX and a fully CG Macau","datePublished":"2021-09-20T07:24:56+00:00","dateModified":"2021-09-20T07:30:03+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://beforesandafters.com/2021/09/20/that-insane-shang-chi-bamboo-scaffolding-fight-featured-insane-roto-reflection-vfx-and-a-fully-cg-macau/#webpage"},"publisher":{"@id":"https://beforesandafters.com/#organization"},"image":{"@id":"https://beforesandafters.com/2021/09/20/that-insane-shang-chi-bamboo-scaffolding-fight-featured-insane-roto-reflection-vfx-and-a-fully-cg-macau/#primaryimage"},"keywords":"Ara Khanikian,Rodeo FX,Shang-Chi and the Legend of the Ten Rings","articleSection":"Articles","inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://beforesandafters.com/2021/09/20/that-insane-shang-chi-bamboo-scaffolding-fight-featured-insane-roto-reflection-vfx-and-a-fully-cg-macau/#respond"]}]},{"@type":["Person"],"@id":"https://beforesandafters.com/#/schema/person/a05bbb1beae784a05c2b92006d5f966d","name":"Ian Failes","sameAs":[]}]}</script>
<!-- / Yoast SEO Premium plugin. -->

<link rel='dns-prefetch' href='//stats.wp.com' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel='dns-prefetch' href='//widgets.wp.com' />
<link rel="alternate" type="application/rss+xml" title="befores &amp; afters &raquo; Feed" href="https://beforesandafters.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="befores &amp; afters &raquo; Comments Feed" href="https://beforesandafters.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="befores &amp; afters &raquo; That insane &#8216;Shang-Chi&#8217; bamboo scaffolding fight featured equally insane roto, reflection VFX and a fully CG Macau Comments Feed" href="https://beforesandafters.com/2021/09/20/that-insane-shang-chi-bamboo-scaffolding-fight-featured-insane-roto-reflection-vfx-and-a-fully-cg-macau/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/beforesandafters.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.8.1"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<!-- beforesandafters.com is managing ads with Advanced Ads – https://wpadvancedads.com/ --><script id="befor-ready">
			window.advanced_ads_ready=function(e,a){a=a||"complete";var d=function(e){return"interactive"===a?"loading"!==e:"complete"===e};d(document.readyState)?e():document.addEventListener("readystatechange",(function(a){d(a.target.readyState)&&e()}),{once:"interactive"===a})},window.advanced_ads_ready_queue=window.advanced_ads_ready_queue||[];		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link crossorigin="anonymous" rel='stylesheet' id='customify-font-stylesheet-0-css'  href='https://fonts.googleapis.com/css2?family=Oswald:ital,wght@0,200;0,300;0,400;0,500;0,600;0,700&#038;family=Roboto:ital,wght@0,100;0,300;0,400;0,500;0,700;0,900;1,100;1,300;1,400;1,500;1,700;1,900&#038;display=swap' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://beforesandafters.com/wp-includes/css/dist/block-library/style.min.css?ver=5.8.1' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
.has-sm-color-primary-color { color: #0f4c81 !important; }.has-sm-color-primary-background-color { background-color: #0f4c81; }.has-sm-dark-primary-color { color: #07233b !important; }.has-sm-dark-primary-background-color { background-color: #07233b; }.has-sm-dark-secondary-color { color: #0a3256 !important; }.has-sm-dark-secondary-background-color { background-color: #0a3256; }.has-sm-light-primary-color { color: #ffffff !important; }.has-sm-light-primary-background-color { background-color: #ffffff; }.has-sm-light-secondary-color { color: #fdf9f5 !important; }.has-sm-light-secondary-background-color { background-color: #fdf9f5; }
</style>
<link rel='stylesheet' id='themezee-magazine-blocks-css'  href='https://beforesandafters.com/wp-content/plugins/themezee-magazine-blocks/assets/css/themezee-magazine-blocks.css?ver=1.1.3' type='text/css' media='all' />
<link rel='stylesheet' id='mediaelement-css'  href='https://beforesandafters.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.16' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='https://beforesandafters.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=5.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='wc-blocks-vendors-style-css'  href='https://beforesandafters.com/wp-content/plugins/woocommerce/packages/woocommerce-blocks/build/wc-blocks-vendors-style.css?ver=5.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='wc-blocks-style-css'  href='https://beforesandafters.com/wp-content/plugins/woocommerce/packages/woocommerce-blocks/build/wc-blocks-style.css?ver=5.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='wp-components-css'  href='https://beforesandafters.com/wp-includes/css/dist/components/style.min.css?ver=5.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-editor-css'  href='https://beforesandafters.com/wp-includes/css/dist/block-editor/style.min.css?ver=5.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='wp-nux-css'  href='https://beforesandafters.com/wp-includes/css/dist/nux/style.min.css?ver=5.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='wp-reusable-blocks-css'  href='https://beforesandafters.com/wp-includes/css/dist/reusable-blocks/style.min.css?ver=5.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='wp-editor-css'  href='https://beforesandafters.com/wp-includes/css/dist/editor/style.min.css?ver=5.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='drop_shadow_block-style-css-css'  href='https://beforesandafters.com/wp-content/plugins/drop-shadow-boxes/block/blocks.style.build.css?ver=1.7.3' type='text/css' media='all' />
<link rel='stylesheet' id='wcz-frontend-css'  href='https://beforesandafters.com/wp-content/plugins/woocustomizer/assets/css/frontend.css?ver=2.3.3' type='text/css' media='all' />
<link rel='stylesheet' id='simple-banner-style-css'  href='https://beforesandafters.com/wp-content/plugins/simple-banner/simple-banner.css?ver=2.10.6' type='text/css' media='all' />
<link rel='stylesheet' id='virp-style-css'  href='https://beforesandafters.com/wp-content/plugins/vi-random-posts-widget/css/virp-frontend.css' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://beforesandafters.com/wp-content/plugins/vi-random-posts-widget/css/font-awesome.css' type='text/css' media='all' />
<link rel='stylesheet' id='woocommerce-layout-css'  href='https://beforesandafters.com/wp-content/plugins/woocommerce/assets/css/woocommerce-layout.css?ver=5.6.0' type='text/css' media='all' />
<style id='woocommerce-layout-inline-css' type='text/css'>

	.infinite-scroll .woocommerce-pagination {
		display: none;
	}
</style>
<link rel='stylesheet' id='woocommerce-smallscreen-css'  href='https://beforesandafters.com/wp-content/plugins/woocommerce/assets/css/woocommerce-smallscreen.css?ver=5.6.0' type='text/css' media='only screen and (max-width: 768px)' />
<link rel='stylesheet' id='woocommerce-general-css'  href='https://beforesandafters.com/wp-content/plugins/woocommerce/assets/css/woocommerce.css?ver=5.6.0' type='text/css' media='all' />
<style id='woocommerce-inline-inline-css' type='text/css'>
.woocommerce form .form-row .required { visibility: visible; }
</style>
<link rel='stylesheet' id='wp-date-remover-css'  href='https://beforesandafters.com/wp-content/plugins/wp-date-remover/public/css/wp-date-remover-public.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='mc4wp-form-themes-css'  href='https://beforesandafters.com/wp-content/plugins/mailchimp-for-wp/assets/css/form-themes.css?ver=4.8.6' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-style-css'  href='https://beforesandafters.com/wp-content/themes/patch/assets/css/font-awesome.css?ver=4.3.0' type='text/css' media='all' />
<link rel='stylesheet' id='patch-style-css'  href='https://beforesandafters.com/wp-content/themes/patch/style.css?ver=5.8.1' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='patch-fonts-css'  href='//fonts.googleapis.com/css?family=Roboto%3A500%2C400%2C300%2C500italic%2C400italic%2C300italic%7COswald%3A300%2C400%2C700&#038;subset=latin%2Clatin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='wp-calypso-bridge-masterbar-css'  href='https://beforesandafters.com/wp-content/mu-plugins/wpcomsh/vendor/automattic/wc-calypso-bridge/store-on-wpcom/assets/css/masterbar.css?ver=1.8.0' type='text/css' media='all' />
<link rel='stylesheet' id='recent-posts-widget-with-thumbnails-public-style-css'  href='https://beforesandafters.com/wp-content/plugins/recent-posts-widget-with-thumbnails/public.css?ver=7.1.1' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='open-sans-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400italic%2C600italic%2C300%2C400%2C600&#038;subset=latin%2Clatin-ext&#038;display=fallback&#038;ver=5.8.1' type='text/css' media='all' />
<style id='wcz-customizer-custom-css-inline-css' type='text/css'>
body.woocommerce .woocommerce-breadcrumb{display:none !important;}body.post-type-archive-product header.woocommerce-products-header .woocommerce-products-header__title{display:none !important;}body.woocommerce form.woocommerce-ordering{display:none !important;}body.woocommerce p.woocommerce-result-count{display:none !important;}body.wcz-btns.wcz-woocommerce ul.products li.product a.button,
					body.wcz-btns.wcz-woocommerce .related.products ul.products li.product a.button,
                    body.wcz-btns.wcz-woocommerce.single-product div.product form.cart .button,
                    body.wcz-btns.wcz-woocommerce.wcz-wooblocks ul.wc-block-grid__products li.wc-block-grid__product .add_to_cart_button{padding:12px 24px 13px !important;}body.woocommerce.wcz-woocommerce ul.products li.product .woocommerce-loop-product__title,
					body.wcz-woocommerce .products .product .woocommerce-loop-product__title,
                    body.wcz-wooblocks ul.wc-block-grid__products li.wc-block-grid__product .wc-block-grid__product-title a{color:#000000 !important;}body.woocommerce.wcz-woocommerce ul.products li.product .price,
					body.wcz-woocommerce .products .product .price,
                    body.wcz-wooblocks ul.wc-block-grid__products li.wc-block-grid__product .wc-block-grid__product-price{font-size:22px !important;}body.woocommerce.wcz-woocommerce ul.products li.product .price,
					body.wcz-woocommerce .products .product .price,
                    body.wcz-wooblocks ul.wc-block-grid__products li.wc-block-grid__product .wc-block-grid__product-price__value,
                    body.wcz-wooblocks ul.wc-block-grid__products li.wc-block-grid__product .wc-block-grid__product-price ins{color:#000000 !important;}body.wcz-wooblocks ul.wc-block-grid__products li.wc-block-grid__product .wc-block-grid__product-price del{color:rgba(0, 0, 0, 0.45);}body.single-product .woocommerce-breadcrumb{display:none !important;}body.single-product .product_meta .posted_in{display:none !important;}body.single-product .product_meta .tagged_as{display:none !important;}.single-product section.related.products{display:none !important;}body.single-product a.wcz-continue{margin-bottom:20px;}body.single-product.wcz-woocommerce div.product .product_title{color:#000000 !important;}body.single-product.wcz-woocommerce div.product p.price{font-size:23px !important;}body.single-product.wcz-woocommerce div.product p.price,
					body.single-product.wcz-woocommerce div.product .woocommerce-variation-price span.price{color:#000000 !important;}body.woocommerce-cart a.button.wcz-bts-btn{background-color:#000000 !important;color:#ffffff !important;}body.woocommerce-cart .wc-proceed-to-checkout a.button.checkout-button{background-color:#000000 !important;color:#ffffff !important;}
</style>
<link rel='stylesheet' id='slick-css'  href='https://beforesandafters.com/wp-content/plugins/woo-product-gallery-slider/assets/css/slick.css?ver=2.1.3' type='text/css' media='all' />
<link rel='stylesheet' id='slick-theme-css'  href='https://beforesandafters.com/wp-content/plugins/woo-product-gallery-slider/assets/css/slick-theme.css?ver=2.1.3' type='text/css' media='all' />
<link rel='stylesheet' id='fancybox-css'  href='https://beforesandafters.com/wp-content/plugins/woo-product-gallery-slider/assets/css/jquery.fancybox.min.css?ver=2.1.3' type='text/css' media='all' />
<style id='fancybox-inline-css' type='text/css'>

                .wpgs-nav .slick-active img{opacity:.7;transition:all ease-in .3s}.wpgs-nav .slick-current img{opacity:1}
                .wpgs-for .slick-arrow{position:absolute;z-index:1;cursor:pointer;top:50%;margin-top:-15px}
                .wpgs .slick-disabled{display:none;}
                .flaticon-right-arrow{right:0}
                .wpgs-for .slick-arrow::before,.wpgs-nav .slick-prev::before, .wpgs-nav .slick-next::before{color: #000000 !important;}
                .fancybox-bg{background: #ffffff !important;}                        
                
</style>
<link rel='stylesheet' id='flaticon-wpgs-css'  href='https://beforesandafters.com/wp-content/plugins/woo-product-gallery-slider/assets/css/font/flaticon.css?ver=2.1.3' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://beforesandafters.com/wp-content/plugins/jetpack/css/jetpack.css?ver=10.1' type='text/css' media='all' />
<script type='text/javascript' id='jetpack_related-posts-js-extra'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://beforesandafters.com/wp-content/plugins/jetpack/_inc/build/related-posts/related-posts.min.js?ver=20210604' id='jetpack_related-posts-js'></script>
<script type='text/javascript' src='https://beforesandafters.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://beforesandafters.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' id='simple-banner-script-js-extra'>
/* <![CDATA[ */
var simpleBannerScriptParams = {"version":"2.10.6","hide_simple_banner":"yes","simple_banner_position":"","header_margin":"","header_padding":"","simple_banner_text":"Get the latest issue of <a href=\"https:\/\/beforesandafters.com\/shop\/\">befores & afters magazine.<\/a>","pro_version_enabled":"","disabled_on_current_page":"","debug_mode":"","id":"71990","disabled_pages_array":[],"is_current_page_a_post":"1","disabled_on_posts":"","simple_banner_font_size":"14","simple_banner_color":"#000000","simple_banner_text_color":"#ffffff","simple_banner_link_color":"#ffeb00","simple_banner_close_color":"","simple_banner_custom_css":"","simple_banner_scrolling_custom_css":"","simple_banner_text_custom_css":"","simple_banner_button_css":"","site_custom_css":"","keep_site_custom_css":"","site_custom_js":"","keep_site_custom_js":"","wp_body_open_enabled":"","wp_body_open":"1","close_button_enabled":"on","close_button_expiration":"","close_button_cookie_set":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://beforesandafters.com/wp-content/plugins/simple-banner/simple-banner.js?ver=2.10.6' id='simple-banner-script-js'></script>
<script type='text/javascript' src='https://beforesandafters.com/wp-content/plugins/wp-date-remover/public/js/wp-date-remover-public.js?ver=1.0.0' id='wp-date-remover-js'></script>
<script defer type='text/javascript' src='https://stats.wp.com/s-202138.js' id='woocommerce-analytics-js'></script>
<script type='text/javascript' src='https://beforesandafters.com/wp-includes/js/swfobject.js?ver=2.2-20120417' id='swfobject-js'></script>
<script type='text/javascript' src='https://v0.wordpress.com/js/videopress.js?ver=1.09' id='videopress-js'></script>
<link rel="https://api.w.org/" href="https://beforesandafters.com/wp-json/" /><link rel="alternate" type="application/json" href="https://beforesandafters.com/wp-json/wp/v2/posts/71990" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://beforesandafters.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://beforesandafters.com/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='https://wp.me/par5YM-iJ8' />
		<!-- Custom Logo: hide header text -->
		<style id="custom-logo-css" type="text/css">
			.site-title, .site-description-text {
				position: absolute;
				clip: rect(1px, 1px, 1px, 1px);
			}
		</style>
		<link rel="alternate" type="application/json+oembed" href="https://beforesandafters.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fbeforesandafters.com%2F2021%2F09%2F20%2Fthat-insane-shang-chi-bamboo-scaffolding-fight-featured-insane-roto-reflection-vfx-and-a-fully-cg-macau%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://beforesandafters.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fbeforesandafters.com%2F2021%2F09%2F20%2Fthat-insane-shang-chi-bamboo-scaffolding-fight-featured-insane-roto-reflection-vfx-and-a-fully-cg-macau%2F&#038;format=xml" />
<style type="text/css">.simple-banner{display:none;}</style><style type="text/css">.simple-banner .simple-banner-text{font-size:14;}</style><style type="text/css">.simple-banner{background:#000000;}</style><style type="text/css">.simple-banner .simple-banner-text{color:#ffffff;}</style><style type="text/css">.simple-banner .simple-banner-text a{color:#ffeb00;}</style><style id="simple-banner-site-custom-css-dummy" type="text/css"></style><script id="simple-banner-site-custom-js-dummy" type="text/javascript"></script>		<script>
			var jabvfcr = {
				selector: "DIV.copyright",
				manipulation: "html",
				html: "© Copyright 2021 befores & afters."
			};
		</script>
		<style type='text/css'>img#wpstats{display:none}</style>
			<noscript><style>.woocommerce-product-gallery{ opacity: 1 !important; }</style></noscript>
			<style type="text/css">
			.recentcomments a {
				display: inline !important;
				padding: 0 !important;
				margin: 0 !important;
			}

			table.recentcommentsavatartop img.avatar, table.recentcommentsavatarend img.avatar {
				border: 0px;
				margin: 0;
			}

			table.recentcommentsavatartop a, table.recentcommentsavatarend a {
				border: 0px !important;
				background-color: transparent !important;
			}

			td.recentcommentsavatarend, td.recentcommentsavatartop {
				padding: 0px 0px 1px 0px;
				margin: 0px;
			}

			td.recentcommentstextend {
				border: none !important;
				padding: 0px 0px 2px 10px;
			}

			.rtl td.recentcommentstextend {
				padding: 0px 10px 2px 0px;
			}

			td.recentcommentstexttop {
				border: none;
				padding: 0px 0px 0px 10px;
			}

			.rtl td.recentcommentstexttop {
				padding: 0px 10px 0px 0px;
			}
		</style>
		<link rel="amphtml" href="https://beforesandafters.com/2021/09/20/that-insane-shang-chi-bamboo-scaffolding-fight-featured-insane-roto-reflection-vfx-and-a-fully-cg-macau/?amp"><meta name="google-site-verification" content="P2kQwk9rkrt1yZ1KVkOcp4IHUUOJ1DUp1Zz7NQ_WkEg" />


<link rel="icon" href="https://beforesandafters.com/wp-content/uploads/2019/03/cropped-beforesafters-32x32.jpeg" sizes="32x32" />
<link rel="icon" href="https://beforesandafters.com/wp-content/uploads/2019/03/cropped-beforesafters-192x192.jpeg" sizes="192x192" />
<link rel="apple-touch-icon" href="https://beforesandafters.com/wp-content/uploads/2019/03/cropped-beforesafters-180x180.jpeg" />
<meta name="msapplication-TileImage" content="https://beforesandafters.com/wp-content/uploads/2019/03/cropped-beforesafters-270x270.jpeg" />
			<style id="customify_output_style">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</style>
			<style id="customify_fonts_output">
	
.nav--main a {
font-family: Oswald, "SF Pro Text", Frutiger, "Frutiger Linotype", Univers, Calibri, "Gill Sans", "Gill Sans MT", "Myriad Pro", Myriad, "DejaVu Sans Condensed", "Liberation Sans", "Nimbus Sans L", Tahoma, Geneva, "Helvetica Neue", Helvetica, Arial, sans-serif;
font-weight: 300;
letter-spacing: 0.06;
text-transform: uppercase;
}


.single .entry-title, .page .entry-title {
font-family: Oswald, "SF Pro Text", Frutiger, "Frutiger Linotype", Univers, Calibri, "Gill Sans", "Gill Sans MT", "Myriad Pro", Myriad, "DejaVu Sans Condensed", "Liberation Sans", "Nimbus Sans L", Tahoma, Geneva, "Helvetica Neue", Helvetica, Arial, sans-serif;
font-weight: 400;
letter-spacing: 0.04;
text-transform: uppercase;
}


body {
font-family: Roboto, "SF Pro Text", Frutiger, "Frutiger Linotype", Univers, Calibri, "Gill Sans", "Gill Sans MT", "Myriad Pro", Myriad, "DejaVu Sans Condensed", "Liberation Sans", "Nimbus Sans L", Tahoma, Geneva, "Helvetica Neue", Helvetica, Arial, sans-serif;
font-weight: 300;
letter-spacing: 0;
text-transform: none;
}


blockquote {
font-family: Oswald, "SF Pro Text", Frutiger, "Frutiger Linotype", Univers, Calibri, "Gill Sans", "Gill Sans MT", "Myriad Pro", Myriad, "DejaVu Sans Condensed", "Liberation Sans", "Nimbus Sans L", Tahoma, Geneva, "Helvetica Neue", Helvetica, Arial, sans-serif;
font-weight: 500;
letter-spacing: 0;
text-transform: uppercase;
}


h1 {
font-family: Oswald, "SF Pro Text", Frutiger, "Frutiger Linotype", Univers, Calibri, "Gill Sans", "Gill Sans MT", "Myriad Pro", Myriad, "DejaVu Sans Condensed", "Liberation Sans", "Nimbus Sans L", Tahoma, Geneva, "Helvetica Neue", Helvetica, Arial, sans-serif;
font-weight: 500;
letter-spacing: 0.04;
text-transform: uppercase;
}


h2 {
font-family: Oswald, "SF Pro Text", Frutiger, "Frutiger Linotype", Univers, Calibri, "Gill Sans", "Gill Sans MT", "Myriad Pro", Myriad, "DejaVu Sans Condensed", "Liberation Sans", "Nimbus Sans L", Tahoma, Geneva, "Helvetica Neue", Helvetica, Arial, sans-serif;
font-weight: 500;
letter-spacing: 0.04;
text-transform: uppercase;
}


h3 {
font-family: Oswald, "SF Pro Text", Frutiger, "Frutiger Linotype", Univers, Calibri, "Gill Sans", "Gill Sans MT", "Myriad Pro", Myriad, "DejaVu Sans Condensed", "Liberation Sans", "Nimbus Sans L", Tahoma, Geneva, "Helvetica Neue", Helvetica, Arial, sans-serif;
font-weight: 200;
letter-spacing: 0;
text-transform: none;
}


h4 {
font-family: Oswald, "SF Pro Text", Frutiger, "Frutiger Linotype", Univers, Calibri, "Gill Sans", "Gill Sans MT", "Myriad Pro", Myriad, "DejaVu Sans Condensed", "Liberation Sans", "Nimbus Sans L", Tahoma, Geneva, "Helvetica Neue", Helvetica, Arial, sans-serif;
font-weight: 500;
letter-spacing: 0.1;
text-transform: uppercase;
}


h5 {
font-family: Roboto, "SF Pro Text", Frutiger, "Frutiger Linotype", Univers, Calibri, "Gill Sans", "Gill Sans MT", "Myriad Pro", Myriad, "DejaVu Sans Condensed", "Liberation Sans", "Nimbus Sans L", Tahoma, Geneva, "Helvetica Neue", Helvetica, Arial, sans-serif;
font-weight: 500;
letter-spacing: 0.02;
text-transform: uppercase;
}


.entry-content h6, h6, .h6 {
font-family: Roboto, "SF Pro Text", Frutiger, "Frutiger Linotype", Univers, Calibri, "Gill Sans", "Gill Sans MT", "Myriad Pro", Myriad, "DejaVu Sans Condensed", "Liberation Sans", "Nimbus Sans L", Tahoma, Geneva, "Helvetica Neue", Helvetica, Arial, sans-serif;
font-weight: 500;
letter-spacing: 0.03;
text-transform: none;
}


.entry-card .entry-title {
font-family: Oswald, "SF Pro Text", Frutiger, "Frutiger Linotype", Univers, Calibri, "Gill Sans", "Gill Sans MT", "Myriad Pro", Myriad, "DejaVu Sans Condensed", "Liberation Sans", "Nimbus Sans L", Tahoma, Geneva, "Helvetica Neue", Helvetica, Arial, sans-serif;
font-weight: 400;
letter-spacing: 0.04;
text-transform: uppercase;
}

</style>
			<style type="text/css" id="wp-custom-css">.single-product .woocommerce-product-gallery .woocommerce-product-gallery__trigger {
display: none;
}</style><!-- Jetpack Google Analytics -->
			<script type='text/javascript'>
				var _gaq = _gaq || [];
				_gaq.push(['_setAccount', 'UA-140669838-1']);
_gaq.push(['_trackPageview']);
				(function() {
					var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
					ga.src = ('https:' === document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
					var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
				})();
			</script>
			<!-- End Jetpack Google Analytics -->
</head>

<body class="post-template-default single single-post postid-71990 single-format-standard wp-custom-logo theme-patch wcz-woocommerce wcz-btns wcz-btn-style-default wcz-wooblocks woocommerce-no-js group-blog has_sidebar aa-prefix-befor-">


<div id="page" class="hfeed site">
	<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

	<div id="content" class="site-content">
		<div class="container">

		

<header id="masthead" class="site-header" role="banner">
	<div class="site-branding">

		<a href="https://beforesandafters.com/" class="custom-logo-link" rel="home"><img width="300" height="300" src="https://beforesandafters.com/wp-content/uploads/2019/03/beforesafters_logo_300.jpg" class="custom-logo" alt="befores &amp; afters" srcset="https://beforesandafters.com/wp-content/uploads/2019/03/beforesafters_logo_300.jpg 300w, https://beforesandafters.com/wp-content/uploads/2019/03/beforesafters_logo_300-100x100.jpg?crop=1 100w, https://beforesandafters.com/wp-content/uploads/2019/03/beforesafters_logo_300-150x150.jpg 150w" sizes="(max-width: 300px) 100vw, 300px" data-attachment-id="406" data-permalink="https://beforesandafters.com/beforesafters_logo_300/" data-orig-file="https://beforesandafters.com/wp-content/uploads/2019/03/beforesafters_logo_300.jpg" data-orig-size="300,300" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="beforesafters_logo_300" data-image-description="" data-image-caption="" data-medium-file="https://beforesandafters.com/wp-content/uploads/2019/03/beforesafters_logo_300.jpg" data-large-file="https://beforesandafters.com/wp-content/uploads/2019/03/beforesafters_logo_300.jpg" /></a>
		<div class="site-title">
		<a href="https://beforesandafters.com/" rel="home">
			befores &amp; afters		</a>

		</div>
		
			<div class="site-description">
				<span class="site-description-text">visual effects magazine</span>
			</div>

		
	</div><!-- .site-branding -->

	<nav id="site-navigation" class="main-navigation" role="navigation">

		<ul id="menu-primary" class="nav nav--main"><li id="menu-item-67623" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-67623"><a href="https://beforesandafters.com/about/">ABOUT</a></li>
<li id="menu-item-46233" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-46233"><a href="https://beforesandafters.com/shop/">MAGAZINE</a></li>
<li id="menu-item-66290" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66290"><a href="https://beforesandafters.com/category/podcasts/">PODCASTS</a></li>
<li id="menu-item-69905" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-69905"><a href="https://beforesandafters.com/support/">ADVERTISE</a></li>
<li id="menu-item-71899" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-71899"><a href="https://beforesandafters.com/cart/">MY CART</a></li>
<li id="menu-item-71900" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-71900"><a href="https://beforesandafters.com/my-account/">LOGIN</a></li>
</ul>
		<ul id="menu-social" class="nav nav--social"><li id="menu-item-214" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-214"><a href="https://twitter.com/ianfailes"><span class="screen-reader-text">Twitter</span></a></li>
<li id="menu-item-217" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-217"><a href="https://www.instagram.com/ianstafailes/"><span class="screen-reader-text">Instagram</span></a></li>
<li id="menu-item-554" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-554"><a href="https://www.facebook.com/Befores-Afters-829036060774243/"><span class="screen-reader-text">Facebook</span></a></li>
<li id="menu-item-218" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-218"><a href="https://www.linkedin.com/in/ian-failes-17154b4/"><span class="screen-reader-text">LinkedIn</span></a></li>
<li id="menu-item-8280" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8280"><a href="https://www.youtube.com/channel/UCDYWiGfmyQNT5tEdmiKpDKg/videos"><span class="screen-reader-text">YouTube</span></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom"><a href="#search">Search</a></li></ul>
	</nav><!-- #site-navigation -->

</header><!-- #masthead -->


	<div id="primary" class="content-area">
		<main id="main" class="site-main" role="main">

			
<article id="post-71990" class="post-71990 post type-post status-publish format-standard has-post-thumbnail hentry category-articles tag-ara-khanikian tag-rodeo-fx tag-shang-chi-and-the-legend-of-the-ten-rings entry-image--landscape">

	
	<header class="entry-header">
		<div class="entry-meta">

			<span class="cat-links"><a href="https://beforesandafters.com/category/articles/" rel="category tag">Articles</a></span>
			<div class="clearfix">

				<span class="byline"> by <span class="author vcard"><a class="url fn n" href="https://beforesandafters.com/author/beforesandafters/">Ian Failes</a></span></span><span class="posted-on"><a href="https://beforesandafters.com/2021/09/20/that-insane-shang-chi-bamboo-scaffolding-fight-featured-insane-roto-reflection-vfx-and-a-fully-cg-macau/" rel="bookmark"><time class="entry-date published" datetime="2021-09-20T17:24:56+10:00">September 20, 2021<span class="entry-time">5:24 pm</span></time><time class="updated" hidden datetime="2021-09-20T17:30:03+10:00">September 20, 2021</time></a></span>
			</div>

		</div><!-- .entry-meta -->

		<h1 class="entry-title">That insane &#8216;Shang-Chi&#8217; bamboo scaffolding fight featured equally insane roto, reflection VFX and a fully CG Macau</h1>
	</header><!-- .entry-header -->

	
		<div class="entry-featured  entry-thumbnail">

			<img width="1024" height="681" src="https://beforesandafters.com/wp-content/uploads/2021/09/SBT-18015-1024x681.jpg" class="attachment-patch-single-image size-patch-single-image wp-post-image" alt="" loading="lazy" srcset="https://beforesandafters.com/wp-content/uploads/2021/09/SBT-18015-1024x681.jpg 1024w, https://beforesandafters.com/wp-content/uploads/2021/09/SBT-18015-300x200.jpg 300w, https://beforesandafters.com/wp-content/uploads/2021/09/SBT-18015-600x399.jpg 600w, https://beforesandafters.com/wp-content/uploads/2021/09/SBT-18015-768x511.jpg 768w, https://beforesandafters.com/wp-content/uploads/2021/09/SBT-18015-640x426.jpg 640w, https://beforesandafters.com/wp-content/uploads/2021/09/SBT-18015-752x500.jpg 752w, https://beforesandafters.com/wp-content/uploads/2021/09/SBT-18015.jpg 1200w" sizes="(max-width: 679px) 100vw, (max-width: 899px) 668px, (max-width: 1079px) 50vw, (max-width: 1259px) 620px, (max-width: 1449px) 66vw, 980px" data-attachment-id="71718" data-permalink="https://beforesandafters.com/2021/09/17/heres-what-went-into-the-visual-effects-of-shang-chis-crazy-bus-sequence-part-1/sbt-18015/" data-orig-file="https://beforesandafters.com/wp-content/uploads/2021/09/SBT-18015.jpg" data-orig-size="1200,798" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="SBT-18015" data-image-description="" data-image-caption="" data-medium-file="https://beforesandafters.com/wp-content/uploads/2021/09/SBT-18015-300x200.jpg" data-large-file="https://beforesandafters.com/wp-content/uploads/2021/09/SBT-18015-1024x681.jpg" />
		</div>

	
	<div class="entry-content">

		<blockquote><p>&#8216;the whole action was shot a blue box with a mirror set in the middle.&#8217;</p></blockquote>
<p>To make the intense <em>Shang-Chi and the Legend of the Ten Rings</em> bamboo scaffolding fight that sees the characters Shang-Chi and Katy pursued off the side of a Macau building, production filmed the actors and stunt performers on a bluescreened set-piece in Sydney, complete with reflective windows and scaffolding sections.</p>
<p>This meant, of course, that the performers would need to be extracted from the plates, and that a massive busy Macau environment would need to be added in to both the backgrounds and as a reflection &#8216;background&#8217; in the building windows. Handling the VFX work for the sequence was <a href="https://www.rodeofx.com/">Rodeo FX</a>, led by visual effects supervisor Ara Khanikian. The studio would also deal with weapon replacements and digi-doubles. Khanikian told <em>befores &amp; afters</em> how they made it all happen.</p>
<div class="jetpack-video-wrapper"><span class="embed-youtube" style="text-align:center; display: block;"><iframe loading="lazy" class="youtube-player" width="980" height="552" src="https://www.youtube.com/embed/4b28WqJ5z-U?version=3&#038;rel=1&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;fs=1&#038;hl=en-US&#038;autohide=2&#038;wmode=transparent" allowfullscreen="true" style="border:0;" sandbox="allow-scripts allow-same-origin allow-popups allow-presentation"></iframe></span></div>
<p><strong>b&amp;a: My first question is, given that the scene was filmed against a building with windows, what were you first discussions about dealing with reflections?</strong></p>
<p><strong>Ara Khanikian</strong>: Well, I mean, there&#8217;s not a whole lot of ways to do it. I think that the way that [production visual effects supervisor] Chris Townsend and Marvel did it was really the best way. They physically built a three story high section of the building, which was on hinges and could rotate about 45 degrees. It was a mirror set with the bamboo scaffolding set up on it with a couple of planks. Basically the whole action was shot on that—a blue box, effectively, with that mirror set in the middle.</p>
<p>This meant we were able to get all the real reflections of the actors. Obviously, we had to extract them from that mirror set. Just about any time you look at a shot, it&#8217;s the main actors, the scaffoldings that they&#8217;re holding onto, and then a CG building reflecting the CG city with CG scaffoldings.</p>
<p><span class="aligncenter"><img data-attachment-id="71713" data-permalink="https://beforesandafters.com/2021/09/17/heres-what-went-into-the-visual-effects-of-shang-chis-crazy-bus-sequence-part-1/sbt-18805/" data-orig-file="https://beforesandafters.com/wp-content/uploads/2021/09/SBT-18805.jpg" data-orig-size="1200,1803" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="SBT-18805" data-image-description="" data-image-caption="" data-medium-file="https://beforesandafters.com/wp-content/uploads/2021/09/SBT-18805-200x300.jpg" data-large-file="https://beforesandafters.com/wp-content/uploads/2021/09/SBT-18805-682x1024.jpg" loading="lazy" class="aligncenter size-full wp-image-71713" src="https://beforesandafters.com/wp-content/uploads/2021/09/SBT-18805.jpg" alt="" width="1200" height="1803" srcset="https://beforesandafters.com/wp-content/uploads/2021/09/SBT-18805.jpg 1200w, https://beforesandafters.com/wp-content/uploads/2021/09/SBT-18805-300x451.jpg 300w, https://beforesandafters.com/wp-content/uploads/2021/09/SBT-18805-600x902.jpg 600w, https://beforesandafters.com/wp-content/uploads/2021/09/SBT-18805-200x300.jpg 200w, https://beforesandafters.com/wp-content/uploads/2021/09/SBT-18805-682x1024.jpg 682w, https://beforesandafters.com/wp-content/uploads/2021/09/SBT-18805-768x1154.jpg 768w, https://beforesandafters.com/wp-content/uploads/2021/09/SBT-18805-1022x1536.jpg 1022w, https://beforesandafters.com/wp-content/uploads/2021/09/SBT-18805-640x962.jpg 640w, https://beforesandafters.com/wp-content/uploads/2021/09/SBT-18805-1024x1539.jpg 1024w, https://beforesandafters.com/wp-content/uploads/2021/09/SBT-18805-333x500.jpg 333w" sizes="(max-width: 620px) 100vw, (max-width: 899px) 620px, 764px" /></span></p>
<p><strong>b&amp;a: It must have been a mammoth effort to rotoscope and just deal with that set—tell me a little about that side of things?</strong></p>
<p><strong>Ara Khanikian</strong>: Yes, the roto was monumental on it, for sure. A lot of it could be extracted; we had the bluescreen, of course. That was all good. But it&#8217;s when you start going into it you realize there’s a lot of detail to go through.</p>
<p>When you look at how buildings in Asia are built with bamboo scaffoldings, there&#8217;s actual notches between the windows. On set, they had something very close to that but they had to sometimes cover them with plexiglass just so during their stunts and all the fighting nobody would get hurt. That meant between every single mirrored window on set that you&#8217;re replacing with a CG one, you have to go in and roto those sections out.</p>
<p><span class="aligncenter"><img data-attachment-id="71748" data-permalink="https://beforesandafters.com/2021/09/17/heres-what-went-into-the-visual-effects-of-shang-chis-crazy-bus-sequence-part-1/bse2710_before-1056/" data-orig-file="https://beforesandafters.com/wp-content/uploads/2021/09/BSE2710_before.1056.jpg" data-orig-size="1200,502" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="BSE2710_before.1056" data-image-description="" data-image-caption="" data-medium-file="https://beforesandafters.com/wp-content/uploads/2021/09/BSE2710_before.1056-300x126.jpg" data-large-file="https://beforesandafters.com/wp-content/uploads/2021/09/BSE2710_before.1056-1024x428.jpg" loading="lazy" class="aligncenter size-full wp-image-71748" src="https://beforesandafters.com/wp-content/uploads/2021/09/BSE2710_before.1056.jpg" alt="" width="1200" height="502" srcset="https://beforesandafters.com/wp-content/uploads/2021/09/BSE2710_before.1056.jpg 1200w, https://beforesandafters.com/wp-content/uploads/2021/09/BSE2710_before.1056-300x126.jpg 300w, https://beforesandafters.com/wp-content/uploads/2021/09/BSE2710_before.1056-600x251.jpg 600w, https://beforesandafters.com/wp-content/uploads/2021/09/BSE2710_before.1056-1024x428.jpg 1024w, https://beforesandafters.com/wp-content/uploads/2021/09/BSE2710_before.1056-768x321.jpg 768w, https://beforesandafters.com/wp-content/uploads/2021/09/BSE2710_before.1056-640x268.jpg 640w, https://beforesandafters.com/wp-content/uploads/2021/09/BSE2710_before.1056-1000x418.jpg 1000w" sizes="(max-width: 620px) 100vw, (max-width: 899px) 620px, 764px" /> <img data-attachment-id="71741" data-permalink="https://beforesandafters.com/2021/09/17/heres-what-went-into-the-visual-effects-of-shang-chis-crazy-bus-sequence-part-1/bse2710_cmp_rdo_v0003-1056/" data-orig-file="https://beforesandafters.com/wp-content/uploads/2021/09/BSE2710_cmp_rdo_v0003.1056.jpg" data-orig-size="1200,502" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="BSE2710_cmp_rdo_v0003.1056" data-image-description="" data-image-caption="" data-medium-file="https://beforesandafters.com/wp-content/uploads/2021/09/BSE2710_cmp_rdo_v0003.1056-300x126.jpg" data-large-file="https://beforesandafters.com/wp-content/uploads/2021/09/BSE2710_cmp_rdo_v0003.1056-1024x428.jpg" loading="lazy" class="aligncenter size-full wp-image-71741" src="https://beforesandafters.com/wp-content/uploads/2021/09/BSE2710_cmp_rdo_v0003.1056.jpg" alt="" width="1200" height="502" srcset="https://beforesandafters.com/wp-content/uploads/2021/09/BSE2710_cmp_rdo_v0003.1056.jpg 1200w, https://beforesandafters.com/wp-content/uploads/2021/09/BSE2710_cmp_rdo_v0003.1056-300x126.jpg 300w, https://beforesandafters.com/wp-content/uploads/2021/09/BSE2710_cmp_rdo_v0003.1056-600x251.jpg 600w, https://beforesandafters.com/wp-content/uploads/2021/09/BSE2710_cmp_rdo_v0003.1056-1024x428.jpg 1024w, https://beforesandafters.com/wp-content/uploads/2021/09/BSE2710_cmp_rdo_v0003.1056-768x321.jpg 768w, https://beforesandafters.com/wp-content/uploads/2021/09/BSE2710_cmp_rdo_v0003.1056-640x268.jpg 640w, https://beforesandafters.com/wp-content/uploads/2021/09/BSE2710_cmp_rdo_v0003.1056-1000x418.jpg 1000w" sizes="(max-width: 620px) 100vw, (max-width: 899px) 620px, 764px" /></span></p>
<p>Then there’s the reflections: you have to roto the reflection from the real plates. You&#8217;re going to have to add your CG reflection and then you have to dial in the amount of light wrap and glows and flares and this and that.</p>
<p>So, the foreground section was extracted with classic bluescreen extractions with roto and then for all the reflections, we roto’d them in a very standardized way. We knew that a specific layer was, say, just a bamboo scaffolding. Another specific layer would be only the character. Another specific layer would be something else, and so on, so that we could standardize it all a little bit more.</p>
<p><span class="aligncenter"><img data-attachment-id="71715" data-permalink="https://beforesandafters.com/2021/09/17/heres-what-went-into-the-visual-effects-of-shang-chis-crazy-bus-sequence-part-1/sbt-18500/" data-orig-file="https://beforesandafters.com/wp-content/uploads/2021/09/SBT-18500.jpg" data-orig-size="1200,800" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="SBT-18500" data-image-description="" data-image-caption="" data-medium-file="https://beforesandafters.com/wp-content/uploads/2021/09/SBT-18500-300x200.jpg" data-large-file="https://beforesandafters.com/wp-content/uploads/2021/09/SBT-18500-1024x683.jpg" loading="lazy" class="aligncenter size-full wp-image-71715" src="https://beforesandafters.com/wp-content/uploads/2021/09/SBT-18500.jpg" alt="" width="1200" height="800" srcset="https://beforesandafters.com/wp-content/uploads/2021/09/SBT-18500.jpg 1200w, https://beforesandafters.com/wp-content/uploads/2021/09/SBT-18500-300x200.jpg 300w, https://beforesandafters.com/wp-content/uploads/2021/09/SBT-18500-600x400.jpg 600w, https://beforesandafters.com/wp-content/uploads/2021/09/SBT-18500-1024x683.jpg 1024w, https://beforesandafters.com/wp-content/uploads/2021/09/SBT-18500-768x512.jpg 768w, https://beforesandafters.com/wp-content/uploads/2021/09/SBT-18500-640x427.jpg 640w, https://beforesandafters.com/wp-content/uploads/2021/09/SBT-18500-750x500.jpg 750w" sizes="(max-width: 620px) 100vw, (max-width: 899px) 620px, 764px" /></span></p>
<p><strong>b&amp;a: Was the entire environment that you see either reflected or in the background to shots CG, or did you have any kind of live action?</strong></p>
<p><strong>Ara Khanikian</strong>: It was entirely CG. Early on, we were talking about going to Macau physically and shooting plates, getting all the references, the HDRs and photogrammetry and drone shots. What we were thinking about in the beginning was a little more of a classic approach of shooting all of these plates and then enhancing them and projecting them or adding a little bit of CG to them and using it that way. But when COVID started, everything just locked down, and there was no more traveling. So we opted for a full CG Macau.</p>
<p>Production had already done some helicopter surveys as part of scouting, early in pre-production. So we already, knew based on those aerial plates, where the skyscraper would be in Macau. Then we started with Google Maps and OpenStreetMap data to form an accurate representation of the streets. We could do rough photogrammetry captures just to get approximate volumes of buildings. We also even used actual elevation and topographical maps to distort the terrain to represent the ‘real’ terrain of Macau.</p>
<p><span class="aligncenter"><img data-attachment-id="71747" data-permalink="https://beforesandafters.com/2021/09/17/heres-what-went-into-the-visual-effects-of-shang-chis-crazy-bus-sequence-part-1/bse2400_before-1042/" data-orig-file="https://beforesandafters.com/wp-content/uploads/2021/09/BSE2400_before.1042.jpg" data-orig-size="1200,502" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="BSE2400_before.1042" data-image-description="" data-image-caption="" data-medium-file="https://beforesandafters.com/wp-content/uploads/2021/09/BSE2400_before.1042-300x126.jpg" data-large-file="https://beforesandafters.com/wp-content/uploads/2021/09/BSE2400_before.1042-1024x428.jpg" loading="lazy" class="aligncenter size-full wp-image-71747" src="https://beforesandafters.com/wp-content/uploads/2021/09/BSE2400_before.1042.jpg" alt="" width="1200" height="502" srcset="https://beforesandafters.com/wp-content/uploads/2021/09/BSE2400_before.1042.jpg 1200w, https://beforesandafters.com/wp-content/uploads/2021/09/BSE2400_before.1042-300x126.jpg 300w, https://beforesandafters.com/wp-content/uploads/2021/09/BSE2400_before.1042-600x251.jpg 600w, https://beforesandafters.com/wp-content/uploads/2021/09/BSE2400_before.1042-1024x428.jpg 1024w, https://beforesandafters.com/wp-content/uploads/2021/09/BSE2400_before.1042-768x321.jpg 768w, https://beforesandafters.com/wp-content/uploads/2021/09/BSE2400_before.1042-640x268.jpg 640w, https://beforesandafters.com/wp-content/uploads/2021/09/BSE2400_before.1042-1000x418.jpg 1000w" sizes="(max-width: 620px) 100vw, (max-width: 899px) 620px, 764px" /> <img data-attachment-id="71742" data-permalink="https://beforesandafters.com/2021/09/17/heres-what-went-into-the-visual-effects-of-shang-chis-crazy-bus-sequence-part-1/bse2400_cmp_rdo_v0005-1042/" data-orig-file="https://beforesandafters.com/wp-content/uploads/2021/09/BSE2400_cmp_rdo_v0005.1042.jpg" data-orig-size="1200,502" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="BSE2400_cmp_rdo_v0005.1042" data-image-description="" data-image-caption="" data-medium-file="https://beforesandafters.com/wp-content/uploads/2021/09/BSE2400_cmp_rdo_v0005.1042-300x126.jpg" data-large-file="https://beforesandafters.com/wp-content/uploads/2021/09/BSE2400_cmp_rdo_v0005.1042-1024x428.jpg" loading="lazy" class="aligncenter size-full wp-image-71742" src="https://beforesandafters.com/wp-content/uploads/2021/09/BSE2400_cmp_rdo_v0005.1042.jpg" alt="" width="1200" height="502" srcset="https://beforesandafters.com/wp-content/uploads/2021/09/BSE2400_cmp_rdo_v0005.1042.jpg 1200w, https://beforesandafters.com/wp-content/uploads/2021/09/BSE2400_cmp_rdo_v0005.1042-300x126.jpg 300w, https://beforesandafters.com/wp-content/uploads/2021/09/BSE2400_cmp_rdo_v0005.1042-600x251.jpg 600w, https://beforesandafters.com/wp-content/uploads/2021/09/BSE2400_cmp_rdo_v0005.1042-1024x428.jpg 1024w, https://beforesandafters.com/wp-content/uploads/2021/09/BSE2400_cmp_rdo_v0005.1042-768x321.jpg 768w, https://beforesandafters.com/wp-content/uploads/2021/09/BSE2400_cmp_rdo_v0005.1042-640x268.jpg 640w, https://beforesandafters.com/wp-content/uploads/2021/09/BSE2400_cmp_rdo_v0005.1042-1000x418.jpg 1000w" sizes="(max-width: 620px) 100vw, (max-width: 899px) 620px, 764px" /></span></p>
<p>Every single building that&#8217;s around the main skyscraper is a high rise building built in CG, and those are really accurate to the Macau buildings themselves. For background buildings, we went with a little bit more mid-res models, where we would analyze a lot of Macau pictures and go, ‘Okay, well, the slums in Macau have this particular look. The apartment complex building towers have a certain look.’</p>
<p>We would do generic versions of those and then add enough variation and basically just scatter them into the city. Each has model and texture variation. And since we started with the Google Maps data, we already knew what the volumes and the shapes would need to fill to have that look.</p>
<p><span class="aligncenter"><img data-attachment-id="71743" data-permalink="https://beforesandafters.com/2021/09/17/heres-what-went-into-the-visual-effects-of-shang-chis-crazy-bus-sequence-part-1/bse1680_cmp_rdo_v0013-1062_r3/" data-orig-file="https://beforesandafters.com/wp-content/uploads/2021/09/BSE1680_cmp_rdo_v0013.1062_R3.jpg" data-orig-size="1200,502" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="BSE1680_cmp_rdo_v0013.1062_R3" data-image-description="" data-image-caption="" data-medium-file="https://beforesandafters.com/wp-content/uploads/2021/09/BSE1680_cmp_rdo_v0013.1062_R3-300x126.jpg" data-large-file="https://beforesandafters.com/wp-content/uploads/2021/09/BSE1680_cmp_rdo_v0013.1062_R3-1024x428.jpg" loading="lazy" class="aligncenter size-full wp-image-71743" src="https://beforesandafters.com/wp-content/uploads/2021/09/BSE1680_cmp_rdo_v0013.1062_R3.jpg" alt="" width="1200" height="502" srcset="https://beforesandafters.com/wp-content/uploads/2021/09/BSE1680_cmp_rdo_v0013.1062_R3.jpg 1200w, https://beforesandafters.com/wp-content/uploads/2021/09/BSE1680_cmp_rdo_v0013.1062_R3-300x126.jpg 300w, https://beforesandafters.com/wp-content/uploads/2021/09/BSE1680_cmp_rdo_v0013.1062_R3-600x251.jpg 600w, https://beforesandafters.com/wp-content/uploads/2021/09/BSE1680_cmp_rdo_v0013.1062_R3-1024x428.jpg 1024w, https://beforesandafters.com/wp-content/uploads/2021/09/BSE1680_cmp_rdo_v0013.1062_R3-768x321.jpg 768w, https://beforesandafters.com/wp-content/uploads/2021/09/BSE1680_cmp_rdo_v0013.1062_R3-640x268.jpg 640w, https://beforesandafters.com/wp-content/uploads/2021/09/BSE1680_cmp_rdo_v0013.1062_R3-1000x418.jpg 1000w" sizes="(max-width: 620px) 100vw, (max-width: 899px) 620px, 764px" /></span></p>
<p>Then we ran some crowd sims and car sims. All the people walking, all the cars&#8211;it was this crazy set-up where we had maybe hundreds or thousands of street lamps just lighting up the whole streets. And then, they&#8217;re lighting the cars, the cars are lighting the environment, the cars are lighting themselves. They&#8217;re lighting the crowd that&#8217;s walking around the storefronts. We managed to, with the car sims, to factor in some slow downs and stopping, and then the brake lights would even activate.</p>
<p>What we wanted to do was build the Macau city environment almost as if it was ‘shot’ for real. So that once it got into shot work, you&#8217;re not modifying the background. You&#8217;re not re-rendering, running sims or relighting specific buildings. We said, ‘Macau looks this way at night, and this is the amount of activity, and this is the amount of animated lights in it.’ This way, we could concentrate the shot work more in terms of doing the set extensions for the scaffoldings, doing the CG building, rendering the reflections and doing all of that and leaving Macau, basically as if it was a background plate.</p>
<p><span class="aligncenter"><img data-attachment-id="71744" data-permalink="https://beforesandafters.com/2021/09/17/heres-what-went-into-the-visual-effects-of-shang-chis-crazy-bus-sequence-part-1/bse0170_cmp_rdo_v0005-1074_r2/" data-orig-file="https://beforesandafters.com/wp-content/uploads/2021/09/BSE0170_cmp_rdo_v0005.1074_R2.jpg" data-orig-size="1200,502" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="BSE0170_cmp_rdo_v0005.1074_R2" data-image-description="" data-image-caption="" data-medium-file="https://beforesandafters.com/wp-content/uploads/2021/09/BSE0170_cmp_rdo_v0005.1074_R2-300x126.jpg" data-large-file="https://beforesandafters.com/wp-content/uploads/2021/09/BSE0170_cmp_rdo_v0005.1074_R2-1024x428.jpg" loading="lazy" class="aligncenter size-full wp-image-71744" src="https://beforesandafters.com/wp-content/uploads/2021/09/BSE0170_cmp_rdo_v0005.1074_R2.jpg" alt="" width="1200" height="502" srcset="https://beforesandafters.com/wp-content/uploads/2021/09/BSE0170_cmp_rdo_v0005.1074_R2.jpg 1200w, https://beforesandafters.com/wp-content/uploads/2021/09/BSE0170_cmp_rdo_v0005.1074_R2-300x126.jpg 300w, https://beforesandafters.com/wp-content/uploads/2021/09/BSE0170_cmp_rdo_v0005.1074_R2-600x251.jpg 600w, https://beforesandafters.com/wp-content/uploads/2021/09/BSE0170_cmp_rdo_v0005.1074_R2-1024x428.jpg 1024w, https://beforesandafters.com/wp-content/uploads/2021/09/BSE0170_cmp_rdo_v0005.1074_R2-768x321.jpg 768w, https://beforesandafters.com/wp-content/uploads/2021/09/BSE0170_cmp_rdo_v0005.1074_R2-640x268.jpg 640w, https://beforesandafters.com/wp-content/uploads/2021/09/BSE0170_cmp_rdo_v0005.1074_R2-1000x418.jpg 1000w" sizes="(max-width: 620px) 100vw, (max-width: 899px) 620px, 764px" /></span></p>
<p>The scaffoldings were a challenge to match-move as well. Since actual stunt performers were running on them and fighting, they would stretch and warp and move around, and then we’d need to do set extensions for these. Everything needed to be tracked super-precisely.</p>
<p>Interestingly, sometimes on set, there would be two planks, one next to each other for safety. The stunt performers would be running on them. What we would do occasionally is separate them and have a gap between the two to create a little bit more danger. We would analyze where their feet would be in the CG world and then move the planks so that they&#8217;re still touching on something.</p>
<p><span class="aligncenter"><img data-attachment-id="71717" data-permalink="https://beforesandafters.com/2021/09/17/heres-what-went-into-the-visual-effects-of-shang-chis-crazy-bus-sequence-part-1/sbt-18311/" data-orig-file="https://beforesandafters.com/wp-content/uploads/2021/09/SBT-18311.jpg" data-orig-size="1200,798" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="SBT-18311" data-image-description="" data-image-caption="" data-medium-file="https://beforesandafters.com/wp-content/uploads/2021/09/SBT-18311-300x200.jpg" data-large-file="https://beforesandafters.com/wp-content/uploads/2021/09/SBT-18311-1024x681.jpg" loading="lazy" class="aligncenter size-full wp-image-71717" src="https://beforesandafters.com/wp-content/uploads/2021/09/SBT-18311.jpg" alt="" width="1200" height="798" srcset="https://beforesandafters.com/wp-content/uploads/2021/09/SBT-18311.jpg 1200w, https://beforesandafters.com/wp-content/uploads/2021/09/SBT-18311-300x200.jpg 300w, https://beforesandafters.com/wp-content/uploads/2021/09/SBT-18311-600x399.jpg 600w, https://beforesandafters.com/wp-content/uploads/2021/09/SBT-18311-1024x681.jpg 1024w, https://beforesandafters.com/wp-content/uploads/2021/09/SBT-18311-768x511.jpg 768w, https://beforesandafters.com/wp-content/uploads/2021/09/SBT-18311-640x426.jpg 640w, https://beforesandafters.com/wp-content/uploads/2021/09/SBT-18311-752x500.jpg 752w" sizes="(max-width: 620px) 100vw, (max-width: 899px) 620px, 764px" /></span></p>
<p><strong>b&amp;a: There were some really elaborate stunts in this sequence. I&#8217;m curious about where you had to do take-overs and how you approached any kind of digi-double work?</strong></p>
<p><strong>Ara Khanikian</strong>: The camera work was fantastic for the sequence because it was shot with fairly wide lenses and it was often hand-held. You were always in the action with them. The sections where we did some take-overs were mostly for the wide shots. Some were when it was really just impossible for them to shoot some specific elements tying altogether.</p>
<p>There&#8217;s one shot where it&#8217;s right after they just step outside, Shang-Chi and Katy, and you have the ten ring soldiers. The ten rings smash one of the windows and it explodes. They&#8217;re right there, and then jump out. The guy does a flip and then hits Shang-Chi. We had some shots like that where we&#8217;re basically transitioning—we&#8217;re starting with the real plate, transitioning to a full CG version and then re-transitioning back into the actual plate.</p>
<p><span class="aligncenter"><img data-attachment-id="71714" data-permalink="https://beforesandafters.com/2021/09/17/heres-what-went-into-the-visual-effects-of-shang-chis-crazy-bus-sequence-part-1/sbt-18508/" data-orig-file="https://beforesandafters.com/wp-content/uploads/2021/09/SBT-18508.jpg" data-orig-size="1200,798" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="SBT-18508" data-image-description="" data-image-caption="" data-medium-file="https://beforesandafters.com/wp-content/uploads/2021/09/SBT-18508-300x200.jpg" data-large-file="https://beforesandafters.com/wp-content/uploads/2021/09/SBT-18508-1024x681.jpg" loading="lazy" class="aligncenter size-full wp-image-71714" src="https://beforesandafters.com/wp-content/uploads/2021/09/SBT-18508.jpg" alt="" width="1200" height="798" srcset="https://beforesandafters.com/wp-content/uploads/2021/09/SBT-18508.jpg 1200w, https://beforesandafters.com/wp-content/uploads/2021/09/SBT-18508-300x200.jpg 300w, https://beforesandafters.com/wp-content/uploads/2021/09/SBT-18508-600x399.jpg 600w, https://beforesandafters.com/wp-content/uploads/2021/09/SBT-18508-1024x681.jpg 1024w, https://beforesandafters.com/wp-content/uploads/2021/09/SBT-18508-768x511.jpg 768w, https://beforesandafters.com/wp-content/uploads/2021/09/SBT-18508-640x426.jpg 640w, https://beforesandafters.com/wp-content/uploads/2021/09/SBT-18508-752x500.jpg 752w" sizes="(max-width: 620px) 100vw, (max-width: 899px) 620px, 764px" /></span></p>
<p><strong>b&amp;a: What about CG weapons? What the tricky things to do here in terms of weapon replacements and tracking them in?</strong></p>
<p><strong>Ara Khanikian</strong>: The tricky thing about weapon replacement, especially on <em>Shang-Chi</em>, is that it looks simple once it&#8217;s finished, but there&#8217;s a huge amount of work that goes behind it. Every single hook sword that the ten ring soldiers are holding is CG. They had actual swords on set. Some of them were half swords. Some of them were the actual full swords, but we&#8217;re adding the blue electric arc on it and it needs to light up and it needs to interact with the environment.</p>
<p>Sometimes we even had some sections where our sims would actually create sparking events and electrical arcs to contact with metals and stuff like that when weapons would come close. So, every single weapon they&#8217;re holding is a CG one, and that means every single soldier and their hands and the weapon is match-moved.</p>
<p><span class="aligncenter"><img data-attachment-id="71745" data-permalink="https://beforesandafters.com/2021/09/17/heres-what-went-into-the-visual-effects-of-shang-chis-crazy-bus-sequence-part-1/ddf_3180_before/" data-orig-file="https://beforesandafters.com/wp-content/uploads/2021/09/ddf_3180_before.jpg" data-orig-size="1200,632" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="ddf_3180_before" data-image-description="" data-image-caption="" data-medium-file="https://beforesandafters.com/wp-content/uploads/2021/09/ddf_3180_before-300x158.jpg" data-large-file="https://beforesandafters.com/wp-content/uploads/2021/09/ddf_3180_before-1024x539.jpg" loading="lazy" class="aligncenter size-full wp-image-71745" src="https://beforesandafters.com/wp-content/uploads/2021/09/ddf_3180_before.jpg" alt="" width="1200" height="632" srcset="https://beforesandafters.com/wp-content/uploads/2021/09/ddf_3180_before.jpg 1200w, https://beforesandafters.com/wp-content/uploads/2021/09/ddf_3180_before-300x158.jpg 300w, https://beforesandafters.com/wp-content/uploads/2021/09/ddf_3180_before-600x316.jpg 600w, https://beforesandafters.com/wp-content/uploads/2021/09/ddf_3180_before-1024x539.jpg 1024w, https://beforesandafters.com/wp-content/uploads/2021/09/ddf_3180_before-768x404.jpg 768w, https://beforesandafters.com/wp-content/uploads/2021/09/ddf_3180_before-640x337.jpg 640w, https://beforesandafters.com/wp-content/uploads/2021/09/ddf_3180_before-949x500.jpg 949w" sizes="(max-width: 620px) 100vw, (max-width: 899px) 620px, 764px" /> <img data-attachment-id="71746" data-permalink="https://beforesandafters.com/2021/09/17/heres-what-went-into-the-visual-effects-of-shang-chis-crazy-bus-sequence-part-1/ddf3180_before-1037/" data-orig-file="https://beforesandafters.com/wp-content/uploads/2021/09/DDF3180_before.1037.jpg" data-orig-size="1200,502" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="DDF3180_before.1037" data-image-description="" data-image-caption="" data-medium-file="https://beforesandafters.com/wp-content/uploads/2021/09/DDF3180_before.1037-300x126.jpg" data-large-file="https://beforesandafters.com/wp-content/uploads/2021/09/DDF3180_before.1037-1024x428.jpg" loading="lazy" class="aligncenter size-full wp-image-71746" src="https://beforesandafters.com/wp-content/uploads/2021/09/DDF3180_before.1037.jpg" alt="" width="1200" height="502" srcset="https://beforesandafters.com/wp-content/uploads/2021/09/DDF3180_before.1037.jpg 1200w, https://beforesandafters.com/wp-content/uploads/2021/09/DDF3180_before.1037-300x126.jpg 300w, https://beforesandafters.com/wp-content/uploads/2021/09/DDF3180_before.1037-600x251.jpg 600w, https://beforesandafters.com/wp-content/uploads/2021/09/DDF3180_before.1037-1024x428.jpg 1024w, https://beforesandafters.com/wp-content/uploads/2021/09/DDF3180_before.1037-768x321.jpg 768w, https://beforesandafters.com/wp-content/uploads/2021/09/DDF3180_before.1037-640x268.jpg 640w, https://beforesandafters.com/wp-content/uploads/2021/09/DDF3180_before.1037-1000x418.jpg 1000w" sizes="(max-width: 620px) 100vw, (max-width: 899px) 620px, 764px" /></span></p>
<p>We developed a look with our FX supervisor and we were able to easily just spread it into hook sword scenes. But it&#8217;s still match-moving every single soldier and what they&#8217;re holding. It had to be way more accurate than another movie would allow for, because this needed to work in both the ‘real world’ and in the reflection as well. You can&#8217;t just cheat it in screen space, it has to physically be very accurate because otherwise in the reflection it&#8217;s going to be off.</p>
<p>In the other sequence we did where Shang-Chi&#8217;s fighting with Death Dealer, they had rubber knives or knives that were cut short. Those were replaced as well to give just an extra layer of danger to it.</p>
<a href="https://www.patreon.com/beforesandafters">Get bonus VFX content by supporting us on Patreon!</a>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>You might also like</em></h3>
</div>
		
	</div><!-- .entry-content -->

	<footer class="entry-footer">

		<span class="screen-reader-text">Tagged with: </span><span class="tags-links"><a href="https://beforesandafters.com/tag/ara-khanikian/" rel="tag">Ara Khanikian</a> <a href="https://beforesandafters.com/tag/rodeo-fx/" rel="tag">Rodeo FX</a> <a href="https://beforesandafters.com/tag/shang-chi-and-the-legend-of-the-ten-rings/" rel="tag">Shang-Chi and the Legend of the Ten Rings</a></span>
	</footer><!-- .entry-footer -->
</article><!-- #post-## -->
<aside>
	<div id="comments" class="comments-area  no-comments">
		<div class="comments-area-title">
			<h2 class="comments-title"><span class="comment-number  comment-number--dark  no-comments">i</span>There are no comments</h2>
			<a class="comments_add-comment" href="#reply-title">Add yours</a>		</div>
		
	</div>
	<!-- #comments .comments-area -->
	
	
		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">Leave a Reply					<small><a rel="nofollow" id="cancel-comment-reply-link" href="/2021/09/20/that-insane-shang-chi-bamboo-scaffolding-fight-featured-insane-roto-reflection-vfx-and-a-fully-cg-macau/#respond" style="display:none;">Cancel reply</a></small>
				</h3>
						<form id="commentform" class="comment-form">
				<iframe
					title="Comment Form"
					src="https://jetpack.wordpress.com/jetpack-comment/?blogid=154221204&#038;postid=71990&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=0&#038;avatar_default=identicon&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=10.1&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=3c9827cc8da92ef67a14e6b83ce323f86a62b3ac#parent=https%3A%2F%2Fbeforesandafters.com%2F2021%2F09%2F20%2Fthat-insane-shang-chi-bamboo-scaffolding-fight-featured-insane-roto-reflection-vfx-and-a-fully-cg-macau%2F"
											name="jetpack_remote_comment"
						style="width:100%; height: 430px; border:0;"
										class="jetpack_remote_comment"
					id="jetpack_remote_comment"
					sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups"
				>
									</iframe>
									<!--[if !IE]><!-->
					<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = false;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
					<!--<![endif]-->
							</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

		
</aside>
		</main><!-- #main -->
	</div><!-- #primary -->


<div id="secondary" class="sidebar" role="complementary">

	<aside id="custom_html-19" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div data-advadstrackid="71137" data-advadstrackbid="1" data-advadsredirect="" class="befor-target" id="befor-1536124196"><a href="https://quixel.com/megascans?utm_campaign=Publishers&#038;utm_source=beforesandafters.com&#038;utm_content=Marmot%20Sci-fi%20Junkyard%20-%20300x300" class="adv-link"><img loading="lazy" src="https://beforesandafters.com/wp-content/uploads/2021/09/Befores-and-Afters-Banner-Small-Box-300x300-1.png" alt=""  width="300" height="300"   /></a></div></div></aside>
		<aside id="recent-posts-42" class="widget widget_recent_entries">
		<h4 class="widget-title">Latest Posts</h4>
		<ul>
											<li>
					<a href="https://beforesandafters.com/2021/09/20/that-insane-shang-chi-bamboo-scaffolding-fight-featured-insane-roto-reflection-vfx-and-a-fully-cg-macau/" aria-current="page">That insane &#8216;Shang-Chi&#8217; bamboo scaffolding fight featured equally insane roto, reflection VFX and a fully CG Macau</a>
									</li>
											<li>
					<a href="https://beforesandafters.com/2021/09/20/the-secrets-behind-the-independence-day-cloud-tank-effects/">The secrets behind the &#8216;Independence Day&#8217; cloud tank effects</a>
									</li>
											<li>
					<a href="https://beforesandafters.com/2021/09/19/a-look-at-the-planning-previs-stuntvis-and-shooting-of-shang-chi/">A look at the planning, previs, stuntvis and shooting of &#8216;Shang-Chi&#8217;</a>
									</li>
											<li>
					<a href="https://beforesandafters.com/2021/09/17/heres-what-went-into-the-visual-effects-of-shang-chis-crazy-bus-sequence-part-1/">Here’s what went into the visual effects of ‘Shang-Chi’s’ crazy bus sequence: Part 1</a>
									</li>
											<li>
					<a href="https://beforesandafters.com/2021/09/17/watch-dnegs-star-trek-discovery-vfx-breakdown/">Watch DNEG&#8217;s Star Trek: Discovery VFX breakdown</a>
									</li>
					</ul>

		</aside><aside id="mc4wp_form_widget-12" class="widget widget_mc4wp_form_widget"><h4 class="widget-title">THE VFX MAILING LIST</h4><script>(function() {
	window.mc4wp = window.mc4wp || {
		listeners: [],
		forms: {
			on: function(evt, cb) {
				window.mc4wp.listeners.push(
					{
						event   : evt,
						callback: cb
					}
				);
			}
		}
	}
})();
</script><!-- Mailchimp for WordPress v4.8.6 - https://wordpress.org/plugins/mailchimp-for-wp/ --><form id="mc4wp-form-1" class="mc4wp-form mc4wp-form-258 mc4wp-form-theme mc4wp-form-theme-light" method="post" data-id="258" data-name="Befores &amp; Afters - The Newsletter" ><div class="mc4wp-form-fields"><label> </label>
	<input type="email" name="EMAIL" placeholder="Your email address" required />

<br>
    <input type="submit" value="Sign up">
</br>
</div><label style="display: none !important;">Leave this field empty if you're human: <input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off" /></label><input type="hidden" name="_mc4wp_timestamp" value="1632130703" /><input type="hidden" name="_mc4wp_form_id" value="258" /><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-1" /><div class="mc4wp-response"></div></form><!-- / Mailchimp for WordPress Plugin --></aside><aside class="widget befor-widget"><h4 class="widget-title">GET THE MAG</h4><div data-advadstrackid="71538" data-advadstrackbid="1" data-advadsredirect="" class="befor-target" id="befor-296995890"><a href="https://beforesandafters.com/shop/" class="adv-link"><img src="https://beforesandafters.com/wp-content/uploads/2021/09/Eo3FdegU8AAngHI-1.jpeg" alt=""  width="2048" height="1364"   /></a></div></aside>
</div><!-- #secondary -->		</div><!-- .container -->
	</div><!-- #content -->

	<footer id="colophon" class="site-footer" role="contentinfo">
		<div class="site-info c-footer__copyright-text">
&copy; 2021 befores &amp; afters.
</div><!-- .site-info
		--><div class="back-to-top-wrapper">
			<a href="#top" class="back-to-top-button"><svg width="10px" height="19px" viewBox="0 0 10 19" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink">
	<defs></defs>
	<g id="Page-1" stroke="none" stroke-width="1" fill="none" fill-rule="evenodd">
		<g>
			<rect id="bar" fill="#ffde00" x="0" y="0" width="10" height="3"></rect>
			<path d="M5,5.953125 L9,12 L1,12 L5,5.953125 Z M4,12 L6,12 L6,19 L4,19 L4,12 Z" id="arrow" fill="#FFFFFF"></path>
		</g>
	</g>
</svg>
</a>
		</div><!--
		--><nav class="footer-menu"><h5 class="screen-reader-text">Footer navigation</h5><ul id="menu-footer-menu" class="nav  nav--footer"><li id="menu-item-71307" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-71307"><a href="https://beforesandafters.com/about/">About</a></li>
<li id="menu-item-72041" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-72041"><a href="https://beforesandafters.com/contact/">Contact</a></li>
<li id="menu-item-71308" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-71308"><a href="https://beforesandafters.com/support/">Support us</a></li>
</ul></nav>	</footer><!-- #colophon -->
	<div class="overlay--search">
		<div class="overlay__wrapper">
			<form role="search" method="get" class="search-form" action="https://beforesandafters.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" title="Search for:" />
				</label>
				<button class="search-submit"><i class="fa fa-search"></i></button>
			</form>			<p>Begin typing your search above and press return to search. Press Esc to cancel.</p>
		</div>
		<b class="overlay__close"></b>
	</div>
</div><!-- #page -->

<div class="mobile-header">
	<div class="mobile-header-wrapper">
		<button class="navigation__trigger  js-nav-trigger">
			<i class="fa fa-bars"></i><span class="screen-reader-text">Menu</span>
		</button>
		<button class="nav__item--search  search__trigger">
			<i class="fa fa-search"></i>
		</button>
	</div>
</div>

<!--  -->
<script defer id='bilmur' data-provider='wordpress.com' data-service='atomic' src='https://s0.wp.com/wp-content/js/bilmur.min.js?m=202138'></script>
<div class="simple-banner simple-banner-text" style="display:none !important"></div>		<script type="text/javascript">
				</script>
	<script>(function() {function maybePrefixUrlField() {
	if (this.value.trim() !== '' && this.value.indexOf('http') !== 0) {
		this.value = "http://" + this.value;
	}
}

var urlFields = document.querySelectorAll('.mc4wp-form input[type="url"]');
if (urlFields) {
	for (var j=0; j < urlFields.length; j++) {
		urlFields[j].addEventListener('blur', maybePrefixUrlField);
	}
}
})();</script><script id="mcjs">!function(c,h,i,m,p){m=c.createElement(h),p=c.getElementsByTagName(h)[0],m.async=1,m.src=i,p.parentNode.insertBefore(m,p)}(document,"script","https://chimpstatic.com/mcjs-connected/js/users/fe63a873c305d7bd840d6d7bf/b4c6a8e923281a2171852ca33.js");</script>					<script>
						let customifyTriggerFontsLoadedEvents = function() {
							// Trigger the 'wf-active' event, just like Web Font Loader would do.
							window.dispatchEvent(new Event('wf-active'));
							// Add the 'wf-active' class on the html element, just like Web Font Loader would do.
							document.getElementsByTagName('html')[0].classList.add('wf-active');
						}

						// Try to use the modern FontFaceSet browser APIs.
						if ( typeof document.fonts !== 'undefined' && typeof document.fonts.ready !== 'undefined' ) {
							document.fonts.ready.then(customifyTriggerFontsLoadedEvents);
						} else {
							// Fallback to just waiting a little bit and then triggering the events for older browsers.
							window.addEventListener('load', function() {
								setTimeout( customifyTriggerFontsLoadedEvents, 300 );
							});
						}
					</script>
						<script type="text/javascript">
		(function () {
			var c = document.body.className;
			c = c.replace(/woocommerce-no-js/, 'woocommerce-js');
			document.body.className = c;
		})();
	</script>
			<div id="jp-carousel-loading-overlay">
			<div id="jp-carousel-loading-wrapper">
				<span id="jp-carousel-library-loading">&nbsp;</span>
			</div>
		</div>
		<div class="jp-carousel-overlay" style="display: none;">

		<div class="jp-carousel-container">
			<!-- The Carousel Swiper -->
			<div
				class="jp-carousel-wrap swiper-container jp-carousel-swiper-container jp-carousel-transitions"
				itemscope
				itemtype="https://schema.org/ImageGallery">
				<div class="jp-carousel swiper-wrapper"></div>
				<div class="jp-swiper-button-prev swiper-button-prev">
					<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
						<mask id="maskPrev" mask-type="alpha" maskUnits="userSpaceOnUse" x="8" y="6" width="9" height="12">
							<path d="M16.2072 16.59L11.6496 12L16.2072 7.41L14.8041 6L8.8335 12L14.8041 18L16.2072 16.59Z" fill="white"/>
						</mask>
						<g mask="url(#maskPrev)">
							<rect x="0.579102" width="23.8823" height="24" fill="#FFFFFF"/>
						</g>
					</svg>
				</div>
				<div class="jp-swiper-button-next swiper-button-next">
					<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
						<mask id="maskNext" mask-type="alpha" maskUnits="userSpaceOnUse" x="8" y="6" width="8" height="12">
							<path d="M8.59814 16.59L13.1557 12L8.59814 7.41L10.0012 6L15.9718 12L10.0012 18L8.59814 16.59Z" fill="white"/>
						</mask>
						<g mask="url(#maskNext)">
							<rect x="0.34375" width="23.8822" height="24" fill="#FFFFFF"/>
						</g>
					</svg>
				</div>
			</div>
			<!-- The main close buton -->
			<div class="jp-carousel-close-hint">
				<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
					<mask id="maskClose" mask-type="alpha" maskUnits="userSpaceOnUse" x="5" y="5" width="15" height="14">
						<path d="M19.3166 6.41L17.9135 5L12.3509 10.59L6.78834 5L5.38525 6.41L10.9478 12L5.38525 17.59L6.78834 19L12.3509 13.41L17.9135 19L19.3166 17.59L13.754 12L19.3166 6.41Z" fill="white"/>
					</mask>
					<g mask="url(#maskClose)">
						<rect x="0.409668" width="23.8823" height="24" fill="#FFFFFF"/>
					</g>
				</svg>
			</div>
			<!-- Image info, comments and meta -->
			<div class="jp-carousel-info">
				<div class="jp-carousel-info-footer">
					<div class="jp-carousel-pagination-container">
						<div class="jp-swiper-pagination swiper-pagination"></div>
						<div class="jp-carousel-pagination"></div>
					</div>
					<div class="jp-carousel-photo-title-container">
						<h2 class="jp-carousel-photo-caption"></h2>
					</div>
					<div class="jp-carousel-photo-icons-container">
						<a href="#" class="jp-carousel-icon-btn jp-carousel-icon-info" aria-label="Toggle photo metadata visibility">
							<span class="jp-carousel-icon">
								<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
									<mask id="maskInfo" mask-type="alpha" maskUnits="userSpaceOnUse" x="2" y="2" width="21" height="20">
										<path fill-rule="evenodd" clip-rule="evenodd" d="M12.7537 2C7.26076 2 2.80273 6.48 2.80273 12C2.80273 17.52 7.26076 22 12.7537 22C18.2466 22 22.7046 17.52 22.7046 12C22.7046 6.48 18.2466 2 12.7537 2ZM11.7586 7V9H13.7488V7H11.7586ZM11.7586 11V17H13.7488V11H11.7586ZM4.79292 12C4.79292 16.41 8.36531 20 12.7537 20C17.142 20 20.7144 16.41 20.7144 12C20.7144 7.59 17.142 4 12.7537 4C8.36531 4 4.79292 7.59 4.79292 12Z" fill="white"/>
									</mask>
									<g mask="url(#maskInfo)">
										<rect x="0.8125" width="23.8823" height="24" fill="#FFFFFF"/>
									</g>
								</svg>
							</span>
						</a>
												<a href="#" class="jp-carousel-icon-btn jp-carousel-icon-comments" aria-label="Toggle photo comments visibility">
							<span class="jp-carousel-icon">
								<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
									<mask id="maskComments" mask-type="alpha" maskUnits="userSpaceOnUse" x="2" y="2" width="21" height="20">
										<path fill-rule="evenodd" clip-rule="evenodd" d="M4.3271 2H20.2486C21.3432 2 22.2388 2.9 22.2388 4V16C22.2388 17.1 21.3432 18 20.2486 18H6.31729L2.33691 22V4C2.33691 2.9 3.2325 2 4.3271 2ZM6.31729 16H20.2486V4H4.3271V18L6.31729 16Z" fill="white"/>
									</mask>
									<g mask="url(#maskComments)">
										<rect x="0.34668" width="23.8823" height="24" fill="#FFFFFF"/>
									</g>
								</svg>

								<span class="jp-carousel-has-comments-indicator" aria-label="This image has comments."></span>
							</span>
						</a>
											</div>
				</div>
				<div class="jp-carousel-info-extra">
					<div class="jp-carousel-info-content-wrapper">
						<div class="jp-carousel-photo-title-container">
							<h2 class="jp-carousel-photo-title"></h2>
						</div>
						<div class="jp-carousel-comments-wrapper">
															<div id="jp-carousel-comments-loading">
									<span>Loading Comments...</span>
								</div>
								<div class="jp-carousel-comments"></div>
								<div id="jp-carousel-comment-form-container">
									<span id="jp-carousel-comment-form-spinner">&nbsp;</span>
									<div id="jp-carousel-comment-post-results"></div>
																														<form id="jp-carousel-comment-form">
												<label for="jp-carousel-comment-form-comment-field" class="screen-reader-text">Write a Comment...</label>
												<textarea
													name="comment"
													class="jp-carousel-comment-form-field jp-carousel-comment-form-textarea"
													id="jp-carousel-comment-form-comment-field"
													placeholder="Write a Comment..."
												></textarea>
												<div id="jp-carousel-comment-form-submit-and-info-wrapper">
													<div id="jp-carousel-comment-form-commenting-as">
																													<fieldset>
																<label for="jp-carousel-comment-form-email-field">Email (Required)</label>
																<input type="text" name="email" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-email-field" />
															</fieldset>
															<fieldset>
																<label for="jp-carousel-comment-form-author-field">Name (Required)</label>
																<input type="text" name="author" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-author-field" />
															</fieldset>
															<fieldset>
																<label for="jp-carousel-comment-form-url-field">Website</label>
																<input type="text" name="url" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-url-field" />
															</fieldset>
																											</div>
													<input
														type="submit"
														name="submit"
														class="jp-carousel-comment-form-button"
														id="jp-carousel-comment-form-button-submit"
														value="Post Comment" />
												</div>
											</form>
																											</div>
													</div>
						<div class="jp-carousel-image-meta">
							<div class="jp-carousel-title-and-caption">
								<div class="jp-carousel-photo-info">
									<h3 class="jp-carousel-caption" itemprop="caption description"></h3>
								</div>

								<div class="jp-carousel-photo-description"></div>
							</div>
							<ul class="jp-carousel-image-exif" style="display: none;"></ul>
							<a class="jp-carousel-image-download" target="_blank" style="display: none;">
								<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
									<mask id="mask0" mask-type="alpha" maskUnits="userSpaceOnUse" x="3" y="3" width="19" height="18">
										<path fill-rule="evenodd" clip-rule="evenodd" d="M5.84615 5V19H19.7775V12H21.7677V19C21.7677 20.1 20.8721 21 19.7775 21H5.84615C4.74159 21 3.85596 20.1 3.85596 19V5C3.85596 3.9 4.74159 3 5.84615 3H12.8118V5H5.84615ZM14.802 5V3H21.7677V10H19.7775V6.41L9.99569 16.24L8.59261 14.83L18.3744 5H14.802Z" fill="white"/>
									</mask>
									<g mask="url(#mask0)">
										<rect x="0.870605" width="23.8823" height="24" fill="#FFFFFF"/>
									</g>
								</svg>
								<span class="jp-carousel-download-text"></span>
							</a>
							<div class="jp-carousel-image-map" style="display: none;"></div>
						</div>
					</div>
				</div>
			</div>
		</div>

		</div>
		<script type='text/javascript' src='https://beforesandafters.com/wp-content/plugins/woocommerce/assets/js/jquery-blockui/jquery.blockUI.min.js?ver=2.7.0-wc.5.6.0' id='jquery-blockui-js'></script>
<script type='text/javascript' id='wc-add-to-cart-js-extra'>
/* <![CDATA[ */
var wc_add_to_cart_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","i18n_view_cart":"View cart","cart_url":"https:\/\/beforesandafters.com\/cart\/","is_cart":"","cart_redirect_after_add":"no"};
/* ]]> */
</script>
<script type='text/javascript' src='https://beforesandafters.com/wp-content/plugins/woocommerce/assets/js/frontend/add-to-cart.min.js?ver=5.6.0' id='wc-add-to-cart-js'></script>
<script type='text/javascript' src='https://beforesandafters.com/wp-content/plugins/woocommerce/assets/js/js-cookie/js.cookie.min.js?ver=2.1.4-wc.5.6.0' id='js-cookie-js'></script>
<script type='text/javascript' id='woocommerce-js-extra'>
/* <![CDATA[ */
var woocommerce_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%"};
/* ]]> */
</script>
<script type='text/javascript' src='https://beforesandafters.com/wp-content/plugins/woocommerce/assets/js/frontend/woocommerce.min.js?ver=5.6.0' id='woocommerce-js'></script>
<script type='text/javascript' id='wc-cart-fragments-js-extra'>
/* <![CDATA[ */
var wc_cart_fragments_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","cart_hash_key":"wc_cart_hash_362468ebb80e199104eac797bd4acff4","fragment_name":"wc_fragments_362468ebb80e199104eac797bd4acff4","request_timeout":"5000"};
/* ]]> */
</script>
<script type='text/javascript' src='https://beforesandafters.com/wp-content/plugins/woocommerce/assets/js/frontend/cart-fragments.min.js?ver=5.6.0' id='wc-cart-fragments-js'></script>
<script type='text/javascript' id='wc-cart-fragments-js-after'>
		jQuery( 'body' ).bind( 'wc_fragments_refreshed', function() {
			var jetpackLazyImagesLoadEvent;
			try {
				jetpackLazyImagesLoadEvent = new Event( 'jetpack-lazy-images-load', {
					bubbles: true,
					cancelable: true
				} );
			} catch ( e ) {
				jetpackLazyImagesLoadEvent = document.createEvent( 'Event' )
				jetpackLazyImagesLoadEvent.initEvent( 'jetpack-lazy-images-load', true, true );
			}
			jQuery( 'body' ).get( 0 ).dispatchEvent( jetpackLazyImagesLoadEvent );
		} );
		
</script>
<script type='text/javascript' id='ppcp-smart-button-js-extra'>
/* <![CDATA[ */
var PayPalCommerceGateway = {"script_attributes":{"data-partner-attribution-id":"Woo_PPCP"},"data_client_id":{"set_attribute":false,"endpoint":"https:\/\/beforesandafters.com\/?wc-ajax=ppc-data-client-id","nonce":"cda0a03973","user":0},"redirect":"https:\/\/beforesandafters.com\/checkout\/","context":"mini-cart","ajax":{"change_cart":{"endpoint":"https:\/\/beforesandafters.com\/?wc-ajax=ppc-change-cart","nonce":"b5c31ffcba"},"create_order":{"endpoint":"https:\/\/beforesandafters.com\/?wc-ajax=ppc-create-order","nonce":"b2556ae001"},"approve_order":{"endpoint":"https:\/\/beforesandafters.com\/?wc-ajax=ppc-approve-order","nonce":"009c9d55ec"}},"enforce_vault":"","save_card":"","bn_codes":{"checkout":"Woo_PPCP","cart":"Woo_PPCP","mini-cart":"Woo_PPCP","product":"Woo_PPCP"},"payer":null,"button":{"wrapper":"#ppc-button","mini_cart_wrapper":"#ppc-button-minicart","cancel_wrapper":"#ppcp-cancel","url":"https:\/\/www.paypal.com\/sdk\/js?client-id=AZ1bWE6uZdh9dAbydRSzXxjHG_CZeoa_eZuID-zCLpzS5a4jMK0rdo5kbDCacC6YfxZplF3hJD3YqgS2&currency=AUD&integration-date=2020-10-15&components=buttons,messages&vault=false&commit=false&intent=capture&disable-funding=card,credit&enable-funding=venmo","mini_cart_style":{"layout":"vertical","color":"gold","shape":"rect","label":"paypal","height":35},"style":{"layout":"vertical","color":"gold","shape":"rect","label":"paypal"}},"hosted_fields":{"wrapper":"#ppcp-hosted-fields","mini_cart_wrapper":"#ppcp-hosted-fields-mini-cart","labels":{"credit_card_number":"","cvv":"","mm_yy":"MM\/YY","fields_not_valid":"Unfortunately, your credit card details are not valid.","card_not_supported":"Unfortunately, we do not support your credit card."},"valid_cards":["mastercard","visa","master-card"]},"messages":[],"labels":{"error":{"generic":"Something went wrong. Please try again or choose another payment source."}},"order_id":"0","single_product_buttons_enabled":"1","mini_cart_buttons_enabled":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://beforesandafters.com/wp-content/plugins/woocommerce-paypal-payments/modules/ppcp-button//assets/js/button.js?ver=1.3.2' id='ppcp-smart-button-js'></script>
<script type='text/javascript' id='mailchimp-woocommerce-js-extra'>
/* <![CDATA[ */
var mailchimp_public_data = {"site_url":"https:\/\/beforesandafters.com","ajax_url":"https:\/\/beforesandafters.com\/wp-admin\/admin-ajax.php","language":"en","allowed_to_set_cookies":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://beforesandafters.com/wp-content/plugins/mailchimp-for-woocommerce/public/js/mailchimp-woocommerce-public.min.js?ver=2.5.2' id='mailchimp-woocommerce-js'></script>
<script type='text/javascript' src='https://beforesandafters.com/wp-includes/js/imagesloaded.min.js?ver=4.1.4' id='imagesloaded-js'></script>
<script type='text/javascript' src='https://beforesandafters.com/wp-includes/js/masonry.min.js?ver=4.2.2' id='masonry-js'></script>
<script type='text/javascript' src='https://beforesandafters.com/wp-content/themes/patch/assets/js/velocity.js?ver=1.2.2' id='velocity-js'></script>
<script type='text/javascript' src='https://beforesandafters.com/wp-content/themes/patch/assets/js/magnificpopup.js?ver=1.0.0' id='magnificpopup-js'></script>
<script type='text/javascript' src='https://beforesandafters.com/wp-content/themes/patch/assets/js/main.js?ver=1.3.4' id='patch-scripts-js'></script>
<script type='text/javascript' src='https://beforesandafters.com/wp-includes/js/comment-reply.min.js?ver=5.8.1' id='comment-reply-js'></script>
<script type='text/javascript' src='https://beforesandafters.com/wp-content/plugins/jetpack/_inc/build/postmessage.min.js?ver=10.1' id='postmessage-js'></script>
<script type='text/javascript' src='https://beforesandafters.com/wp-content/plugins/jetpack/_inc/build/jquery.jetpack-resize.min.js?ver=10.1' id='jetpack_resize-js'></script>
<script type='text/javascript' src='https://beforesandafters.com/wp-content/plugins/jetpack/modules/likes/queuehandler.js?ver=10.1' id='jetpack_likes_queuehandler-js'></script>
<script type='text/javascript' id='advadsTrackingScript-js-extra'>
/* <![CDATA[ */
var advadsTracking = {"impressionActionName":"aatrack-records","clickActionName":"aatrack-click","targetClass":"befor-target","blogId":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://beforesandafters.com/wp-content/plugins/advanced-ads-tracking/public/assets/js/dist/tracking.min.js?ver=2.1.2' id='advadsTrackingScript-js'></script>
<script type='text/javascript' src='https://beforesandafters.com/wp-content/plugins/visual-footer-credit-remover/script.js?ver=5.8.1' id='jabvfcr_script-js'></script>
<script type='text/javascript' src='https://beforesandafters.com/wp-content/plugins/woo-product-gallery-slider/assets/js/slick.min.js?ver=2.1.3' id='slick-js'></script>
<script type='text/javascript' src='https://beforesandafters.com/wp-content/plugins/woo-product-gallery-slider/assets/js/jquery.fancybox.min.js?ver=2.1.3' id='fancybox-js'></script>
<script type='text/javascript' src='https://beforesandafters.com/wp-content/plugins/woo-product-gallery-slider/assets/js/wpgs.js?ver=2.1.3' id='wpgsjs-js'></script>
<script type='text/javascript' id='wpgsjs-js-after'>
jQuery(document).ready(function(){
        jQuery('.wpgs-for').slick({
            slidesToShow:1,
            slidesToScroll:1,
            arrows:true,
            fade:false,
            rtl: false,
            infinite:true,
            adaptiveHeight:true,
            autoplay:false,
            draggable:false,
           nextArrow:'<i class="flaticon-right-arrow"></i>', 
            prevArrow:'<i class="flaticon-back"></i>',       
            asNavFor:'.wpgs-nav',
          
        });
        jQuery('.wpgs-nav').slick({
            slidesToShow:4,
            slidesToScroll:1,
            asNavFor:'.wpgs-for',
            arrows:true,
            rtl: false,
            infinite:true,
            focusOnSelect:true,
            responsive:[{
                breakpoint:767,
                settings:{
                    slidesToShow:3,
                    slidesToScroll:1,
                    draggable:true,
                    autoplay:false,
                    arrows:true
                }
            }],
        });

        
        

      });
</script>
<script type='text/javascript' src='https://beforesandafters.com/wp-includes/js/wp-embed.min.js?ver=5.8.1' id='wp-embed-js'></script>
<script type='text/javascript' src='https://beforesandafters.com/wp-content/plugins/jetpack/modules/theme-tools/responsive-videos/responsive-videos.min.js?ver=1.3' id='jetpack-responsive-videos-min-script-js'></script>
<script type='text/javascript' id='jetpack-carousel-js-extra'>
/* <![CDATA[ */
var jetpackSwiperLibraryPath = {"url":"https:\/\/beforesandafters.com\/wp-content\/plugins\/jetpack\/_inc\/build\/carousel\/swiper-bundle.min.js"};
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/beforesandafters.com\/wp-admin\/admin-ajax.php","nonce":"7946446605","display_exif":"1","display_comments":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/beforesandafters.com\/wp-login.php?redirect_to=https%3A%2F%2Fbeforesandafters.com%2F2021%2F09%2F20%2Fthat-insane-shang-chi-bamboo-scaffolding-fight-featured-insane-roto-reflection-vfx-and-a-fully-cg-macau%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"]};
/* ]]> */
</script>
<script type='text/javascript' src='https://beforesandafters.com/wp-content/plugins/jetpack/_inc/build/carousel/jetpack-carousel.min.js?ver=10.1' id='jetpack-carousel-js'></script>
<script defer type='text/javascript' src='https://beforesandafters.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.12' id='akismet-form-js'></script>
<script type='text/javascript' defer src='https://beforesandafters.com/wp-content/plugins/mailchimp-for-wp/assets/js/forms.js?ver=4.8.6' id='mc4wp-forms-api-js'></script>
<script>!function(){window.advanced_ads_ready_queue=window.advanced_ads_ready_queue||[],advanced_ads_ready_queue.push=window.advanced_ads_ready;for(var d=0,a=advanced_ads_ready_queue.length;d<a;d++)advanced_ads_ready(advanced_ads_ready_queue[d])}();</script>
		<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
		<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=154221204&postid=71990&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=0&avatar_default=identicon&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=10.1&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=3c9827cc8da92ef67a14e6b83ce323f86a62b3ac#parent=https%3A%2F%2Fbeforesandafters.com%2F2021%2F09%2F20%2Fthat-insane-shang-chi-bamboo-scaffolding-fight-featured-insane-roto-reflection-vfx-and-a-fully-cg-macau%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=154221204&postid=71990&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=0&avatar_default=identicon&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=10.1&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=3c9827cc8da92ef67a14e6b83ce323f86a62b3ac#parent=https%3A%2F%2Fbeforesandafters.com%2F2021%2F09%2F20%2Fthat-insane-shang-chi-bamboo-scaffolding-fight-featured-insane-roto-reflection-vfx-and-a-fully-cg-macau%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								frame.style.height = event.data + 'px';
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								frame.style.height = event.data + 'px';
							});
						}
					}
				})

			})();
		</script>

		<script src='https://stats.wp.com/e-202138.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.1',blog:'154221204',post:'71990',tz:'10',srv:'beforesandafters.com'} ]);
	_stq.push([ 'clickTrackerInit', '154221204', '71990' ]);
</script>
<script id="befor-tracking">var advads_tracking_ads = {"1":[71137,71538]};var advads_tracking_urls = {"1":"https:\/\/beforesandafters.com\/wp-content\/ajax-handler.php"};var advads_tracking_methods = {"1":"frontend"};var advads_tracking_parallel = {"1":false};var advads_tracking_linkbases = {"1":"https:\/\/beforesandafters.com\/linkout\/"};</script>
</body>
</html>